Viewer is a single "command center" used by a support technician/admin. The Viewer is where you keep your connection list, start a remote session and manage your licenses. The built-in tools such as Remote Install, MSI Configurator, Host Scanner, Address Book Manager and License Key Storage are all launched from within the Viewer.

Viewer runs in a trial mode for 30 days until you add a valid license or until the trial period ends. Learn more about registration.


You can run a portable version of the Viewer from a USB stick. This version doesn't require installation. Download the portable Viewer from the download page.

Main window

Main Viewer window

The main window has the following parts:

  • 1 Ribbon toolbar This toolbar contains all the program commands spread across five tabs.
  • 2 Groups pane Connection entries can be grouped into folders shown on the Groups pane. If the Viewer PC is located in an Active Directory network, the Groups pane automatically retrieves the AD tree.
  • 3 Contents pane The contents of the folder selected in the tree is shown here. The Groups pane and the Contents pane together constitute what is called an address book
  • 4 Status bar This bar shows preview information about the objects selected in the Contents pane.

General tab

Viewer with General tab open
  • Add Computer Click to add a new connection to the address book
  • Connection mode buttons Used to start a remote session in one of the available connection modes

Connection tab

Viewer with Connection tab open
  • Add Computer Click to add a new connection to the address book
  • Add using code Paste a special code to add remote computer's ID and password from an e-mail message
  • Delete Delete selected connection
  • Rename Rename selected connection
  • Logon Get into the logged on state
  • Logoff Exit the logged on state
  • Refresh status Refresh status of visible connections
  • Relogon connections Relogon visible connections
  • Ping Ping visible connections
  • Wake on LAN Invoke WOL command for a selected connection

View tab

Viewer with View tab open
  • Update previews Update thumbnail previews
  • Show groups Show/hide the Groups pane
  • Show event log Open the Connection Log panel
  • Reset panels Reset panels to default layout
  • Thumbnails Switch to thumbnail view (in this view remote screen previews are shown as thumbnails)
  • Large icons Switch to large icons view
  • List Switch to list view
  • Details Switch to list view with details shown for every connection record
  • Change preview size Use the slider to change the visible size of previews in the Thumbnail view

Tools tab

Viewer with Tools tab open
  • Options Open Viewer's global options
  • Default connection properties Set default properties for all newly-created remote connections
  • Language Select program language
  • Address book manager Open the Address Book Manager
  • Import connections Import connections from an external address book
  • Export connections Export connections to an xml file

Help tab

Viewer with Help tab open
  • RU help This documentation
  • License Key Storage Run the License Key Storage tool
  • Purchase Enterprise Key Purchase a commercial license
  • Get License Key for Free Get a free license key for 10 PC for business and personal use
  • Remote Utilities on the Web Visit program website
  • Check for updates Check for new versions of Remote Utilities
  • About Remote Utilities Show details about the program copy currently installed