Community

Viewer for Mac and Linux - Beta testing

Page:
Links used in this discussion

Nijel Terry, User (Posts: 28)

Aug 31, 2020 6:33:52 pm EDT

Polina Krasnoborceva wrote:

Could you please clarify what version of Remote Utilities Host is used on the remote machine? In case if you use version 6.10.10.0, please try updating your remote Host to the latest 6.12 Beta 2 version - there was a similar issue in the previous versions of Remote Utilities with some keys not working on a remote computer in some circumstances, which was fixed in the most recent Beta version releases.
The 6.12 Beta 2 version is available for the download on this page.

Hi Polina,

Thank you for the advice.  I was using the latest stable host v6.10.10.0 on the computer I was testing connecting to with the linux viewer.  I installed 6.12 Beta 2 host and the typing problem seems to be resolved now.

I tried opening the viewer using the terminal and can see there is a lot of output of what the viewer is doing in the terminal.  I was unable to reproduce the crash but I will keep launching viewer from linux terminal each time I use it & will hopefully have something to share soon.

Best,
Nijel

Polina, Support (Posts: 1103)

Sep 01, 2020 9:41:50 am EDT

Hello Nijel,

I installed 6.12 Beta 2 host and the typing problem seems to be resolved now.

I'm glad to hear that we were able to help and it works for you now!

I was unable to reproduce the crash but I will keep launching viewer from linux terminal each time I use it & will hopefully have something to share soon.

In case if you will be able to reproduce the issue once again, please feel free to send us the terminal output. You can send it to support@remoteutilities.com or create a ticket and attach the file to the ticket.

Please let us know if you have more questions.

Yann Liebaert, User (Posts: 2)

Sep 08, 2020 6:00:45 am EDT

Support level: Free or trial
Hi,

I just installed the latest viewer version on a Mac running 10.15.6. I have a host installed on a Win 10 machine. In the viewer, 'update required' was showing Yes. I therefore upgraded from the 6.10.10 version to the beta 6.12.2b2, but it still shows 'Upgrade required'.

I also lost connection during the update, and had to complete it manually on the remote machine.

Polina, Support (Posts: 1103)

Sep 08, 2020 4:17:23 pm EDT

Hello Yann,

Thank you for your message.

I therefore upgraded from the 6.10.10 version to the beta 6.12.2b2, but it still shows 'Upgrade required'.

This is actually expected behavior as it is a newer beta version of Remote Utilities. In our future updates, we'll make the program update Hosts' version information immediately during the online status check without the user having to log in on the Hosts at all. Could you please let me know if you've logged on to the remote Host after updating it?

I also lost connection during the update and had to complete it manually on the remote machine.

Perhaps, the disconnect occurred due to the remote Host service being restarted after the update (which is required). Could you please confirm if you've waited for approximately 10-15 seconds for the remote Host service to restart before trying to reconnect to the Host?

Looking forward to your reply.

Yann Lieb, User (Posts: 2)

Sep 09, 2020 5:37:36 am EDT

Support level: Free or trial
Hi Polina,

Viewer is still listing the host version 6.12.2 (69220) as 'YES' in update required column

I face some disconnections after a bit of inactivity on the host (I connect through Internet-ID not direct IP, I'm on the same local network). It happened several times that when re-connecting I had some crashes from the viewer.

Polina, Support (Posts: 1103)

Sep 09, 2020 2:38:01 pm EDT

Hello Yann,

Thank you for your message.

I checked with our developers and they confirmed that the "update is required"  displaying in Viewer for the latest 6.12 Beta 2 version is expected behavior. Sorry for the inconvenience.

I face some disconnections after a bit of inactivity on the host (I connect through Internet-ID not direct IP, I'm on the same local network). It happened several times that when re-connecting I had some crashes from the viewer.

In case if your Viewer and Host are on the same LAN, then please note that it's recommended to use Direct connection as it's always more stable and faster than the Internet-ID connection. In addition, please note that even if you use Internet-ID connection, but there's a direct route available between Viewer and Host then it will be used automatically because of the direct route detection mechanism implemented in the program.
As for the disconnects please try referring to this troubleshooting guide to see if any of the solutions listed there help to resolve the issue. Namely, we'd recommend that you check if there is any antivirus/firewall software installed on the remote Host machine that might be blocking ports/Remote Utilities. If this might be the case, then please try whitelisting Remote Utilities as described in this guide.
In addition, in case if the solutions above did not help, please feel free to send us Host connection log files for examination. You can send the logs to support@remoteutilities.com.

Hope that helps.

abduraman, User (Posts: 2)

Sep 25, 2020 5:48:34 pm EDT

Support level: Free or trial
Hi,

I have a PC on which Windows 10 is installed. I do not have admin rights on that PC. So I installed RemoteUtilities host without admin rights. If it is unlocked, I can connect to it and use keyboard&mouse. Otherwise (i.e. it is locked), I can connect but I cannot pass the background image. In other words, user and password boxes do not appear. I tried to send Ctrl+Alt+Del, to press Space key and some nonsense things :) but no way. Could you help me? Thanks.

P.S.: I use both iOS and MacOS viewers. Both are same.
Edited:abduraman - Sep 25, 2020 5:49:25 pm EDT

Polina, Support (Posts: 1103)

Sep 28, 2020 1:20:31 pm EDT

Hello,

Thank you for your message.

I do not have admin rights on that PC. So I installed RemoteUtilities host without admin rights.

Could you please clarify if you mean Agent? If this is the case, then could you please clarify if you mean that you cannot log in to a Windows user when connecting to the locked remote machine?
If this is the case, then please note that this is not how the Agent is supposed to be used - in the described scenario, the Host module should be used instead (however, please note that administrative privileges are required in order to install the Host).

Hope that helps.

abduraman, User (Posts: 2)

Sep 28, 2020 5:54:04 pm EDT

Support level: Free or trial

Polina Krasnoborceva wrote:

the Host module should be used instead (however, please note that administrative privileges are required in order to install the Host).

I run Host module on Windows 10 PC. Yes, without admin rights. I can connect to it via iOS/MacOS viewers (i.e. Agent module). The problem is not there. As I described, if Windows PC is in unlocked state, I can work normally. However, if Windows PC is in locked state, I can still connect but I cannot log into Windows since the password box does not appear in the remote PC. Just background image. I send Ctrl+Alt+Del or any key combinations but no way. I click the mouse but no way. To sum, there is no problem with the connection. The problem is that the password textbox does not appear in the remote PC if it is in locked state. So, I cannot log into the remote PC.

Polina, Support (Posts: 1103)

Sep 29, 2020 10:37:44 am EDT

Hello,

Thank you for your message.

I've checked on this with our development department just in case - unfortunately, not proceeding to the screen with the password field is expected behavior. You can only log in to a locked Windows user when using Host, it wouldn't work for the Agent module as it's meant to be used for spontaneous remote support and can be run by a standard Windows user.

Sorry for the inconvenience.
Page:

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.