Community

RU Server IPv6 support

Links used in this discussion

tudne, User (Posts: 2)

Feb 04, 2020 11:51:02 am EST

Support level: Free or trial
This is machine translation
The InternetIdService.exe program does not listen on the IPv6 port, and IPv6 cannot connect to the server. Please solve this problem. I have downloaded server2.9.b1.exe but the same.

Polina Krasnoborceva, Support (Posts: 958)

Feb 04, 2020 3:55:51 pm EST

Hello,

Thank you for your message.

Could you please confirm if I'm right in assuming that you use the self-hosted RU Server? If this is the case, please double-check if you have the Use IPv6 checkbox enabled in Settings for Host:
1. Right-click on the Host icon in the system tray and select Settings for Host...
2. While on the Dashboard tab click the Configure button in the Internet-ID connection section. Select Advanced -> Select Internet-ID Server

In the opened window please check if you have the Use IPv6 checkbox selected and if there's a correct port number specified:


Also please check if you have the ports you want to use added in the RU Server's Configuration window -> Communication tab:


In addition, please check if the Use IPv6 checkbox is selected and the correct ports are added on the Viewer's side, namely in the Server manager window:


Hope that helps.

tudne, User (Posts: 2)

Feb 04, 2020 11:42:39 pm EST

Support level: Free or trial
This is machine translation
I checked IPv6 as you said, and connected with IPv6 address, but the connection was unavailable.
You can connect with IPv6 address or AAAA domain name, I don't know what is wrong.

Rutview uses IPv6 to connect to the server, it crashes, and there is no information about failure.

Polina Krasnoborceva, Support (Posts: 958)

Feb 05, 2020 11:23:26 am EST

Hello,

Thank you for the clarification.

Could you please send us the log files for examination? Here is how to locate the Host logs, the Viewer logs and the Server connection logs.
You can send them to support@remote-utilities.com

Also on the screenshots above, I can see that the Host's status is Connection not available that could point to some connectivity issues, i.e. that the Host cannot connect to the self-hosted relay server. In the meantime, please also try referring to this troubleshooting KB article and see if any of the solutions listed there help to resolve the issue.

In addition, please note that we highly recommend that you obtain and use a DNS name as the server address instead of using an IP address.

Looking forward to your reply.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.