Community

WIndows Version: All computers showing OFFLINE however are all still accessible.

Page:
Links used in this discussion

John Wilson, User (Posts: 7)

Mar 28, 2017 4:06:23 pm EDT

Support level: Free or trial
Conrad, I updated the private server to 2.6.03 and everything seems to be working now!  Both public and private show correct On/Offline status, and I can log-in to the private server.  For a while, I still had the invalid user error when trying to sign in from the viewer.  I eventually had to delete the user from the server admin console and then re-add it and then it started working.

Thanks for you help,
John

Conrad, Administrator (Posts: 2556)

Mar 28, 2017 4:50:25 pm EDT

Hi John,

I'm glad it works for you! Now keep an eye on antivirus software - they like to target newly released versions with their "detections". If you have any antivirus program installed on remote PCs you might want to check if Host is added to exceptions there.

Thanks.

Like Remote Utilities? Write a review

Hans Lackermeier, User (Posts: 2)

May 07, 2017 5:37:00 am EDT

Support level: Free or trial
Hello,
I do have similar problems since V6 although using actual Versions 6.07 for hosts and viewer and 603 for private server.
For example the host is online and also online is shown in viewer but if connecting it switches to offline although being physical online. Or it is showing offline but if connecting it jumps to online.
I do have many interruptions while working on hosts, if connecting again it takes 2 or more trials to get connection again.
In viewers Log I have many errors like
CheckID Connection. After process message. Host "xy:55655". MsgCode: 10
or socket errors like "EIdConnClosedGracefully".

So I seem to be the only one with this troubles, can you help me to find a solution?

best regards
Hans

Conrad, Administrator (Posts: 2556)

May 07, 2017 6:11:53 am EDT

Hello Hans,

Thank you for your message.

I do have similar problems since V6 although using actual Versions 6.07 for hosts and viewer and 603 for private server.

The server has its own version numbering. A new server release does not necessarily happen with each RU release. Currently, the latest server version is 2.6.0.3. If that's what you mean, then yes, it's the latest version.

For example the host is online and also online is shown in viewer but if connecting it switches to offline although being physical online. Or it is showing offline but if connecting it jumps to online.

During logging in a connection may briefly show as offline , but that doesn't actually mean that it's offline.

I do have many interruptions while working on hosts, if connecting again it takes 2 or more trials to get connection again.
In viewers Log I have many errors like
CheckID Connection. After process message. Host "xy:55655". MsgCode: 10
or socket errors like "EIdConnClosedGracefully".

If this happens with all your hosts, then probably it's not a problem with the Hosts. It could be a network issue either on the server side or the Viewer side.

To start with, could you send us logs from a few of your Hosts, especially from those you had connection issues with. We'll see if Hosts had any difficulty connecting to your server.

You can use the email support@remote-utilities.com to send the logs.

Like Remote Utilities? Write a review

Hans Lackermeier, User (Posts: 2)

May 08, 2017 6:51:37 pm EDT

Support level: Free or trial
Hello,
just have sent you a viewers and a host protocol

best regards
Hans

Conrad, Administrator (Posts: 2556)

May 09, 2017 1:02:09 pm EDT

Hello Hans,

Thank you. There is nothing special in the Host log except that connection times out several times, perhaps because of brief network interruptions on either the Host or the Server side. If you experience this different Hosts that poor network connectivity on the Server side my be the reason.

On your server PC you can run ping <some internet address> -t  command for some time and see if there are any lost packets.

Like Remote Utilities? Write a review

Halen Rodrigues, User (Posts: 1)

Jul 22, 2020 12:00:46 pm EDT

Conrad wrote:

Hello Hans,

Thank you for your message.

I do have similar problems since V6 although using actual Versions 6.07 for hosts and viewer and 603 for private server.

The server has its own version numbering. A new server release does not necessarily happen with each RU release. Currently, the latest server version is 2.6.0.3. If that's what you mean, then yes, it's the latest version.

For example the host is online and also online is shown in viewer but if connecting it switches to offline although being physical online. Or it is showing offline but if connecting it jumps to online.

During logging in a connection may briefly show as offline , but that doesn't actually mean that it's offline.

I do have many interruptions while working on hosts, if connecting again it takes 2 or more trials to get connection again.
In viewers Log I have many errors like
CheckID Connection. After process message. Host "xy:55655". MsgCode: 10
or socket errors like "EIdConnClosedGracefully".  

If this happens with all your hosts, then probably it's not a problem with the Hosts. It could be a network issue either on the server side or the Viewer side.

To start with, could you send us logs from a few of your Hosts, especially from those you had connection issues with. We'll see if Hosts had any difficulty connecting to your server.

You can use the email support@remote-utilities.com to send the logs.

I´m having the same issue: (Viewer 6.10.10.0; Server 2.8)
Viewer log:
22-07-2020__13:43:22__253 CheckID Connection. Connecting...: "myRUServer:5655".
22-07-2020__13:43:22__409 CheckID Connection. Connected...: "myRUServer:5655".
22-07-2020__13:43:22__425 CheckID Connection. Request MsgTransportThread.Send. Host: "myRUServer:5655".
22-07-2020__13:43:22__659 CheckID Connection. After process message. Host "myRUServer:5655". MsgCode: 10
22-07-2020__13:43:22__831 CheckID Connection. Exit: "myRUServer:5655".

Note that:
- Ping from Viewer to myRUServer responses are ok, no packet losses;
- MiniInternetIdService is up (started) running as Local System;
- I can reach port 5655 through telnet client, so network pass is ok;
- AddressBook is upd ated upon connection to Ru Server;

And another issue is that Viewer is trying to reach a cloud ID server, althoungh my 'Default connection properties' are se t to:
- Authorization->Authorization method: Custom security server;
- Internet-ID: Internet-ID Server: server: myRUServer [5655]

Viewer, server and Host, has no access to internet, so I got errors logged on the Viewer:
22-07-2020__13:43:22__253 CheckID Connection. Connecting...: "id.remoteutilities.com:5655".
22-07-2020__13:43:23__378 CheckID Connection to internet-id error. Host: "id.remoteutilities.com:5655". Exception class: "EIdSocketError". Message: "Socket Error # 10061
Connection refused.".
22-07-2020__13:43:24__479 CheckID Connection to internet-id error. Host: "id.remoteutilities.com:443". Exception class: "EIdSocketError". Message: "Socket Error # 10061
Connection refused.".
22-07-2020__13:43:24__479 CheckID Connection to internet-id error. Host: "id.remoteutilities.com:443". Exception class: "EIdSocketError". Message: "Socket Error # 10061
Connection refused.".
22-07-2020__13:43:24__479 CheckID Connection. Exit: "id.remoteutilities.com:443".

Polina Krasnoborceva, Support (Posts: 967)

Jul 22, 2020 6:21:53 pm EDT

Hello Halen,

Thank you for your message.

Host: "id.remoteutilities.com:5655". Exception class: "EIdSocketError". Message: "Socket Error # 10061
Connection refused.".
22-07-2020__13:43:24__479 CheckID Connection to internet-id error. Host: "id.remoteutilities.com:443". Exception class: "EIdSocketError". Message: "Socket Error # 10061
Connection refused.".

Please note that these entries in your log files point to the fact that the Host is trying to connect to our public Internet-ID servers instead of your custom self-hosted RU Server. Please double-check that you've configured both Host and Viewer to connect to the custom RU Server as described in this tutorial. Namely, please double-check the following:
1) Your custom server's address is specified in the Host settings -> Internet-ID settings and your settings look similar to the screenshot below:


2) The custom server's address is specified in Viewer, in the Connection properties for this specific Host (as the Default connection properties dialog is rather a global setting that applies to all newly added connections, which might have been specified after this specific Host was added to your address book):


In addition, please note that the attached log contains the following error: Socket Error # 10061
Connection refused
. According to the Windows Sockets Error Codes, this error means that no connection could be made because the target computer actively refused it, i.e. that Host has issues connecting to your server. Please, double-check that you use the correct IP address or DNS name and that (if it's a DNS name) the IP address is resolved properly from your DNS name. In addition please also check if any security software is blocking the connection on either side.

Finally, in case if everything is set up correctly but the issue persists, please try updating your Remote Utilities installation to the latest 6.12 Beta 2 version (2.9.5.0 Beta 2 for the RU Server). In this release, we have implemented multiple fixes and improvements for the RU Server, including improved background signing in on a self-hosted server and automatic reconnects to the server when connection is interrupted. The full list of Release notes is available on this page.
6.12 Beta 2 version of Host/Viewer and 2.9.5.0 Beta 2 version for the RU Server are available on for the download on this page.
When updating Remote Utilities please make sure to update all modules - Host, Viewer, and RU Server as the version mismatch might lead to performance issues or some features not working.

Hope that helps.
Page:

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.