Community

Host 6.10.9 service needs to be started manually at every boot

Links used in this discussion

Black Frank, User (Posts: 2)

May 02, 2019 7:49:01 am EDT

> Windows Server 2019 Datacenter ( Fully updated )
> Host 6.10.9
> Viewer 6.10.9 ( all of them )

Hi everyone!!! Hope everything's fine!!!

As the title says, I need to start the service manually at every system startup. I've reinstalled the host a few times and nothing changes. I used both the executable and the msi version.
I even tried manually inserting the service initialization in the task scheduler.... no luck either.

Sorry for double post it...

Conrad Sallian, Support (Posts: 2371)

May 02, 2019 8:13:11 am EDT

Hello Black Frank,

Thank you for your message.

How exactly do you start the Host service?

Black Frank, User (Posts: 2)

May 02, 2019 12:45:10 pm EDT

Conrad Sallian wrote:

Hello Black Frank,

Thank you for your message.

How exactly do you start the Host service?

Right-click on Start button > run > services.msc... Right click Host service > start.

I forgot to mention in my previous post: host service = automatic. I can log off any account after that it remains functional... but if the system is shut down or restarted, it is necessary to restart the service manually.
Edited:Black Frank - May 02, 2019 12:48:04 pm EDT

Conrad Sallian, Support (Posts: 2371)

May 03, 2019 12:41:26 pm EDT

Hello,

We recommend that you start the Host using Windows Start menu -> Remote Utilities - Host -> Start Host.

Make sure that you have service state set to "auto" in Host settings:



Finally, you are not supposed to run the Host service manually if that settings is "auto". If the Host service does not start you should find the reason why. Usually it is security/antivirus software activity that may lead to such behavior.

Hope that helps.

Nijel Terry, User (Posts: 22)

May 06, 2019 3:04:22 am EDT

Is there a way to use the Task Scheduler to auto start the host? I thought I saw a guide to do that somewhere & I can't find it now.  I'm having problems with a client's host not starting now after a W10 upgrade.  Tried reinstalling the latest host version & verifying service is set to auto on the admin account.  Also sometimes when doing a simple upgrade the host fails to start afterwards & requires manually starting the host. If there was a way to Task Schedule host to automatically start if crashed that would help. I never upgrade a client now unless I'm connected on my other remote program in case I lose the host during upgrade.

Polina Krasnoborceva, Support (Posts: 362)

May 06, 2019 2:06:00 pm EDT

Hello Nijel,

Thank you for your message.

Is there a way to use the Task Scheduler to auto start the host? I thought I saw a guide to do that somewhere & I can't find it now. I'm having problems with a client's host not starting now after a W10 upgrade.

If the startup mode is set to Auto, the Host service starts automatically. If the service doesn't start, there might be an issue caused by the antivirus/security software. Please try completely uninstalling the Host and then install it from scratch as described here: https://www.remoteutilities.com/support/docs/installing-and-uninstalling/#Uninstalling_Host.
I also highly recommend that you add the Host installation folder to antivirus software exceptions list to avoid future problems in this regard.
Please let us know if the problem persists.

Also sometimes when doing a simple upgrade the host fails to start afterwards & requires manually starting the host.

This is a known issue and it was fixed in the version 6.10.8.0.
This is not an issue specifically with the simple update. For some reason, Windows Restart Manager (which may act as part of the msi installation procedure) failed to restart Remote Utilities Host service after the update.
We decided to completely re-write the update process and we implemented this change in the previous version (6.10.8.0).  

This fix has one downside - unfortunately, it does not work retrospectively. The new process applies when updating Hosts version 6.10.8.0 (i.e. the previous version) and later.

When updating older versions, you can use the Remote Install tool as a workaround and an alternative to simple update. In this tool, the upgrade process uses a slightly different approach, so it should help to override the problem with the restart manager. You will need a Host msi installer to "feed" into the tool. You can download it here https://www.remoteutilities.com/download/host6.10.msi

Hope that helps.

Alex Mendez, User (Posts: 2)

May 24, 2019 7:20:07 pm EDT

Como estas amigo, lograstes solventar el problema, yo tengo el mismo problema en 4 pc del mismo modelo, podrias ayudarme...

Polina Krasnoborceva, Support (Posts: 362)

May 27, 2019 6:40:09 pm EDT

Hello Alex,

Thank you for your message.

Please check if the service startup mode is set to Auto in Host settings as it's shown on the screenshot:

If it is set to Auto and the service doesn't start, there might be an issue caused by an antivirus/security software.
Please try completely uninstalling the Host and then install it from scratch. Here's a related Documentation guide that might be helpful: https://www.remoteutilities.com/support/docs/installing-and-uninstalling/#Uninstalling_Host.

In addition, please add the Host installation folder to antivirus software exceptions list after the installation is completed.

Hope that helps.

Alex Mendez, User (Posts: 2)

May 28, 2019 7:08:58 pm EDT

Hello Polina,

I have already done the agent's uninstallation, and I have also excluded the installation folder of my antivirus scan, however, they are only some computers where the agent does not work well, the only common factor of these devices is that they are HP brand and have windows 10, my other clients with different operating system work well.

Also check the services and they are in auto mode,

Will it be a compatibility problem?

Polina Krasnoborceva, Support (Posts: 362)

May 28, 2019 8:14:46 pm EDT

Hello Alex,

Thank you for your message.

Could you please clarify if you mean the Agent module? If this is the case, could you please double check if you have the Run after reboot checkbox in the Agent window selected before a machine is rebooted?


Looking forward to your reply.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.