(public ID server) Connections Constantly Dropping

Links used in this discussion

Larry Gray, User (Posts: 24)

Jul 02, 2014 2:28:41 pm EDT

Support level: Free or trial
I work from home and have two computers that I connect to remotely.  I use DSL at home and the remote computers are behind a staticly addressed firewall.  I am not allowed to open any ports inbound through the firewall.  The two remote computers were configured to use the default gateway server, but today I downloaded and setup a gateway on my home computer and put a hole through my home firewall.  Then I setup dynamic DNS and configured the host and connection properties.

Prior to all of this, I was dropping connections, a lot!  So, I thought I might have better connectivity if I put in my own gateway, but it seems worse.  I have an IP Phone at my house and it doesn't experience any issues with quality over this DSL connection, so it can't be that my DSL is this bad.  And the site with the remote computers is solid as a rock as well.

The two remote computers have two monitors each, I have a connection setup for each monitor as suggested in another forum topic (thx again  :D ).  One monitor will drop while the other stays connected.  The logs in the viewer show lots of Authorizing and connection failed messages.

This all used to work well, not sure why it is disconnecting so much lately.

Anton Kalugin, User (Posts: 209)

Jul 02, 2014 2:39:24 pm EDT

Support level: Free or trial
Hello Larry,

Thank you for your message.

Could you please try to execute "ping %your_GMS_server_DNS_name% -t" command in your command line on one of your Host computers. And look at the packet's behavior when there is a disconnect.

Looking forward to your reply.

Larry Gray, User (Posts: 24)

Jul 03, 2014 7:11:42 am EDT

Support level: Free or trial
I was working on getting Pings to actually work (my home firewall doesn't have settings to allow them through).  I then realized it wasn't necessary.  In Viewer at home, I have four sessions, two that connect to the one computer and two more that connect to another computer and all are in the same office; Each of the two computers has two screens, thus the four sessions.  I connected to my left computer this morning with both screen sessions as I worked on setting up the ping, and the right screen connection dropped.  Here are the log entries I am seeing in the viewer (for example: Ofc_Lft = computer on the left at my office, the RtScrn = the right screen on that computer):

28:00:08_03-07-2014_400 Connection #468112. Connection to "Ofc_Lft_RtScrn". Mode: <Authorization>. Connecting...
28:00:08_03-07-2014_409 InetConnection #468112. Internet connection to Ofc_Lft_RtScrn (
29:00:08_03-07-2014_884 Connection #468112. Connection to "Ofc_Lft_RtScrn" established. Mode: <Authorization>.
29:00:08_03-07-2014_979 Context #468112 removed. Mode: <Authorization>.
37:00:08_03-07-2014_201 Connection #680589. Connection to "Ofc_Lft_LftScrn". Mode: <Command>. Connecting...
37:00:08_03-07-2014_211 InetConnection #680589. Internet connection to Ofc_Lft_LftScrn (
37:00:08_03-07-2014_201 Connection #736264. Connection to "Ofc_Rgt_LftScrn". Mode: <Command>. Connecting...
37:00:08_03-07-2014_230 InetConnection #736264. Internet connection to Ofc_Rgt_LftScrn (
38:00:08_03-07-2014_543 Connection #680589. Connection to "Ofc_Lft_LftScrn" established. Mode: <Command>.
38:00:08_03-07-2014_653 Connection #736264. Connection to "Ofc_Rgt_LftScrn" established. Mode: <Command>.
39:00:08_03-07-2014_226 Context #680589 removed. Mode: <Command>.
39:00:08_03-07-2014_324 Context #736264 removed. Mode: <Command>.

The Host logs just show connection dropped for this instance.

Larry Gray, User (Posts: 24)

Jul 03, 2014 7:17:27 am EDT

Support level: Free or trial
Could it be my setup?  I setup Dynamic DNS.  I put the FQDN of the GMS into the Host settings at the office.  In the Viewer at home, I set the connection properties for each session to point at (local computer).  The connections work, they just seem to randomly disconnect.  Remember, I work with 4 sessions: 2 to one computer and 2 to another computer.  Each one of them are dropping randomly.  Computer 1 Session 1 might stay up while Computer 1 Session 2 drops.  Same for Computer 2.
Edited:Larry Gray - Jul 03, 2014 7:19:13 am EDT

Anton Kalugin, User (Posts: 209)

Jul 03, 2014 7:45:21 am EDT

Support level: Free or trial

I have created a tech support ticket from your message. You will be replied shortly.

Kerry Fisher, User (Posts: 2)

Sep 28, 2017 10:26:22 am EDT

Support level: Free or trial
I have been having the same issue since upgrading to the latest version. I Run my own connection server and the problem only started after upgrading.  It's like the connections time out.  Because I close the window and can reconnect immediately.

Conrad, Support (Posts: 2592)

Sep 28, 2017 3:09:29 pm EDT

Hello Kerry,

Could you please create a support ticket and enclose the Host log. If there is not one Host but many that have this issue, you can attach logs from a few of other Hosts as well.

Thank you.

Tom Davis, User (Posts: 3)

Feb 22, 2018 5:16:17 pm EST

Support level: Starter
This is 5 months old, anyone mind updating status on this ?
Have the same situation, run my own connection server, get the same continuous drops.
And get a connection was interrupted ...
If I just sit here and watch, I see popups repeatedly saying online/offline for these hosts.
When this happens, The viewer still shows the screen, albeit froze, and if I try to reconnect from address book it acts like it connects but the screen is still froze, I must close the original screen, which is fine but why wouldn't it close that screen ?  it obviously is already dead??

Conrad, Support (Posts: 2592)

Feb 22, 2018 5:28:18 pm EST

Hello Tom,

Have you updated your program installations to the most recent version, which is currently You need to update both Viewer and Host/Hosts, not just the Viewer.


Tom Davis, User (Posts: 3)

Feb 22, 2018 6:06:49 pm EST

Support level: Starter
Yes I have, this clearly is more involved but thanks for asking.
I also noticed:
22-02-2018__18:06:18__689 CheckID Connection. After process message. Host "my.ip.address". MsgCode: 10
22-02-2018__18:06:18__832 Exception
22-02-2018__18:06:18__833 MakeConnection.

with a dump that i'd rather not post here.

To my original question, what was the resolution to the earlier posts in this thread?
Edited:Tom Davis - Feb 22, 2018 6:12:03 pm EST

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.