Knowledge Base

Socket error #11001: Host not found

Symptoms

There are issues connecting to a remote Host:

  • Host status is shown as "Offline" in the Viewer address book.
  • You can establish a remote connection, but the connection is unstable.

When you examine the Host log you see the following error:

Socket Error # 11001 Host not found.(EIdSocketError)

Cause

This issue applies to Internet-ID connection. When this connection type is in use, the program communicates with an intermediary server on the web — depending on your settings this can be our public server or a self-hosted server that you maintain.

As quoted from Windows Sockets Error Codes:

WSAHOST_NOT_FOUND
11001
Host not found.
No such host is known. The name is not an official host name or alias, or it cannot be found in the database(s) being queried. This error may also be returned for protocol and service queries, and means that the specified name could not be found in the relevant database.

This error might mean that the remote Host is unavailable due to one of these reasons:

  • DNS problem, i.e. the IP address of the intermediary server cannot be resolved from its DNS name.
  • The intermediary server's address and/or outbound port is blocked in the firewall.

To resolve the issue, please try the solutions below in the order they are listed.

Solution 1

Clear DNS cache on the computer where the Host is installed (the steps below apply to Windows 10):

  1. Press Win + R to open the Run dialog.
  2. Type ipconfig /flushdns and click OK (or hit Enter): Flush DNS
  3. A command box will flash on the screen for a split second and the DNS cache is cleared.
  4. Right click on the Host icon in the tray area and select Restart Host. Wait 10-20 seconds until the Host restarts and establishes a connection to the intermediary server.

Solution 2

If you use our public Internet-ID service make sure that the primary server at id.remoteutilities.com can be accessed from the Host PC and the IP address of the server can be resolved successfully.

  1. Press Win + R to open the Run dialog.
  2. Type cmd and click OK (or hit Enter). The Command Prompt will open.
  3. Type ping id.remoteutilities.com and hit Enter.
  4. If the ping command and DNS resolution are successful you should see the result as in the image below: Ping ID server
  5. If you receive "Request timed out" as a response, the ID server cannot be reached from the Host location. Please, contact your system administrator.

Solution 3

The Internet-ID connection requires some outbound ports to be open. When used with our public service the ports used are TCP 5655 and 443. Make sure that the Host can establish outbound connections on these ports.

Note that even if outbound connections on TCP ports 5655 and 443 are allowed on the Host machine, such connections may still be blocked on your corporate network (perimeter) or ISP level depending on their security policy. In this case you are advised to contact your system administrator or ISP to further investigate the issue.

Tags: Error, Connectivity

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