Community

Synced Address Book Error

Page:
Links used in this discussion

Conrad Sallian, Support (Posts: 2371)

Jul 30, 2019 5:37:45 am EDT

Hello Karel,

I was guessing it could be some missing port forward, is TCP 5655 enough?? No more ports needed??

Yes, this is the default communication port. There is also an administration port but it's only used if you are using the Admin console on the computer and the actual running service on another computer, which is seldom a scenario. Here is more information about RU Server ports https://www.remoteutilities.com/support/docs/ports-used-by-ruserver/

But after Matt's workaround, I think this is not the core of problem.. I also assume you're testing it on LAN, I'm trying to make it work on the internet

Yes, we would still want to get to the root of the problem and fix it if possible. Could you please do the following:

0. Make sure that you installed the latest server version. As of this writing it's version 2.7.9.0.

1. Create several books on your server (or just re-use the ones from your previous test if there's no confidential information in them).

2. Reproduce the problem.

3. Copy all the books from the server - they are stored in C:\Program Files (x86)\Remote Utilities - Server\data\ as xml files.

4. Export the registry entry HKEY_LOCAL_MACHINE\SOFTWARE\Usoris\Remote Utilities\MiniInternetId

Zip the books and the reg file and send them to us to support@remoteutilities.com . We will examine the files and see if they can give us a clue.

I mean: I can give you access to my 'server' (Win10) if you want to try the 'buggy' configuration, we have TCP 5655 and 3389 (RDP) forwarded. Directory structure and users can be deleted as well as two saved test connections..

No need for remote access for now, let's see if we can figure out the problem from the files above.

Thanks!

Karel Vychodsky, User (Posts: 10)

Jul 30, 2019 5:54:14 am EDT

Hi guys..
server reinstall helped. Maybe the sequence of tasks has to be preserved somehow??

1) install server
2) create user (apply)
3) (right after that I have logged user into Viewer)
4) create group and add user into it (apply)
5) create directory and add group permission (apply)
-> Viewer pops up window 'New dir avail.' so I added it and it works

Next, randomly adding directories, groups and users works just fine so far.
I'm sorry for being so impatient and thanks for help anyways. I hope next person that comes to this thread will continue where we finished.

Karel

Karel Vychodsky, User (Posts: 10)

Jul 30, 2019 6:31:11 am EDT

Aaaand it's gone again, Conrad.. worked like for an hour. I'll follow the steps you asked for and we will see..

Karel

Conrad Sallian, Support (Posts: 2371)

Jul 30, 2019 6:33:09 am EDT

Hi Karel,

Of course, this should be fixed once we find the root cause. The fact that we cannot reproduce it in our environment means that this problem manifests itself only in certain conditions, that's why your help would be appreciated.

Thanks.

Karel Vychodsky, User (Posts: 10)

Jul 31, 2019 1:23:07 am EDT

Hi Conrad, I have sent the mail.
Further testing and investigation showed that it behaves kinda random.. I added myself as a user to Directories rights explicitly so I could start working, and left Directory 'Test' with group access only.. In the evening it behave like expected, all directories syncing fine, only Test was left with exclamation mark. In the morning I came to PC and was logged off the console. I couldn't log back in.. So I restarted the service on the server and all Directories came up, even the 'Test' and even after console restart.. I removed myself from few other Directories, left only groups (I'm member of) and everything OK.. I'll observe for few more days and keep the updates..

Karel
Edited:Karel Vychodsky - Jul 31, 2019 1:23:36 am EDT

Karel Vychodsky, User (Posts: 10)

Jul 31, 2019 2:56:01 am EDT

Update: after Viewer start, autologin seems OK, but ALL Directories are not syncing (both group only + group and user explicit). After logout/relogin, ALL Directories come online and working.

Karel

Matthew Cooper, User (Posts: 5)

Jul 31, 2019 3:56:51 am EDT

I recall seeing odd behaviors after changing settings on the server, then rebooting the machine. I know that doesn't help the troubleshooting, and I cannot remember the specifics, but I recall at one time thinking everything was ok prior to a server reboot, then permissions began to behave differently.

Matthew

Conrad Sallian, Support (Posts: 2371)

Jul 31, 2019 5:32:48 am EDT

Hello Karel,

We didn't receive an email, unfortunately. Since you already are a Pro user with the appropriate support status could you create a ticket and submit the files by attaching them to the ticket?

On another note, please try adding the server's installation directory to your antivirus software exceptions list just in case.

Looking forward to receiving the address book files for examination.

Karel Vychodsky, User (Posts: 10)

Jul 31, 2019 6:22:42 am EDT

Hi Conrad, Ticket #3597. I'm 'sorry' to say that for now it works well..

Karel Vychodsky, User (Posts: 10)

Aug 02, 2019 1:19:42 am EDT

Hey Matthew,

so just to inform you, nor me nor the RU team found anything strange. Furthermore the problem disappeared itself. Last time it was happening was when Viewer autologin was used, the directories didn't sync (few days ago and only from time to time). After logout/relogin, it worked well. I suspected some timeout, so I carefuly checked all the Windows power settings. I came accross 'hard disk timeout' (no idea why virtual PC has 2 hours timeout by default). Anyway, the only thing I can recommend is check and turn off all power saving features on your server, nothing else was done so far. Also the bug became more rare as we started to save connections into prepared Address books structure (?). I just wanted to let you know about the conclusions.

Karel
Page:

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.