Forums

Gateway/IP issues

Bobby Mills, User (Posts: 34)

Mar 25, 2014 4:58:36 pm EDT

So i setup the gateway with the IP Address and configured the port, then i configured the host side to connect to my IP and port and connection works. Now the issue i am having is my IP address has changed to another IP so now the host arnt connecting to gateway because its configured to connect to my old IP. Is their a fix or a way to have the gateway connect to a website to get IP and have host connect to the same website to get IP or something. Because now the host PC's i cant reach out to now without them reconfiguring them themselves.

Conrad Sallian, Administrator (Posts: 1083)

Mar 25, 2014 5:12:41 pm EDT

Hello Bobby,

Perhaps, you just need to use a service like no-ip.com. It's free from what I know. Generally, here's what you need to do:

1. Register with no-ip.com and create your own DNS name.
2. Install the No-ip client program on your GMS computer so that it regularly updates your DNS record with new IP address when it changes.
3. IMPORTANT: use your DNS name in the Host and Viewer settings for the custom Internet ID server (replace the IP address with your DNS name).

With this trick you won't have to change Viewer or Host settings each time your GMS IP address changes.

Hope that helps.

Bobby Mills, User (Posts: 34)

Mar 25, 2014 5:29:56 pm EDT

Ok signed up and added my DNS name in the custom IP address, i still use the Internet ID right..?

Conrad Sallian, Administrator (Posts: 1083)

Mar 25, 2014 5:34:56 pm EDT

Yes. Nothing changes except that you now use the DNS name in the "Internet ID settings -> Advanced -> Custom server" on both sides (Viewer and Host) + the no-ip client installed on the GMS server. You only need to make sure that your DNS name resolves to your current IP address properly, but that depends on the No-ip client software.

Bobby Mills, User (Posts: 34)

Mar 25, 2014 5:37:35 pm EDT

I am able to see type in my DNS name and it takes me to my website so it registers my ip. I changed my laptop settings and I can see it on the Idle tab on the gateway but viewer shows it offline and wont connect.

Conrad Sallian, Administrator (Posts: 1083)

Mar 25, 2014 5:41:19 pm EDT



Have you changed the custom server IP address to the DNS name on both sides, i.e. Viewer and Host?
This needs to be clarified. In the Host settings a custom GMS server is a global setting. Whereas in the Viewer you need to specify it for each remote connection that you want to route via your GMS. You can, of course, mass-edit them by selecting multiple records or use Default Connection properties for newly created connections.

Bobby Mills, User (Posts: 34)

Mar 25, 2014 5:49:19 pm EDT

Yes. The gateway reads my Moms PC over another IP connection. So it connect the GMS under IDLE tab. Do i still use the Internet ID or direct connection..?

Conrad Sallian, Administrator (Posts: 1083)

Mar 25, 2014 5:59:55 pm EDT

Bobby Mills wrote:
Yes. The gateway reads my Moms PC over another IP connection. So it connect the GMS under IDLE tab. Do i still use the Internet ID or direct connection..?
GMS is always about Internet ID connection. It's just a self-hosted replacement for our hosted Internet ID servers, and is entirely optional.

Direct connection by definition does not use any intermediary servers. It's a plain Viewer -> Host connection where the IP address (or DNS name) of the Host is used. Whereas an Internet ID connection always looks like this:

Viewer -> Default (our company's) intermediary server -> Host

or

Viewer -> Your self-hosted GMS -> Host

Bobby Mills, User (Posts: 34)

Mar 25, 2014 6:02:07 pm EDT

Ok just setup my other desktop PC on my LAN and configured it and it shows both my moms and other desktop under the Idle tab but the viewer wont connect. I changed the settings on my viewer under each of them and under default connections. MMMMMM what am i missing...

Conrad Sallian, Administrator (Posts: 1083)

Mar 25, 2014 6:07:27 pm EDT

Just created a tech support ticket from this thread. You will receive an e-mail notification.

Page:

* Website time zone: America/New_York (UTC -4)