Community

only 8 connections, but can't connect because apparently I have >10

Links used in this discussion

Tom Morton, User (Posts: 3)

Oct 24, 2018 3:18:21 am EDT

Viewer version is 6.8.0.1.

I can't connect to any of my connections because apparently "My license does not allow using this key for more than 10 computers"  - yet I only have 8 connections.  How can I get this working?  I had 10, yesterday added a new one and got the message, then I removed 3 old unused connections but still getting this error.

screenshots attached.

Cheers, Tom
Attached Files

Tom Morton, User (Posts: 3)

Oct 24, 2018 5:19:45 am EDT

Found the answer!  In %appdata%\Roaming\Remote Utilities Files is an XML called "connections.xml" or similar, and in this is a complete list of all connections in XML format.  There were several entries that weren't showing up in RUT viewer, I deleted these and all is good again!

Conrad, Support (Posts: 2406)

Oct 24, 2018 5:34:38 am EDT

Hello Tom,

The connections_4.xml file is the file where your general address book is stored. However, all entries must be shown not just some of them.

Either the file was corrupted somehow or it was one known bug with the 6.8 address book that has been fixed in the current version 6.9.

Anyway, I'm glad that you figured out and fixed the issue.

Thanks.

donpowell Don, User (Posts: 3)

Nov 11, 2019 11:16:01 am EST

I have this problem too.  I have a total of 6 computers.  All six have the host program running and two of them have Viewer running (although I loaded viewer on all of them, they are not running)

I run Viewer from either my main pc or my netbook.

When i try to run viewer from the netbook I get the max license error message of 10.  The only thing I can think of is that it sees my main pc as 6 plus netbook for 6 which equals 12 in its mind instead of 6.

I've shutdown Viewer on the main pc (since I'm not on that PC anyway) and it makes no difference.

I've looks for the address book but the only places I have found show only 6.

What do I need to do to have my netbook view the 5 other PCs and my main PC view the other 5 PCs (excluding themselves?)

Don

Tom Morton, User (Posts: 3)

Nov 11, 2019 11:23:01 am EST

Don have you checked my post from 24-10-18?  That didn't fix it for you?  You could always rename the XML completely, and then RU will create  a new blank one.  Then create 10 new connections from scratch without putting details in.  If you can do this then the XML file is at fault.  Otherwise you can delete the new one and reinstate the old XML file without losing any saved details.

However going through the XML and fixing it worked for me originally.  I've had the problem since but fixed it each time by deleting out the 'ghosts' in the XML.

Polina Krasnoborceva, Support (Posts: 431)

Nov 11, 2019 2:01:21 pm EST

Hello Don,

Thank you for your message.

Could you please clarify if you have the AD tree displaying enabled in the Viewer's Navigation pane? If you do, please try enabling the Hide default domain controller feature in the Viewer options, on the Misc tab:

This might be causing the issue as the computers in the tree also count against your license. So if this is the case, you are advised to add the computers you need from your AD to your address book and disable showing the AD tree in Viewer.

If the AD tree is disabled, but you're still encountering the issue, it might be caused by the Viewer configuration file (config_4.xml) being somehow corrupted (perhaps, by an antivirus/firewall software). Please try resetting the Viewer options by deleting the config_4.xml file found in %appdata%\Remote Utilities Files\ folder. This will reset the Viewer settings/options, your address books won't be affected by this action.
Please note that the AppData folder might be hidden by default in which case you need to enable "Hidden files and folders" in Windows Explorer settings.

Also, as it was mentioned above by Conrad and Tom, the issue might be caused by the General address book file connections_4.xml being corrupted. In this case, please try copying the address book file to another location and see if the problem still persists upon the next Viewer startup. If it does, then please try removing the connections_4.xml file from the %appdata%\Roaming\Remote Utilities Files folder.

Tom, thank you for the suggested workaround and for helping other users in the community.

Hope that helps.

donpowell Don, User (Posts: 3)

Nov 13, 2019 10:33:15 am EST

I think I found it.  I had under "All Connections" a General Address Book" with my 6 connections and also a "PrimaryList" with 5.  When I delete the Primary List so that I only have the General Address Book, then the error message went away.

I was thinking the additional address books were subsets of the General but I guess they are additive.

Thanks!

Don

Polina Krasnoborceva, Support (Posts: 431)

Nov 13, 2019 4:16:18 pm EST

Hello Don,

I'm glad to hear you have figured out the issue!

I was thinking the additional address books were subsets of the General but I guess they are additive.

That's correct. All connections from additional address books as well as from the AD tree also count against the license.

Please let us know if you have other questions.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.