Community

Remote Utilities server - All connections inactive

Links used in this discussion

ben ellis, User (Posts: 5)

Jan 03, 2020 9:27:29 am EST

Support level: Starter
Server: 2.6.2603
Clients on latest version

All connections in remote server are inactive only direct connection will work. The port is open on my network and is listening

IP filter on server is set to apply black list - with no ips.


Stat log shows connected:
47.222.108.193;421900669861;47.222.108.193;69110;V205078900AB447A4;69110;07-29-48 03-01-2020;OK
47.222.108.193;421900669861;47.222.108.193;69110;V29A1F10F12184B58;69110;07-38-32 03-01-2020;OK

Netstat shows connected machines on port 7237
i tried default 5655 and 7237 and both work fine... but machines never go active.

What ports am i missing?

The ports can be seen from internet.

Any ideas why the server quit working?
Attached Files

Conrad Sallian, Support (Posts: 2560)

Jan 03, 2020 11:41:28 am EST

Hello Ben,

Thank you for your message.

I would recommend to restart your server to see if the problem persists. Or at least restart the server service (see Configuration -> Service state tab)

I can see that your server version is slightly outdated. I highly recommend that you update the server to 2.8.2.0 which is the latest version up to date (you can download it here) especially given the fact that you have the most recent RU version.

ben ellis, User (Posts: 5)

Jan 03, 2020 12:09:57 pm EST

Support level: Starter
I just updated to 2.8.2.0 and rebooted. Still idle.
Attached Files

Conrad Sallian, Support (Posts: 2560)

Jan 06, 2020 5:40:32 am EST

Hello Ben,

I"m afraid I misunderstood your initial post, sorry for that. Actually, idle here just means that a Host is waiting for connection (there is no active remote session with that Host). Whereas a Host is moved to the Active tab whenever you start a remote session with that Host (i.e. open/start at least one of the available connection modes or simply log on).

Hope that helps.

ben ellis, User (Posts: 5)

Jan 06, 2020 9:35:51 am EST

Support level: Starter
Thank you for the clarification but i still do not think you understand.

Ok so you know when they go active they look like (see attached screenshot). This is because i am on their network now and directly connected. The Server connections  is still showing idle even if i remote.

prior the Connections would be online all the time with the server being able to switch to connect. When not on vpn, i cannot connect to them all of a sudden. I didnt change my firewall when it was working. I even have server port 5655 open so What else can i check to see why they dont connect off vpn. i didnt change any settings they just went offline and never connect anymore.  Are there suppose to be additional ports open for agents to remote and show online when not directly connected. As you can see they can communicate to the server. They are idle.
Attached Files
Edited:ben ellis - Jan 06, 2020 9:43:38 am EST

Conrad Sallian, Support (Posts: 2560)

Jan 06, 2020 12:52:47 pm EST

Hello Ben,

Ok so you know when they go active they look like (see attached screenshot). This is because i am on their network now and directly connected. The Server connections is still showing idle even if i remote.

Unfortunately, this is not the case. Yes, they are online (which here means "available", "ready") and they should be in the "Idle" tab in your server panel.

When they are active (i.e. logged in) the thumbnails will either show a green monitor or a preview of the remote screen. And in this case they should be visible in the "Active" tab on the server.

prior the Connections would be online all the time with the server being able to switch to connect. When not on vpn, i cannot connect to them all of a sudden. I didnt change my firewall when it was working. I even have server port 5655 open so What else can i check to see why they dont connect off vpn. i didnt change any settings they just went offline and never connect anymore. Are there suppose to be additional ports open for agents to remote and show online when not directly connected. As you can see they can communicate to the server. They are idle.

If the hosts are in the idle list on your server that at least means that the "host -> server" leg of the connection works. However, if you cannot connect (and you see the connection items as "offline" in your Viewer) that means that it is the Viewer that can't communicate with your server due to some reason.

If this happens while your Viewer computer is on a VPN you should make sure that you can access your self-hosted server from that network. This might be the real reason for the issue, and not the hosts or the server.

ben ellis, User (Posts: 5)

Jan 07, 2020 11:33:55 am EST

Support level: Starter
I checked that.. But what is odd is its all machines even other networks.
So i would assume its on my network not theirs.

Can you telnet viperbe.duckdns.org 5655 ? You should get a blinking curser . If thats right then you connected to my server.. Which is the same machine the viewer sits on and the same machine the clients communicate too.
What other ports do i need to open on my side for client to connect back? From client what ports need to be outgoing/incoming?  Everything is default....except for the server instead of your Internet-ID . i did tell it to use your server but i couldnt connect to it still .
Edited:ben ellis - Jan 07, 2020 11:35:52 am EST

Conrad Sallian, Support (Posts: 2560)

Jan 07, 2020 3:18:22 pm EST

Hello Ben,

Here is the documentation on ports, specifically the ports used by RU Server https://www.remoteutilities.com/support/docs/ports-and-port-forwarding/

If you change RU Server communication port make sure that you also change it on Viewer and Host side so that they use the correct port.

ben ellis, User (Posts: 5)

Jan 08, 2020 8:51:13 pm EST

Support level: Starter
I have figured out the issue. It was because SPI firewall was enabled on my dd-wrt firmware.
When i disabled it. Everything connected as normal.

Thanks for the help. You can close this.

Polina Krasnoborceva, Support (Posts: 1011)

Jan 09, 2020 1:18:41 pm EST

Hello Ben,

I'm glad to see that you have figured out the issue!

Please do not hesitate to contact us if you have other questions. We're happy to assist!

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.