RU Server Problem

Links used in this discussion

Michael -, User (Posts: 9)

Mar 16, 2019 9:09:37 am EDT

Support level: Free or trial
Hello, I installed RU server on my Windows 2016 server, managed to get it to run, on PC1 i logged in with the user i gave permission and I see my PC2 in my address book. Its online, I can connect. But then it goes Offline in the list and online again, it switches every minute. 1 Minute the PC is online, 1 Minute the PC is offline switches all the time, i get notification "xxx is online" then i can connect again, then after a minute its offline again and so on all the time. Don't know what I do wrong.

Michael -, User (Posts: 9)

Mar 16, 2019 9:11:49 am EDT

Support level: Free or trial
It seems to work now, after re-installing everything.

But I still got one big problem. I cant connect to any of my PCs with Internet-ID with custom server. Everytime i try to connect i get the error "Custom Server Security Authorization Error" and I don't know why.  I have one Server, 3 PCs and 1 User.

On the RU-Server:
- Pin Code: 8 numbers
- Require Pin on Viewer: On
- Enable Permission Based Internet-ID Access: Username

I am logged in with the same user (have only one) and I get the Internet-ID and see on my Viewer my PC where I added the Host to my Address Book. So everything fine here.

On the Host:
- Dashboard / Internet-ID connection:
Status: Ready for connection (Correct port, Pin code added same as on RU Server)
Authorization: Single password: On
Custom Server Security: On
User and access control: logged in with same user (allow on all checkboxes)
Modes: All
2-factor Auth: On

On the Viewer:
- General: Internet-ID Connection (customserver IP, Port and correct PIN)
- Security: Single Password Security on, but do I even need it for not LAN connections?
- Authorization: Custom Server Security (both check-boxes On)

Shouldn't it work? I am logged in with the same user on the viewer. I tried already disabling Pin, didn't help.
The connection for LAN works with Single Password Security, its just the connection by Internet-ID gives me that error.

*EDIT* I have again the problem with the disconnect/connect every 40 seconds on the 3rd PC, is there no other solution the doing all over again everything to solve this? I sit here now already since almost 6 hours and I dont get this to work :/ Its still disconnecting & connecting for one PC all the time. EDIT: Now it changed to a different PC, that one is now with the same problem and the other one is working, this is killing me... it always disconnected for 1 second, then stays online for 1 minute or so, loop.
*EDIT2* This seems like never ending, after restarting the PC with the Viewer, all the LAN/Direct connections wont connect anymore, just a hourglass symbol.... ping and refresh status are not doing anything. I had to Restart the HOST on all PCs so it would work again, thats not a solution, I cant every time I restart my PC restart on all Hosts the Host program :/ This is really frustrating working all day on this and nothing works.

*EDIT3* The menu that should appear when clicking with the right mouse button on the HOST icon in tray wont open... have to shut it down with the Task Manager. That is the second time this happens today. I really want to like this program, it has awesome features, but it just won't work. Wasted my whole Saturday on this.
Attached Files
RU Server Problem
Edited:Michael - - Mar 16, 2019 7:31:09 pm EDT

Polina, Support (Posts: 1156)

Mar 18, 2019 3:47:06 pm EDT

Hello Michael,

Thank you for your message.

Authorization: Custom Server Security (both check-boxes On)

Please try to sel ect the Auto option in the Authorization tab in connection properties. If you have both Custom server security and Single password enabled as your authorization method, with the Auto option enabled the Viewer will use Custom server security, because it goes before Single password security in the priority list.
In order to enable Auto please do the following:
1. In the main Viewer window right-click on the remote connection and choose Properties.
2. Navigate to the section Authorization and in the dropdown menu choose Auto.
RU Server Problem - 18 Mar 2019 03:46:22

Also please clarify if your server is located in the same LAN as the Viewer or Host and if you use the server's external address? If this is the case, please try using its internal address to connect within your LAN.

Single Password Security on, but do I even need it for not LAN connections?

Single Password is one of the authorization methods. You must authorize on a remote Host regardless of connection type. Here's a related article on  authorization methods you can choose fr om.

Also, it's not necessary to use the RU server as a relay server and the Custom Server Security simultaneously. For example, you can use a direct connection and still use a Custom Server Security as the authorization method.
Of course, the server should still be directly accessible for Viewers and Hosts.

Please let me know if you have more questions.

Michael -, User (Posts: 9)

Mar 19, 2019 7:11:33 pm EDT

Support level: Free or trial
Hello, setting it to AUTO did not change the error message, same error.
The Server is a hosted Windows 2016 server i rent from a hosting company.
I use DNS to connect to the server.
Edited:Michael - - Mar 23, 2019 9:18:31 am EDT

Polina, Support (Posts: 1156)

Mar 20, 2019 2:40:46 pm EDT

Hello Michael,

Could you please send us the Host and the Viewer logs for examination? Here is how to locate the Host logs and the Viewer logs.
You can send them to

Also, please try disabling the Pin Code feature on the Server's side.
To disable the Pin Code feature please follow these steps:
1. Open the Server Configuration window and navigate to the tab Communication
2. Deselect the PIN Code checkbox:
RU Server Problem - 20 Mar 2019 02:16:11

If the issue still persists I recommend that you perform a complete uninstalling of the Host, the Viewer and the Server. Then re-install the Host, the Viewer and the Server with default parameters and set up the Server following this guide:

Hope that helps.

Michael -, User (Posts: 9)

Mar 20, 2019 3:44:03 pm EDT

Support level: Free or trial
Hello, thanks for your reply. I did follow the guide as best as I understood it for setting up everything.
I rented the windows server just for Remote Utilities.

Server: Windows Server 2016
PC1: host & viewer
PC2: host & viewer
PC3: host only

Ports: 5640 hosts and 5660 for server

As you can see on the screenshot I made all 3 PCs once with Internet-ID for Remote acces, and a second LAN connection for every PC to connect on LAN. The connection on LAN works.
But as you see on the Screenshot, I cant connect. As soon as I start the viewer the 3 Internet-ID based connections show as "online" and the 3 LAN connections just show the wait icon.

As soon as I restart the Host (right mouse button, restart host) the LAN connection shows as online and I can connect. Refresh Status has no effect cant do anything, only option is to restart the host. On screenshot 3 you see after I restart the host it will show the PC as online. But that cant be the solution to every time i restart my Viewer PC i have to restart all hosts so they show up as online. I could not restart the host on PC1 because the menu when clicking the icon didnt not open, I dont know why this is always happening with that icon. All other icons in Tray work. After stopping the server manually and starting it again, the icon is clickable again.

For the Internet-ID based PCs they show online for about 1 minute then they all go offline for 1 second or less and all go online again at the same time, thats a infinite loop. See Screenshot 2 (its only for half a second maybe). Last time that only happened with 1 PC, now it is happening with all 3 of them at the same time. Its just sometimes the icon wont open the right-mouse button menu to restart the host, its very annoying that goes on all day every minute and it shows every minute the notification ot4gpc has gone online on bottom left corner, every minute.

I dont havy any kind of Anti Virus software with real time scanning on my PCs (I also deactivated Windows Defender), only a Firewall and that one is deactivated for the time beeing. If I try to connect to one of the 3 Internet-ID based connections i get the error and the host goes offline. After pressing refresh status, they show as online again.

I disabled the PIN now and got a new Internet-ID, the new ID shows up on the Server to, restarted the server also. But it still is the same error.
I dont know what to do anymore, its very frustrating because i spend already so much time on this, even rented the server for it.

*EDIT* I send now the logs to the support Mail, also I added a screenshot from the viewer after I connected directly to all 3 PCs they show up as green inside my viewer, but the Internet-ID based connection still has the same error. Connection is set to Auto and PIN is removed. User is only 1 on the system. I also renewed my Internet-IDs and updated the Viewer address book.

Also after restarting all 3 hosts for LAN connection only 1 shows up, the other 2 are stuck again, see screenshot viewer5 :/ have to restart the host again so it will be online...
Edited:Michael - - Mar 23, 2019 9:18:13 am EDT

Polina, Support (Posts: 1156)

Mar 20, 2019 4:43:34 pm EDT

Hello Michael,

Thank you.

We will examine your log files and get back to you soon.

Michael -, User (Posts: 9)

Mar 20, 2019 4:50:48 pm EDT

Support level: Free or trial
Thanks a lot, ....LAN connects are again stuck and wont come online again firewall is deactivated, also the windows firewall, restarting the host is the only thing that works to make them go online again on the viewer.
Edited:Michael - - Mar 20, 2019 4:56:27 pm EDT

Polina, Support (Posts: 1156)

Mar 21, 2019 9:57:26 am EDT

Hello Michael,

Thank you for your details.

Please do the following:
1. Locate the folder C:\Program Files (x86)\Remote Utilities - Server and zip the entire folder.
2. Locate the folder C:\Users\Username\AppData\Roaming\Remote Utilities Files. Zip the entire folder.
3. Run Windows Registry Editor (regedit.exe), locate the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Usoris\Remote Utilities\MiniInternetId, right click on the key and sel ect Export. Save the .reg file.
4. In the Windows Registry Editor navigate to the key HKEY_LOCAL_MACHINE\SOFTWARE\Usoris\Remote Utilities Host. Right click on the key and select Export. Save the .reg file.
5. Please send 2 zipped folders and 2 registry keys fr om the steps above to We will examine the files to figure out the issue.
6. Then please change your credentials for security reasons.

Looking forward to your reply.

Michael -, User (Posts: 9)

Mar 23, 2019 9:16:04 am EDT

Support level: Free or trial
Sorry, you can close the ticket, I gave up and switched to a different solution :/ Honestly your Remote Desktop would be the most amazing thing if it worked, but also the problems with the icon that cant be clicked and the connection problems really are a pain. The other solution did costs me a bit of money but all 3 pcs setup worked within 20 minutes connecting in all directions.

Still I think your solution would be best with the server and all the options for security, I hope you have success with your tool I really want your software to work.

PS: After uninstalling Remote Utilities, the Folder inside the AppData will NOT get deleted! Really dangerous, also the Registry Key will not get deleted had to do that all manually.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.