Community

Enter, shift, ctrl and Alt keys not working from viewer to all hosts

Page:
Links used in this discussion

Polina Krasnoborceva, Support (Posts: 884)

Nov 19, 2019 5:21:08 pm EST

Hello Ian and Julia,

I apologize for the late reply.

Could you please clarify if it's possible to try installing the Viewer to a machine with no antivirus software installed and check if the issue occurs there as well? If it's not possible, then please try resetting the Viewer setting by performing the following steps:

1. Fully exit the Viewer File -> Exit.
2. Locate the file config_4.xml in the C:\Users\[Your_username]\AppData\Roaming\Remote Utilities Files\ folder.
Please note that the AppData folder might be hidden by default in which case you need to enable "Hidden files and folders" in Windows Explorer settings.
3. Remove the config_4.xml file from that folder.
This will reset the Viewer settings. Your address books won't be affected by this action.
In addition, I highly recommend that you add the folder mentioned above and the C:\Program Files\Remote Utilities - Viewer\ folder (or in case if you have a 64-bit operating system, the folder should be located in C:\Program Files (x86)\) to the antivirus software exceptions list to avoid future problems in this regard.
4. Run the Viewer and see if the issue persists.

Please let me know if this worked for you.

Julia O'Neill, User (Posts: 2)

Nov 20, 2019 11:20:49 am EST

Support level: Free or trial
Hi. My problem has now resolved. I discovered yesterday that I appeared to have 2 x office 365 installed on my laptop. A business one and a student edition, so I deleted them and reinstalled office. It was only when I then used remote utilities for my work that I realised the keys were functioning again. However, this doesn't explain why it wasn't working on my desktop machine. My desktop machine has developed a major fault and so I will be replacing it. The only other thing I did was I changed a firewall setting. I use Avast on my laptop and I changed, ' programs with no defined rules' from Auto Decide to Allow. I ticked the internet sharing mode and I change it form a public network to a private network. As you can probably tell, I do not fully understand the firewall settings, I was just trying stuff randomly. Should I run into further problems I will let you know. Julia

Polina Krasnoborceva, Support (Posts: 884)

Nov 20, 2019 3:08:48 pm EST

Hello Julia,

I'm glad to hear that you've figured out the issue!

Please let us know if the issue occurs again or if you have other questions.

Sam Jackson, User (Posts: 3)

Mar 27, 2020 10:01:18 am EDT

Support level: Free or trial
Hey Polina,

I've having the exact same issue as Julia.  My Enter key doesn't work when using Unicode but my Shift, Alt and Control keys don't work when using Scan Code.  I'm running a Microsoft Surface 7 as the viewer.  Neither the Host or the View have any Anti virus beyond what is shipped by MS.

Any help would be appreciated.

Thanks

Sam

Sam Jackson, User (Posts: 3)

Mar 27, 2020 10:10:11 am EDT

Support level: Free or trial
Hi I'd like to clarify the above message as I can't modify it.

Unicode:  Enter Key Does not work.  Everything else does (not tested every key).
Scan code: Enter, Ctrl, Shift, Alt Key do not work.

Cheers and keep well.

Sam

Polina Krasnoborceva, Support (Posts: 884)

Mar 27, 2020 2:00:45 pm EDT

Hello Sam,

Thank you for your message.

Could you please clarify what version of Remote Utilities do you use? If you use version 6.10.10.0, please try updating Remote Utilities to the latest 6.12 Beta 1 version as we have implemented a fix for this behavior. The 6.12 Beta 1 version is available for the download here.
When updating Remote Utilities please make sure to update both Viewer and Host/Agent as the version mismatch might lead to performance issues and some features not working.

Please let us know if the issue persists.

Sam Jackson, User (Posts: 3)

Mar 29, 2020 7:13:43 am EDT

Support level: Free or trial
Hi Polina,

Thanks for the quick response.

This fixed the issue.

Keep well.

Sam

Polina Krasnoborceva, Support (Posts: 884)

Mar 30, 2020 9:30:11 am EDT

Hello Sam,

I'm glad to hear we were able to help!

Please feel free to post another message if you have more questions.

Basil Cinnamon, User (Posts: 2)

Apr 02, 2020 2:53:42 pm EDT

Support level: Free or trial
A possibly related issue:
I use autohotkeys (AHK, a replacement for the venerable AllChars) to expand short strings into longer ones, like say an email address:

]jg  => Joseph.Something@gmail.com

AHK is extremely useful in that it can do a lot more than this simple example, so I use it a lot.
For example, to enter date and time I use ]dt which expands to 4/2/2020 2:47 PM.

However, when remoting in with RU, it does not transmit the upper case or shift, so that the email example becomes
joseph.something2gmail.com

While an email address is not case-sensitive, the @ becomes 2 (the lower case for that key), which makes it unusable.
The date & time in RU expands to 4/2/2020 2;49 PM which is also incorrect.

If I remote from the same laptop to the same host machine via other remote software like UVNC,  [censored] , or RDP, this does not happen. The string expansions happen correctly. In fact, I can simultaneously remote into the host machine via RU, UVNC, and [censored] , to try the expansions into the same program like Notepad, and the problem only happens with RU.
I have tried the RU settings for Scan code and Unicode, and they make no difference.
Any ideas?

Polina Krasnoborceva, Support (Posts: 884)

Apr 02, 2020 4:54:50 pm EDT

Hello Basil,

Thank you for your message.

Could you please clarify what version of Remote Utilities do you use? If you use version 6.10.10.0, please try updating Remote Utilities to the 6.12 Beta 1 version as a fix for this behavior was specifically implemented in the Beta version. The 6.12 Beta 1 version is available for the download here.
When updating Remote Utilities please make sure to update both Viewer and Host/Agent as the version mismatch might lead to performance issues and some features not working.

Please let us know if the issue persists after updating Remote Utilities.
Page:

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.