Looking for a solution for remote work? See how Remote Utilities can help! (X) Dismiss


Remote Utilities Viewer for Mac andLinux has been released. Send us your feedback and report bugs in this discussion thread.

no keyboard shows to enter password on iOS

Links used in this discussion

ed, User (Posts: 1)

Dec 05, 2018 11:49:13 am EST

iOS version
after entering the internet id, the app asks for the password; a field is available to enter the password but it can't be selected and no keyboard appears to enter the characters.  The "Save password" check box appears and it can be toggled.  Notification ""Please, enter your credentials" appears at the bottom of the screen.

Same thing happens on iPhone and iPad.

I know there was a previous thread on this, but it didn't state how to resolve the problem!

Conrad Sallian, Support (Posts: 2490)

Dec 06, 2018 5:17:39 pm EST

Hello Ed,

Thank you for your post.

Could you make a screenshot of the said screen? You can make a screenshot on an iPhone if you press the Home and Power button at the same time.  Make sure that the screenshot does not contain any personally identifiable information before you post it here.

Andrew Schmidt, User (Posts: 3)

Dec 12, 2018 6:11:25 pm EST

I'm having the same problem with Remote Utilities on the iPad iOS version 12.1.   After I enter the IP Address to connect to a local computer on the LAN, the iPad keyboard fails to appear, no matter where I tap on the screen.  See attached screencap from  the iPad.
Attached Files

Conrad Sallian, Support (Posts: 2490)

Dec 13, 2018 9:08:58 am EST

Hello Andrew,

Thank you for your message.

We could’t reproduce the issue. The field works as it should on the iPad with the latest iOS (12.1 16B92) and RU updates.

Andrew Schmidt, User (Posts: 3)

Dec 15, 2018 5:49:07 pm EST

After an hour of troubleshooting, the app suddenly began working and showing the keyboard.  We'll never know for sure, but the fix may have come by manipulating the Authorization method settings in the HOST PC's software, which acted to clear out an unseen corruption among the various authorization steps communicated between the Host PC and iPad app.  Something had glitched and caused the iPad's app code to lock up just before it was supposed to pop-up the keyboard.

Here is the final series of steps taken that ended with the app beginning to work properly:

Remote Utilities Host software - Configuration menu:  General, Dashboard, Authorization method section:

Experimenting with the Authorization method settings, I disabled the Single Password option, configured the "Remote Utilities security" option, then attempted and failed to login from the iPad.  The next change was to  disable the RU security option and try the "Windows security" option -which again failed to allow the iPad to login.
The iPad App's response to the RU security and Windows security options was a login error message that said something about that the proper login method was not selected in the HOST configuration, which was a very unclear way of saying that the App can only use the Single Password method for logging in.

Also to note: before each one of these password tests, I manually forced the iPad to unload its RU App from memory, so that it would have a fresh start at communications.

Finally, I re-selected the Single Password authorization option in the Host software and created a new password (forcing it to forget the previous password settings).

And then magically, the iPad's keyboard screen popped up! and allowed me to enter the password.  It completed the connection to the remote PC and was in remote control mode.

Conrad Sallian, Support (Posts: 2490)

Dec 17, 2018 12:40:51 pm EST

Hi Andrew,

I'm glad to hear it is working for you now. I should say that we are going to significantly improve the mobile version pretty soon and add new features (including a full-fledged address book like in the desktop client).

Don't hesitate to post another message if you have any questions.

uscpeterkim, User (Posts: 2)

Mar 10, 2019 11:22:48 pm EDT

I am also having the same issue. I am not able to input a password because I am not able to click on the password field.

I just installed the client software on my computer (Win 10) and on my ipad.
I tried the steps mentioned above, but no results.
Attached Files

uscpeterkim, User (Posts: 2)

Mar 11, 2019 1:55:03 am EDT

Actually, I solved the issue. It's the simplest thing. Right before it asks for the password, a popup appears asking if you want to still display the tips (regarding the tap or double tap, etc functionality). As long as you click "Yes" (I still want to see the tips), you will not be able to enter a password. But if you click "No" (or whatever the equivalent was) you will be able to enter a password.

A little bug to fix, I believe.

Polina Krasnoborceva, Support (Posts: 663)

Mar 11, 2019 11:24:14 am EDT


Thank you for your message.

I am not able to input a password because I am not able to click on the password field.

We will be fixing this issue in the upcoming update. Sorry for the inconvenience.

Please let me know if you have more questions.

Polina Krasnoborceva, Support (Posts: 663)

Mar 13, 2019 4:47:46 pm EDT


The issue has been fixed. A new version is available to download here: https://www.remoteutilities.com/download/mobile.php

Please let me know if you have more questions.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.