Community

Hosts not auto-imported into the RU-address book

Links used in this discussion

Espen Simonsen, User (Posts: 7)

Mar 09, 2018 4:39:49 am EST

Latest version of host and server installed.
Installed RU-server on a 2012 server, created an address book and a connection. From my own machine i am able to start Viewer and login and sync the address book from the server.
However, when deploying new hosts with a customized .msi file, none of the hosts are imported into the address book.
The only way to add them is to do it manually, searching through ad, adding the host as a connection and moving it to the address book.

Also, the 5 hosts i`ve installed it on, everyone says Offline/Unknown even though they are up and running, and i am able to remote them.

Espen Simonsen, User (Posts: 7)

Mar 09, 2018 5:01:10 am EST

Seems like all hosts i install the msi on all get "direct" connection, instead of "internet ID - with the RU-servername", even though i have specified the internet-id on the msi-config

Conrad, Support (Posts: 2406)

Mar 09, 2018 5:04:10 am EST

Hello Espen,

Thank you for your message.

However, when deploying new hosts with a customized .msi file, none of the hosts are imported into the address book.

Provided that you enabled the auto-import option on the server (see how in this document), the Hosts should get automatically added to the designated folder. If they aren't, then perhaps they cannot even connect to the server in the first place.

Also, the 5 hosts i`ve installed it on, everyone says Offline/Unknown even though they are up and running, and i am able to remote them.

This might confirm what I said above. The Hosts cannot connect to the server for some reason. That's why they don't get imported into the address book - the server simply doesn't see them.

In order to troubleshoot Host -> Server connectivity please check this document https://www.remoteutilities.com/support/kb/cannot-connect-using-internet-id-connection/ .

Hope that helps.

Conrad, Support (Posts: 2406)

Mar 09, 2018 5:06:33 am EST

Hi Espen,

Do you mean the 3rd step of the configuration process, correct?

Espen Simonsen, User (Posts: 7)

Mar 09, 2018 5:08:43 am EST

Conrad wrote:

Hi Espen,

Do you mean the 3rd step of the configuration process, correct?

   

Hi,
thanks, yes there i untick generate new internet-code,  and select SPECIFY custom INTERNET-ID server and set it to the RU-server.

Conrad, Support (Posts: 2406)

Mar 09, 2018 5:15:31 am EST

Hi,

thanks, yes there i untick generate new internet-code, and select SPECIFY custom INTERNET-ID server and set it to the RU-server.

That might be the reason. You should tick the "Generate a new Internet-ID code" in order for the internet-ID to get generated at all. I assume that your msi file is used for a new Host installation, not for updating existing installations.

Unticking the "Generate..." check box in this step only makes sense if you are going to update existing Host installations. That is, if you want to update the server address (e.g. change it from public to a self-hosted one) without  changing the Internet-ID codes already assigned to Hosts.

Espen Simonsen, User (Posts: 7)

Mar 09, 2018 5:24:24 am EST

Seems like that did the trick, i will try a couple of more hosts first, thanks!

Espen Simonsen, User (Posts: 7)

Mar 09, 2018 2:56:17 pm EST

Thanks, i deployed the new MSI to 5 machines, and everyone registered correctly.
Many thanks

Conrad, Support (Posts: 2406)

Mar 09, 2018 3:20:27 pm EST

You are welcome :)

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.