Forums

RU and win 2012 - always offline

Salam ELIAS, User (Posts: 11)

Dec 20, 2014 4:07:06 pm EST

I have RU connectiing to win 8.1 and win 2008 like a charm but it is not working with Windows 2012, of course I have the latest version
Always offline in internet id mode. is RU free version for 10 is compatible with Windows 2012


I browsed some threads her, I did a "ping server.rutils.com", response seems OK as follows

C:\Windows\system32>ping server.rutils.com

Pinging server.rutils.com [70.38.38.43] with 32 bytes of data:
Reply from 70.38.38.43: bytes=32 time=156ms TTL=114
Reply from 70.38.38.43: bytes=32 time=156ms TTL=114
Reply from 70.38.38.43: bytes=32 time=165ms TTL=114
Reply from 70.38.38.43: bytes=32 time=155ms TTL=114

Ping statistics for 70.38.38.43:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 155ms, Maximum = 165ms, Average = 158ms

C:\Windows\system32>

Conrad Sallian, Administrator (Posts: 1163)

Dec 21, 2014 9:53:41 am EST

Hello Salam,

Thank you for your message.

Always offline in internet id mode. is RU free version for 10 is compatible with Windows 2012
Yes, there is no difference between free and paid license in terms of program features and compatibility.

Are both Viewer machine and Host (Win2012 machine) located on the same LAN? When you use an ID connection but there is direct accessibility of the Host, the program will use direct connection even if you choose ID connection. For direct connection you need to have incoming port 5650 open on the remote Host. Please, check if that port is open on your Win2012 Host.

To add security, you can change the default port to something else. See Settings for Host -> Options -> Network.

I also recommend you taking a look at this KB article: http://www.remoteutilities.com/support/kb/206/

Hope that helps.

Salam ELIAS, User (Posts: 11)

Dec 22, 2014 1:57:59 pm EST

Dear Conrad, thanks for the information. Firewall on my win 2012 is completely disabled, it is off on public, private and public

Salam ELIAS, User (Posts: 11)

Dec 22, 2014 2:25:51 pm EST

Conrad, I have just went and did a new experience, I have 2 VMs one is Win2K8 R2, the 2nd is win2K12. Both of them are on HYper-V and both are on same lan.
I ran a RU on both, the win2k8 R2 worked fine right away and I was able to connect to it remotely, the 2nd box with win 2K12 behave just like the other one, the small circle is greyed out and cnanot connect to internet.
Again, I confirm that Firewalls are disabled on all machines

Conrad Sallian, Administrator (Posts: 1163)

Dec 23, 2014 9:31:33 am EST

Hello Salam,

The grey circle can only mean that the Internet ID packets cannot go through some obstacle. Something is definitely getting in the way of Host trying to establish remote connection with our server.

Take a look at this KB article http://www.remoteutilities.com/support/kb/53/. It explains what ports must be open for ID connection.

Salam ELIAS, User (Posts: 11)

Dec 23, 2014 1:17:56 pm EST

Conrad, I am not sure what is needed to be done as I have no active firwall, it is disabled on all levels.
In the KB it is indicated to open specific ports, so as far as win firewal is disabled, what should i do?
Thanks

Conrad Sallian, Administrator (Posts: 1163)

Dec 23, 2014 3:10:49 pm EST

Salam ELIAS wrote:
Conrad, I am not sure what is needed to be done as I have no active firwall, it is disabled on all levels.

In the KB it is indicated to open specific ports, so as far as win firewal is disabled, what should i do?

Thanks
It's not necessarily the firewall right on the PC itself. You said that it was a VM. The hypervisor machine for the VM can work as a router/NAT or as a bridge, depending on how you configure it. You need to check the settings on it, namely whether it allows the guest machine to send packets to and fro using the ports the RU Host needs for Internet ID connection.

So it's certainly a network issue, but not necessarily on the VM machine itself. Check the hypervisor and your network router too, perhaps you have some firewall rules enabled on them.

Salam ELIAS, User (Posts: 11)

Dec 23, 2014 7:06:24 pm EST

Ok, I found that firewall on the hyper-V was enabled, I disabled it completely, rebooted the VM and rebooted the host to be sure, always getting the grey circle. Regarding my router firewall as it allows access to other VMs, I am more than sure that nothing is hindering packets to gop in:out otherwise I would not be able to connect to the other 4 win2K8 VMs

Conrad Sallian, Administrator (Posts: 1163)

Dec 23, 2014 7:14:15 pm EST

Hi Salam,

Is the computer on the same LAN/VPN as the Viewer? Perhaps you could simply utilize direct connection instead of trying to make ID work.

I'm still thinking that something's hindering ID connection on that specific PC. There's no other explanation, off the top of my head at least :)

By the way, make sure that "default" internet ID server checkbox is selected in Settings for Host -> Internet ID connection Settings -> Advanced -> "Select Internet ID server" dialog.

Salam ELIAS, User (Posts: 11)

Dec 24, 2014 9:51:45 am EST

I checked everything from Firewall perspective, I have absolutly no active firewall in the chain,as I saidm if there was any issue with my routerm then the other VMs would have never been able to communicate ober 5655 and 5665.

By the way, isn²t ther any log somewhere that can give a hint why it is not able to connect that comes with the host application?
Page:

* Website time zone: America/New_York (UTC -5)