Community

Certain keys (Enter, CTRL, Shift etc) not working on Remote Host

Page:
Links used in this discussion

Dylan Law, User (Posts: 3)

Dec 04, 2019 9:19:59 am EST

Support level: Free or trial
Hi, I have been setting up Remote Utilities on my home PC network as a replacement for  [censored] but I have run into a very annoying issue which I can see many others are also experiencing.

When connected to a Remote Host PC, certain key presses are not working including CTRL, Shift and the Enter key. I have tested this on multiple PCs with slightly different setups and tried all previously mentioned attempts at fixing (from this forum) and nothing works.

Here is my current setup:-

All PCs running latest Windows 10 Pro version 1903 build 18362.476

Main PC - Used for most work, gaming etc. and for remotely accessing all other PCs on my network (except the laptop). Currently running latest Norton Security (all Remote Utilities apps are whitelisted in AV and Firewall). Also tried this disabled etc and no difference
3 HTPCs 2 of which run Kodi 18.5 and 1 acts as a Kodi SQL server. All running Windows Defender AV and nothing else. These have been stripped to bare bones setup purely for Kodi and Netflix use.
Toshiba C50-b-14d laptop, used purely to Remote to my Main PC (so I can't be accused of sitting away from my partner too much) but also used to remote to all other systems. Again running Windows Defender and very little else as it is not a powerful device by any means.

I have tried using latest versions of Remote Utilities Viewer and Host as well as version 6.9.4.0 of both for testing across all devices. I can get the shift key working by selecting Unicode in the keyboard options but cannot get the Enter key to work no matter what I do. Also tried deleting the config_4.xml file, no difference I'm afraid.

I know it is nothing I have installed or have running as I have disabled everything and also tried a fresh install of Windows on my main PC so I am out of ideas. Can anyone help?

Polina Krasnoborceva, Support (Posts: 961)

Dec 04, 2019 2:11:54 pm EST

Hello Dylan,

Thank you for your message.

Could you please clarify if I'm right in assuming that the issue occurs on both your main PC and on the Toshiba laptop when you connect to other remote Host machines? If this is the case, could you please double check if there is any software that is installed on both your main PC and the Toshiba laptop as it might help us to isolate the issue? Unfortunately, right now it's hard to determine what exactly might be causing the issue as it manifests itself only in certain conditions that are very different for every user. Sorry for the inconvenience.

Looking forward to your reply.

Alex Shaw, User (Posts: 4)

Dec 18, 2019 4:33:09 pm EST

Support level: Free or trial
I can confirm that this happened to me too, exactly like this, and just today.  Just before doing windows updates, it worked, and as soon as I did windows updates on the host machine, it no longer worked.  The KB4522742 already existed on the remote machine since Nov 20.

On the remote machine, CTRL, Shift, Enter do not work.
(Thus, cannot CTRL-C / CTRL-V, cannot shift-arrow keys for highlighting, and Enter doesn't work, both of them - on the main keyboard, and the enter key in the num pad).

I am attaching a screenshot of the Windows Updates.  The updates that were installed were these two:
TWO Microsoft Office "Click-to-Run Update Support".
"October 24, 2019-KB4522742 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10, version 1909 and Windows Server, version 1909".

I hope that helps to figure out the issue.

EDIT: I am using the latest Remote Utilities on both machines 6.10.10.0.
Attached Files
Edited:Alex Shaw - Dec 18, 2019 4:34:43 pm EST

J Mo, User (Posts: 2)

Dec 19, 2019 9:32:55 am EST

I don't know if this is a coincidence or if it actually did anything.

Try going into the services of the host machine. Run>services.msc
Stop the process "Microsoft Office "Click-to-Run Update Support"
Log off of remote utilities on the viewer.
Close the viewer program on the viewer.
Re-open and try again.

Did this work for anyone else?

Polina Krasnoborceva, Support (Posts: 961)

Dec 19, 2019 10:16:43 am EST

Hello Alex,

Thank you for your message.

We will try to reproduce the issue to see if there's anything we can do to fix it. Could you please also check if the issue occurs on some other machine where the Windows update is not installed yet if it's possible?

In addition, please try the workaround suggested by J Mo in the message above and see if it helps to resolve the issue.

Looking forward to your reply.

Polina Krasnoborceva, Support (Posts: 961)

Dec 19, 2019 10:20:09 am EST

Hello J,

Thank you for your contribution.

We, in turn, will try to reproduce the issue and see if it's somehow connected with the Microsoft Office "Click-to-Run Update Support" process.

Please do not hesitate to contact us if you have other questions.

Mike Greene, User (Posts: 12)

Dec 19, 2019 11:51:03 am EST

I'm also dealing with this issue.  Viewer machine Win 10Pro.  Host machines range from Win7, Server2012, 2016 and Win10Pro.  All running the latest RU.  (6.10).

Changing keyboard input didn't have any effect.  What I did notice though is if I open an RDP or Terminal session to the remote host the Enter/Shift/CTRL keys work fine.  If I use the RU Full control method I have the issue.

I've uninstalled and deleted the "AppData\Roaming\Remote Utilities Files" folder and re-installed RU on both the host and viewer machines.  No change.

Stopping the MS Click to run service had no effect.

May attempt to roll-back some updates but this is very annoying to say the least.

Polina Krasnoborceva, Support (Posts: 961)

Dec 19, 2019 12:38:09 pm EST

Hello Mike,

Thank you for your message.

Could you please clarify if I'm right in assuming that the issue occurred after the same Windows updates mentioned above were installed on the remote Host machines?

Looking forward to your reply.

Mike Greene, User (Posts: 12)

Dec 19, 2019 12:45:20 pm EST

Not specifically the same updates, my issue came up last month and it was very random which hosts were impacted.  Now pretty much all of my hosts are an issue.  

The viewer (my workstation) had updates done this month and a couple from last month.  I've uninstalled all of them (with exception to KB...338 and 204) they won't go away!

I don't always run the latest updates on remote hosts for a variety of reasons, however I do run the updates on my workstation on a fairly regular basis.

Mike Greene, User (Posts: 12)

Dec 19, 2019 12:51:57 pm EST

I just tested my Win7Pro workstation, latest RU (6.10) and connected to a host I had issues with before, this time it worked fine.  

Attempting a connection to the same host on my Win10Pro workstation I have the issue.  Appears to be Win10 specific.
Page:

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.