Community

Certain keys (Enter, CTRL, Shift etc) not working on Remote Host

Page:
Links used in this discussion

Mike Greene, User (Posts: 12)

Jan 14, 2020 2:52:48 pm EST

Well this is interesting, I downloaded the portable viewer, created two separate directories and extracted the contents of the zip file in each, copied over the Dec 20 build to one of them.

Applied my license, and created one entry in the address book on each version.

Tested both, and both work without issue.

I'm at a total loss as to why everything is working on both versions of viewer but I'll gladly accept it, even though it bugs me that we really don't have a reason why it would suddenly stop and then start working again.

Polina Krasnoborceva, Support (Posts: 959)

Jan 14, 2020 5:45:51 pm EST

Hello Mike,

I'm glad to hear it works for you now!

Could you please answer a few additional questions that might be helpful in identifying the reason the issue might be occurring?

1. Please let me know if I'm right in assuming that the issue does not occur anymore on the same Win 10 Viewer machine when you connect to the Server 2012 Host machines? Would it be possible for you to also check if it occurs when connecting to the Win 10 Pro Host machine where it previously occurred?

2. Could you please clarify if you mean this Windows Defender update?
Version: 1.307.2344.0
Released: 1/14/2020 6:47:16 PM

3. In addition, please clarify if the Unicode input was also set as a keyboard input model for this remote Host machine previously when the issue occurred?

Looking forward to your reply.

Mike Greene, User (Posts: 12)

Jan 14, 2020 6:06:17 pm EST

Answers:

1) Yes, same Win10Pro 1909 machine, connecting to the Win10Pro host is also working fine now
2) Not that specific update number, I had two updates today. (image attached)
3) Both scan mode and unicode tested, both worked fine.

Pretty odd huh?  I really wished it didn't just start working without some sort of concrete reason, but I'm glad it's working because it was a major pain to use the onscreen keyboard.
Attached Files

Polina Krasnoborceva, Support (Posts: 959)

Jan 15, 2020 8:50:24 am EST

Hello Mike,

Thank you for the provided information.

I will forward it to our development team for further investigation. Could you also please answer one last question - please let me know if you have completely uninstalled the Viewer and re-installed version 6.10.10.0 from scratch or if you have just replaced the test version of the Viewer.exe file in the folder to the original one?

Looking forward to your reply.

Mike Greene, User (Posts: 12)

Jan 15, 2020 12:19:14 pm EST

Prior to the Dec 20 rutview.exe file I completely uninstalled and deleted the /app*/roaming/* folders for RU and reinstalled.

I did not uninstall/reinstall the app when using the Dec 20 .exe, I just copied over the file (keeping a copy of the July 2 .exe file elsewhere)

Polina Krasnoborceva, Support (Posts: 959)

Jan 15, 2020 1:16:39 pm EST

Hello Mike,

Thank you.

I'll forward it along with the rest of the information to our developers.

Please let us know if you have other questions.

martin, User (Posts: 1)

Jan 23, 2020 5:40:16 pm EST

Support level: Free or trial
Enter,Ctrl and Shift keys did not work
My situation was resolved by not installing a Office 2016 application.
OS Windows 10 ver 1903 x64
viewer 6.10
host 6.10
OfficePro Plus 2016 15.0.4446 x64 (Click-To-Run)
Ending Tasks did not produce any solution so I built a second system and tested at each install.
OfficePro Plus 2016  Click-To-Run was the repeated problem.
By default Word. Excel ,Access, Outlook .Onenote ,Powerpoint, Publisher, Skype for business and Onedrive for business are installed.

Uninstalling Office and reinstalling without OneDrive for busness repetedly solved the problem.
I did have issues with OneNote but that was a non repeatable result.

Polina Krasnoborceva, Support (Posts: 959)

Jan 24, 2020 9:10:48 am EST

Hello Martin,

Thank you for your input on the issue.

Hopefully, it will help some future users who might encounter the issue and we will certainly take notes regarding the OneDrive uninstallation.

Please let us know if you have other questions.

Alex Shaw, User (Posts: 4)

Jan 27, 2020 4:52:08 pm EST

Support level: Free or trial
DO you have a fix for this yet?  I am unable to uninstall one drive. (nor is that a viable solution).  Martin has given you a way to reproduce this issue.  When do you think a permanent solution will be available?

Greg Vandergriff, User (Posts: 1)

Jan 27, 2020 8:31:45 pm EST

I too have been struck by this "bug".  Of course I didn't notice it until I have upgraded my license :-)
Things I have tried:  
1: uninstalled onedrive
2: disabled the Microsoft "Click to run" service
3: Created new User profile on system

Running Windows 10 pro  1909 build 18363.592

Any new ideas on thing to try?
Page:

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.