Forums

Remote Desktop Window Position

Benny Tucker, User (Posts: 26)

Mar 23, 2017 9:54:49 am EDT

Hello Conrad,
I am trying my best to figure out how to save my RDP screen position. I can edit the .rdp files and position the remote desktop exactly where I want it. Specifically, the parameter "winposstr:s:0,1,300,70,1450,900". This is for a 1024 x 768 window on a 1600 x 900 viewer computer. The other parameters "desktopwidth:i:1024" and "desktopheight:i:768", all remain as they should. However, each time I open the RDP connection from within viewer, the winposstr parameter gets defaulted to the top left corner of the local screen "winposstr:s:0,1,0,0,1600,900". I've tried changing the default.rdp file and the individual rdp files to no avail.
Everything else works just fine, Full Control, View Only, all work great. Just can't get RDP to save the remote screen position. Any work arounds you know for this.
Thanks in advance for your help.
Benny Tucker

Conrad, Administrator (Posts: 1573)

Mar 24, 2017 12:45:02 pm EDT

Hello Benny,

Here is what you can try:

1. In the Viewer address book right click on the connection in question, and select Properties.

2. Navigate to the RDP tab and click Configure. Microsoft RDC window will open. Keep it open.

3. Navigate to  \AppData\Roaming\Remote Utilities Files\rdp_connections , find the file that you were editing and edit what you need then save the file.

4. Now close the RDC window and click OK in connection properties dialog.

Let us know if that worked. Thanks.

Like Remote Utilities? Write a review:
https://www.remoteutilities.com/about/write-review.php

Benny Tucker, User (Posts: 26)

Mar 24, 2017 3:13:17 pm EDT

Hello Conrad,
I have tried your suggestions above, and still no dice. It seems that no matter what I try, the parameter winposstr:s:0,1,300,70,1450,900, gets changed to default winposstr:s:0,1,0,0,1600,900, no matter how I try to save it. All other parameters remain unchanged. With a direct connection, I can click on the .rdp file itself and everything works correctly. It's only when I use the viewer to connect, that the values get overwritten. I can't figure out where the viewer is picking up the default values from. I know that the last two parameters "1600,900" is the screen resolution of the viewer computer.
Thanks Conrad for your help.

Conrad, Administrator (Posts: 1573)

Mar 25, 2017 4:00:14 am EDT

Hello Benny,

We have made the necessary changes to the code - the fix will be available in the upcoming 6.6. That is, you will be able to apply manual changes.

Like Remote Utilities? Write a review:
https://www.remoteutilities.com/about/write-review.php

Benny Tucker, User (Posts: 26)

Mar 25, 2017 7:45:58 am EDT

Thank You, Thank You, Thank You !!! That is awesome Conrad... Much appreciated !!!

Conrad, Administrator (Posts: 1573)

Mar 25, 2017 7:50:09 am EDT

You are always welcome :)

Like Remote Utilities? Write a review:
https://www.remoteutilities.com/about/write-review.php

* Website time zone: America/New_York (UTC -5)