Community

RDP desktop resolution

Links used in this discussion

Pete Burgess, User (Posts: 4)

Nov 18, 2019 8:03:37 am EST

Support level: Free or trial
How can I change the desktop resolution of an RDP connection?

The method for "normal" full-control connections is to set the desktop resolution once logged in but with RDP connections, that's disabled in the OS and the resolution is set when making the RDP connection which isn't available when doing it via RemoteUtilities.

Polina Krasnoborceva, Support (Posts: 1018)

Nov 19, 2019 4:43:36 pm EST

Hello Pete,

I apologize for the late reply.

Could you please elaborate a bit more on what do you mean by the "RDP connections, that's disabled in the OS"?
The RDP mode in Remote Utilities just launches the native Microsoft Remote Desktop Connection client from within Remote Utilities and connects to a remote computer using the RDP protocol. In order to change the desktop resolution for a connection in the RDP mode, please do the following:
1. Right-click on the connection in the address book and select Properties.
2. Navigate to the RDP tab and click Configure:
RDP desktop resolution - 19 Nov 2019 04:44:17
This will open the native Microsoft RDC client.
3. Click Show Options:
RDP desktop resolution - 19 Nov 2019 04:44:28
4. Navigate to the Display tab and select the size of the remote desktop:
RDP desktop resolution - 19 Nov 2019 04:44:41
5. Get back to the General tab and press Save
6. Close the RDC window and click OK in the connection properties window.

Please let me know if that worked.

Pete Burgess, User (Posts: 4)

Dec 10, 2019 1:52:39 pm EST

Support level: Free or trial
Hi Polina (sorry for my late reply!).

The workaround you suggest does work but each time I connect RU creates a new random number port.

There doesn't appear to be a way to set the default connection properties, so I have to go into config every time I connect; I can't click the RDP button to connect full screen.

Polina Krasnoborceva, Support (Posts: 1018)

Dec 10, 2019 5:11:46 pm EST

Hello Pete,

I'm glad to hear it worked for you!

There doesn't appear to be a way to set the default connection properties, so I have to go into config every time I connect; I can't click the RDP button to connect full screen.

Please try to do the following and see if it helps to resolve the issue:
1. In the Viewer address book right-click on the remote connection, and select Properties.
2. In the connection properties window navigate to the RDP tab and click Configure. Microsoft RDC window will pop up, please keep it opened for a while.
3. Navigate to the \Users\username\AppData\Roaming\Remote Utilities Files\rdp_connections folder, find the file that you were editing. It would be easy to spot it by the date:
RDP desktop resolution - 10 Dec 2019 04:54:12

Right-click on the file and select Edit. Specify the resolution settings as needed, then return to the tab General and save the file.
4. Close the RDC window and click OK in the Connection properties dialog.

but each time I connect RU creates a new random number port.

As for the port issue - could you please clarify if you tried specifying the port number in the connection properties window? If yes, then am I right in assuming that each time you open the properties before connecting to the remote Host machine, the port number is changed to another?

Looking forward to your reply.

Pete Burgess, User (Posts: 4)

Dec 16, 2019 4:26:41 pm EST

Support level: Free or trial
What you've suggested regarding finding the RDP file and editing it works but it's the same as changing the screen resolution within the RDP dialog you get by clicking "Configure"

When I open a connection to the server, it creates a new computer name (not port) in the form "localhost:21398" and creates an RDP connection file for that using the default resolution of 1024x768.

If I edit the connection (before connecting) to be resolution full screen, it works but if I save the RDP connection, next time I open a connection I get a different generated computer name and a new RDP file with the default resolution of 1024x768 again!

As I've asked, how can I change the default resolution???

Polina Krasnoborceva, Support (Posts: 1018)

Dec 17, 2019 12:54:03 pm EST

Hello Pete,

I apologize for my somewhat misleading previous replies.

Could you please let me know if I'm right in assuming that you need to set the RDP resolution as fullscreen for all connections that are added to your address book? If this is the case, you can set default connection properties that will apply to all newly created connections.
To set the RDP resolution in the default connection properties, please do the following:
1. In the main Viewer window, select the Tools tab and click Default Connection Properties:
RDP desktop resolution - 17 Dec 2019 12:41:12
2. Navigate to the RDP tab and repeat the steps I've listed in my very first message.
This way, the screen resolution should be set as default for all connections that are created afterward. Also please let me know if the issue with the port number and computer name still persists in this case.

Looking forward to your reply.

Pete Burgess, User (Posts: 4)

Dec 19, 2019 5:22:30 pm EST

Support level: Free or trial
I'd already set the "default" screen resolution to full-screen but it didn't work. I checked again that the default was correct but new connections are still not full-screen.

I then deleted all the RDP files from that folder and opened the default connection settings again as you suggest. This time it wasn't set to full-screen so I changed it and saved the settings file.

Subsequently opening a new RDP connection still does not start in full-screen.

The result is that I have to manually set the resolution every time before opening the connection.

Polina Krasnoborceva, Support (Posts: 1018)

Dec 20, 2019 10:26:28 am EST

Hello Pete,

Thank you for the clarification.

I have forwarded the issue to our development department to see if there's anything we can do in order to fix the issue.

I'll get back to you with their reply soon.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.