RDP connection through RU "reconnects" constantly

Links used in this discussion

Jeffrey Brinkerhoff, User (Posts: 2)

Jun 17, 2017 7:42:03 pm EDT

Support level: Free or trial
I have a client who wants to work remotely. Previously I had port-forwarded port 3389 from the internet to his work PC, and used a dynamic DNS service so he could connect from his home PC. However this leaves a lot to be desired from a security perspective, and we were running into random crashes on his work PC related to bots attacking the RDP port.

I closed the port-forward off, and installed RU on his work PC and home, and it seemed to work fine. Only problem is, anytime there is little to no activity on the RDP session it will drop and "reconnect". This can happen multiple times over a 10 minute span.

I have tested with multiple different PCs on both ends (office and his home) AND I have tested from another site with a totally different ISP (Verizon fios) with the same result.

This did NOT happen with the traditional "port forward RDP" connection we were using before RU.

Since it looks like RU is just tunneling the connection, all I can think is that RU is being very agressive in its connection throttling or something.

I can make it happen by connecting via RU (RDP connection type). Login as normal. Minimize the RDP session and wait about 2min. When maximized again it will say "reconnecting try 1 of 20" and usualy it will reconnect within a few seconds. The same thing can happen if say walking away to answer the phone, and come back 2 mins later - session dead and reconnecting.

Has anyone else seen this? I have tried everything I can think of to try. I want to use RU for this, but we may have to revert to direct RDP, or I may have to install a VPN tunnel instead.

RU is on both ends
Windows 7 pro 64 (fully updated) on both ends
Internet is Verizon FIOS 50Mbit
Nothing remarkable hardware/network wise
Happens with multiple PCs (even clean build) and even with no AV installed.

Thanks in advance

Conrad, Support (Posts: 2589)

Jun 18, 2017 10:45:39 am EDT

Hello Jeffrey,

Thank you for your message.

I closed the port-forward off, and installed RU on his work PC and home, and it seemed to work fine. Only problem is, anytime there is little to no activity on the RDP session it will drop and "reconnect". This can happen multiple times over a 10 minute span.

This is a known problem when RDP-over-ID is used. This is not about Remote Utilities, more about RDP. But we will see how we can fix or eliminate this problem on our end.

That said, there are a couple questions:

1. If you still want to connect directly using RDP, you could change the RDP port or mask it (using different source and target ports in the port forwarding rule).

2. Why not using Remote Utilities own Full Control connection mode instead of RDP?


Jeffrey Brinkerhoff, User (Posts: 2)

Jun 18, 2017 8:40:35 pm EDT

Support level: Free or trial
Thanks for the reply.

Full control works perfectly, however this client is very particular and the refresh rate (click/lag/redraw) in full control mode is unacceptable to him.

I had previously used port masking on his router as well (direct RDP over NAT) but again, we were having issues that I traced to port-scanning bots hitting the RDP port and crashing or locking up the OS. Exposing RDP to the internet seems a bad idea, at least it was causing enough issues for me to say enough and find a better solution.

For the time being I am implementing a VPN at his office, and will use that with standard RDP.

If you fix the RDP over ID issue, please do let me know.

Thanks for a very nice product!

Benny Tucker, User (Posts: 27)

Jun 19, 2017 12:46:25 am EDT

Support level: Free or trial
I have the exact same issues. RDP for me is at minimum 5 times faster, sometimes up to 10 times faster than Full Control mode. I use both regularly, but with Full Control, I have to turn off the wallpaper and other extras, and then it still is slower that RDP. When I have several computers to work on at the same time, it's much easier to see the wallpapers, to help keep up with which computer I'm working on. Hopefully RU will find a way to speed up the screen re-draws, and fix the dropping connections as you mentioned. Otherwise, it works great !!!

Conrad, Support (Posts: 2589)

Jun 19, 2017 4:47:19 am EDT

Hello Jeffrey and Benny,

Actually, RDP (Microsoft Remote Desktop Services) may be the fastest on the market. Not surprisingly, because it comes from the folks who develop the operating system itself.

That said, it only makes sense to compare apples to apples. Namely,

1. If you compare RU's Full Control mode against RDP, you need to use the same connection type. In this case direct connection. It doesn't make sense to compare Full Control over Internet ID with RDP over direct connection.

2. Color depth settings should be the same in both cases.

3. RDP can automatically optimize performance. Currently, RU doesn't adjust performance according to connection speed whereas RDP does.

Still, I'm not saying that RDP isn't faster than Full Control, perhaps it is (due to program architecture and some clever code). I'm only saying that the difference may not be that big if you take into consideration the factors above. Soon we'll implement auto-adjustment too.

All in all, Remote Utilities allows you to get the best of both worlds. So you can work with RDP in RU too, and use RU's powerful address book capabilities to manage your RDP connections. We need to fix that drop issue soon though.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.