Forums

Last IP reported

BartB, User (Posts: 22)

Aug 22, 2016 3:38:05 pm EDT

I'm using my own self-hosted Server. In the Server interface, I see all my Hosts listed, with their external IP's correctly listed. In my Viewer, however, the Last IP column displays the IP address of the self-hosted Server instead of the actual WAN IP of the Host. The exception being the Hosts that are on the same LAN and are being connected to directly.

One other related observation. One Host that has been upgraded to latest beta, 6.4.0.1, and is the same Host that the Viewer is running on, is displaying 169.254.13.154 as the Last IP.

Conrad, Administrator (Posts: 1163)

Aug 22, 2016 4:30:42 pm EDT

Hi Bart,

I'm using my own self-hosted Server. In the Server interface, I see all my Hosts listed, with their external IP's correctly listed. In my Viewer, however, the Last IP column displays the IP address of the self-hosted Server instead of the actual WAN IP of the Host. The exception being the Hosts that are on the same LAN and are being connected to directly.
That is absolutely correct. Hosts that communicate with the Viewer through the server rather than directly are "invisible" to the Viewer, so to say. Their IP address is only known to the server.

One other related observation. One Host that has been upgraded to latest beta, 6.4.0.1, and is the same Host that the Viewer is running on, is displaying 169.254.13.154 as the Last IP.
It all depends on your specific configuration, your network adapters, settings etc. You may have multiple network interfaces and apparently 169.254.x.x is one of those.

BartB, User (Posts: 22)

Aug 22, 2016 5:31:21 pm EDT

Conrad,

Thank you for confirming this is normal and expected behavior. It may be helpful for someone else who was wondering this.

* Website time zone: America/New_York (UTC -5)