Help with initial setup - cannot connect

Links used in this discussion

G Hall, User (Posts: 6)

May 31, 2014 3:56:22 pm EDT

Support level: Free or trial
I'm sure I'm missing something simple in my initial setup of Remote Utilities.  Using version

Have GMS setup with host on the same Windows 8.1 workstation and Dynamic Domain Service which works fine with both FTP connections and local web hosting etc.  RU host is started.  Ports on Viewer and Host set to 5655.  Ports are open on router (5655 and 5670) and Windows Firewall indicates that apps are not blocked.  In the Viewer on a remote Windows 8.1 machine I have the remote connection listed under "other connections" with OFFLINE showing on the thumbnail and a blue dot in the upper right corner.  Double clicking the thumb does not start a remote session.  The thumb changes to || briefly and then back to OFFLINE.

I'm now getting quite frustrated after working for multiple hours on Remote Utilities setup.  Love the features of RU. Just can't get connected.   [censored] has left us high and dry. Jump Desktop with Tight VNC doesn't seem to support file transfer.

Would greatly appreciate any insight available.

Conrad Sallian, Support (Posts: 2589)

May 31, 2014 4:37:37 pm EDT


Thank you for your message.

First, let me elaborate on three possible connection types:

1. Direct connection by an IP address or DNS name. In this case no intermediary server is used. Viewer connects directly to Host.

2. Internet-ID connection: hosted by us[/B]. This is the simplest setup - just follow this tutorial to get everything up and running in seconds. You don't have to change any ports.

3. Internet-ID connection hosted by you (RU Server).[/B] You point both Host (Settings -> Internet ID connection settings) and Viewer (selected connection -> Properties -> General tab -> "Change" button) at your RU Server. Note that for Host this setting is global whereas for Viewer it's on a per-remote-connection basis, that is you can have records in your address book that use different types of connection. Once you specified your RU Server instead of the default ID server at both ends, use the ID of the remote computer in order to connect just like you would do if you used the second type above.

I would recommend you exactly follow the RU Server documentation as it explains everything you need to know for this advanced (yet powerful) option.

Don't hesitate to write here if you didn't have any success with configuration.

G Hall, User (Posts: 6)

Jun 01, 2014 11:41:33 am EDT

Support level: Free or trial
Hi Conrad,

Unfortunately, no luck. I do have a remote idle connection showing in GMS to the remote PC. Viewer still will not bring up a remote session.

Conrad Sallian, Support (Posts: 2589)

Jun 01, 2014 11:57:08 am EDT


If the remote computer successfully connects to the GMS and is waiting for incoming connection, then the problem is certainly on the Viewer side.

Please, check this KB article and especially points 2,  3, 5, 6 , 9 (make sure the GMS address/port are the same on both Viewer and Host sides), and 11.

You can also send a private message via the forum to me with the following info:

- your gms IP address (or DNS if used) and port
- you Internet ID for the remote PC which is currently online and shows as idle in your GMS

So I can try to connect from my place. If the connection is successful, I should see a password prompt.

Conrad Sallian, Support (Posts: 2589)

Jun 01, 2014 3:47:51 pm EDT

I'll continue here so that the full context is available to other support staff.

Ok, I tried to connect but with no success. However, I couldn't ping the GMS' DNS name either. I have a question - is GMS in the same local network as the Host? That could explain why the Host/Hosts had easily connected to the GMS and were shown in the idle list. It can be so that the GMS is misconfigured or is simply not accessible out of the Internet by the DNS name you use. I assume that the computer with the GMS installed doesn't have an external IP address and is only available via a router. Did you set up a port forwarding rule on the router then?  

I recommend you to check back the "Default server" checkboxes on both ends and try to establish remote connection using our default servers (you don't even have to change the ID, although it's recommended to re-generate it just in case).  In this case you will at least get a general idea of how the program works, and then you might want to try more advanced options such as the GMS.  

Hope that helps.

Anton Kalugin, User (Posts: 209)

Jun 03, 2014 12:28:30 am EDT

Support level: Free or trial

I have created a tech support ticket from your message. You will be replied shortly.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.