Remote Utilities 7.0 has been released! Learn what's new and upgrade your license key. (X) Dismiss

Community

Saving Tweaked RDP Configuration

Links used in this discussion

Brant, User (Posts: 7)

Feb 22, 2021 3:35:36 pm EST

Support level: Free or trial
Hi there,

I am running version 6.10.10 of the Viewer and the Host (in this case, the host is on a Windows 7 system, required for support of a legacy program for a piece of specialty equipment).

I am connecting successfully using RDP-over-ID (which is the desired method in this case), and I have created a shortcut for this connection on the Viewer desktop.  All good so far.

What I would like to do is pre-configure the RDP connection parameters (eg., use Full Screen instead of 1024x768, use 24bit colour depth instead of 32bit, etc.).  If I go into the Viewer, right-click on the Host, and go to Properties, I can tweak the RDP settings to my like there and they do work - for that particular session.  But they seem to be lost when the session ends.

I have tried doing a Save of the RDP configuration, and I do see a corresponding ".rdp" file created in the "C:\Users\User\AppData\Roaming\Remote Utilities Files\rdp_connections" folder.  But when I open (edit) that file directly, in Windows, it does not have the same settings that I configured.  It seems to contain the defaults (1024x768, etc.).  Even if I change the settings and save it out again, they don't seem to stick.

Is there a way that I can permanently configure the desired RDP settings and have them remembered so that when I double-click on the desktop short cut, the remote connection will be established as I expect?

Many thanks,
Brant

Polina, Support (Posts: 1247)

Feb 24, 2021 2:06:06 pm EST

Hello Brant,

Thank you for your message.

Could you please clarify if you select the Save button or the Save As...? Could you please try configuring the RDP parameters for a remote connection once again and after doing so, please navigate back to the General tab and click the Save button:
Saving Tweaked RDP Configuration - 24 Feb 2021 01:46:20

Then close the RDP's client configuration window and try reopening it later once again - the properties you've previously set should be saved. In case if the properties are saved correctly this time, please try creating a new shortcut for this remote connection and see if the properties you've set before are applied correctly when connecting to the remote machine.
Please do not open files in the C:\Users\Test\AppData\Roaming\Remote Utilities Files\rdp_connections folder since these are temporary files that are generated when you connect to a remote Host, we only recommend editing the properties for RDP connections via the RDP's client configuration window.
In addition, please note that RDP connection mode in Remote Utilities simply starts Microsoft's own RDP client.

Hope that helps.

Brant, User (Posts: 7)

Feb 27, 2021 5:29:03 pm EST

Support level: Free or trial
Hi Polina,

Thanks for your help.  Yes, it was the Save (not Save As) button that I was using in the first place.  I only started to dig deeper, and modify the ".rdp" file directly in the Roaming area, when things were not working as I expected.

I have followed your instructions carefully, and I still get the same results - my settings are only remembered for the one session.  If I close down RU, and try to connect again (using RDP), I am back to 1024x768 (not Full Screen), etc.

Here is what I do ...

In the RU Viewer, I right-click on the desired Host which I see is online.  I select Properties

Saving Tweaked RDP Configuration - 27 Feb 2021 05:20:20

Then I click on RDP, and click on Configure

Saving Tweaked RDP Configuration - 27 Feb 2021 05:22:26

I configure the desired screen settings (Full Screen, 24bit)

Saving Tweaked RDP Configuration - 27 Feb 2021 05:23:38

I go back to the General tab, and Save

Saving Tweaked RDP Configuration - 27 Feb 2021 05:25:07

When I first Connect, everything is fine. Then I finish my session, and I close down the RU Viewer.  Later, I start up the RU Viewer.  I go to Properties, RDP ... and I can already see that the settings have not "stuck" - they have reverted back to 1024x768, 32bit.

This happens even without the desktop icon.  I suspect that if we can get the Configuration issue resolved, the desktop icon will automatically work just fine.  It is the saving of the RDP Configuration parameters which is not working.

I look forward to your feedback / suggestions.

Cheers,
Brant

Polina, Support (Posts: 1247)

Mar 01, 2021 2:22:29 pm EST

Hello Brant,

Thank you for the provided details.

Allow me to ask one more thing - after configuring connection properties for RDP and clicking the "Save" button, do you proceed with selecting the Connect button?
If this is the case, could you please try closing the RDP properties window after clicking "Save" instead of connecting to a remote Host? Then try selecting the OK button in the RU's own connection properties window - this should save the properties correctly. Please see the screenshot below:
Saving Tweaked RDP Configuration - 01 Mar 2021 02:20:02

Please let me know if this worked for you.

Brant, User (Posts: 7)

Mar 02, 2021 6:12:28 pm EST

Support level: Free or trial
Hi Polina,

Thank you so much.  You hit on the critical item.  Yes, I always assumed that after the Save, the settings were ... well, um ... saved [smile]. So, I always went directly from the Save, to Connect.

It never occurred to me that I had to close the Configuration window after doing the Save, and then click on OK on RU's own window.  (After the fact, I can understand that logic - but it was not intuitive without your help.)

So, now I have success - it remembers the settings.  Not only that, but now the shortcut that I saved to the desktop allows me to connect - with all of my desired preferences - with a single action.  This is exactly what I was looking for.

Thank you again for all your help, and for sticking with this.

Cheers,
Brant

Polina, Support (Posts: 1247)

Mar 03, 2021 12:30:53 pm EST

Hello Brant,

I'm glad to hear I was able to help!

Please feel free to post another message if you have other questions or need further assistance.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.