Community

Error - this authorization method not enabled in remote host settings

Page:
Links used in this discussion

Polina Krasnoborceva, Support (Posts: 1011)

Jan 09, 2020 1:21:21 pm EST

Hello Jay,

Thank you for the provided screenshots.

Could you please send us the full Host log file along with the Viewer logs for examination? Here is how to locate the Host logs and the Viewer logs.
You can send the logs to support@remote-utilities.com.

Looking forward to your reply.

Jay W., User (Posts: 9)

Jan 09, 2020 1:35:00 pm EST

Support level: Free or trial
They're on their way.

Polina Krasnoborceva, Support (Posts: 1011)

Jan 09, 2020 1:49:02 pm EST

Hello Jay,

Thank you.

Meanwhile, could you please try switching the Viewer's language to English, then restart the Viewer and see if the issue still persists? In order to switch the language to English, in the main Viewer window, please navigate to the Tools tab on the ribbon toolbar and sel ect Language.... In the opened window select English and click OK:

Fully exit the Viewer (File -> Exit), launch it again and see if the issue persists.

If the above did not help, then please try cleaning up your installation (including the registry key) and then install the Host fr om scratch. Here is a complete uninstall guide for Host.

Please let me know if the issue persists.

Jay W., User (Posts: 9)

Jan 16, 2020 6:10:23 am EST

Support level: Free or trial
I'm very sorry, it seems that I have wasted your time.
First I tried it with the original language.
Afterwards I ran a RU Host on my machine and tried to connect with no luck.
Then I set the server to the default one and suddenly the "Enter your password" prompt box popped up.
So I guess my problem is due to a self hosted server which I expect to be out of version... Maybe you could build this into your following viewers: Some kind of message if the version is too old? :)
P.S.: I'll recheck this by any means since it really interests me. Could even be a blocked port by my router (the external router-server runs on a special port).
Edited:Jay W. - Jan 16, 2020 6:12:30 am EST

Polina Krasnoborceva, Support (Posts: 1011)

Jan 16, 2020 9:55:26 am EST

Hello Jay,

I'm glad to hear you've figured out the issue!

So I guess my problem is due to a self hosted server which I expect to be out of version... Maybe you could build this into your following viewers: Some kind of message if the version is too old? :)

Yes, the version mismatch between Remote Utilities modules may lead to performance issues and some features not working. Please double check that the RU Server is updated to the most recent version (as of this writing it's 2.8.2.0, it's available for the download here). Please note that if the self-hosted server (RU Server) is used, it's highly recommended to update it to the most recent version too.
As for the suggested feature - we already have a similar feature for the Host, (e.g. once the newer version of the Host is available, an exclamation point appears next to the remote connection in the address book). We also already have a similar feature for the RU Server in our wishlist and it will be implemented in our future updates.

I'll recheck this by any means since it really interests me. Could even be a blocked port by my router (the external router-server runs on a special port).

Of course, please feel free to let us know if there are any updates on what was causing the issue. Also, here's an Internet-ID connection troubleshooting guide that might be helpful in determination of the issue's reason.

Please let us know if you have other questions.

Jay W., User (Posts: 9)

Jan 21, 2020 6:44:35 am EST

Support level: Free or trial
UPDATE: Well this might be very important for the developers (where's the blinking red font bbcode? ;) ) !!! First have a look at my screenshot, there's something messed up with the german carrier returns.
Here comes the magic: So my friend set up a custom routing server. On my Viewer clients I was logged in there automatically. Whenever I tried to connect to a host, that was NOT configured to be in connection with this custom routing server the authorization failed regardless of this!!! When I configured the test host machines to use the public routing server, and logged out of the custom routing server (upper right corner) I had NO PROBLEMS and could finally enter my password. When I am not signed in the custom routing server, I can even connect to the host via the custom routing server via local network!!
What might be interesting: The connection worked on the most machines within the same local network, but never via Internet. Hence, I couldn't even built up a connect from within the host's network with a local IP. I think this needs to be deeply reviewed, as if there are bugs you may want to bust 'em. :P
One tiny thing I also encountered: If you switch back from custom routing to default routing server, it seems like it is still the port of the custom one active. Please have a look and tell me if maybe I did something wrong, because I dont wanna charge you for my stupidness. Have a very nice day!
P.S.: I just retried it with the portable version and had problems to connect. The installable Viewer works just fine. Feel free to mail me if you have any questions.
Attached Files
Edited:Jay W. - Jan 21, 2020 8:01:50 am EST

Polina Krasnoborceva, Support (Posts: 1011)

Jan 21, 2020 11:04:49 am EST

Hello Jay,

Thank you for your input.

there's something messed up with the german carrier returns

This is a known issue caused by a typo in the localization file for the German language. We will implement a fix for it in the next update. I apologize for the inconvenience.

Could you please let me know if I'm understanding everything correctly - the issue occurs when you are logged on to the RU Server in the right upper corner of the main Viewer window, so it's not possible to establish a connection to a remote Host which did not use your custom server as its' relay server? Could you please also clarify if it was possible to connect to the Host machines that were using the self-hosted server as their relay server?
In addition, please let me know what roles did you use the RU Server in, i.e. Adress book sync, Relay Server or Authorization?

Looking forward to your reply.

Jay W., User (Posts: 9)

Jan 21, 2020 2:02:31 pm EST

Support level: Free or trial
Not exactly. It's not possible for me to establish a connection to *any* remote Host when I'm signed in the custom routing server. In the portable version goes nothing. Additionally, If I'm not signed in and in the same local network, I can connect to the host with the custom ID server. Of course, If I sign out and wait too long, the Host is shown as offline and I can't connect to it.
We have an address book sync on the relay server. The authorisation is always the same: single password. So there's no special user permission control configured if you ask for that. But if there could be some misconfiguration that would lead to the described symptoms, please let me know and I will recheck that.
Edited:Jay W. - Jan 21, 2020 2:03:30 pm EST

Polina Krasnoborceva, Support (Posts: 1011)

Jan 21, 2020 4:52:06 pm EST

Hello Jay,

Thank you for the clarification and provided details.

We will try to reproduce the issue. I will forward the issue to our developers and ask for their input on this as well.

I'll keep you updated.

Nándor Árgyelán, User (Posts: 2)

Mar 16, 2020 12:06:48 pm EDT

Support level: Free or trial
Hi,
I have similar error, when i use self hosted server. I have no problem when i use the default server.
I use the versions below:
6.10.10.0 host,
6.10.10.0 viewer,
2.8.2.0 server
When I try to connet to the host, the following message appears: "This authorization method is not enabled in remote Host settings", but the server show the active connection.
I use single password authorization, that you see in attached pictures.
I attached a diagram that show our networks.

Can someone help please?
Page:

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.