Forums

RDP resolution can not be changed

Geoff Patton, User (Posts: 3)

Mar 21, 2014 2:42:56 pm EDT

RDP resolution defaults to 1024X768 when launched from Remote Utilities.

If you login to a computer connection and then you sel ect the properties you can select the RDP press configure and chose a different resolution before connecting and then press the connect button. It is not saved for the next time you connect even i you press save in the RDP configuration form. Also when you select the properties to get to RDP it locks the Viewer so you cannot make a second connection to another computer.

To get the resolution I want I currently fully connect with RDP and then disconnect the RDP session. The port number RDP uses changes every time you Login to the Remote Utilities connection for a computer. so this make sure it is correct in the file Remote Utilities saves.

Then I go to C:\Users\HP User\AppData\Roaming\Remote Utilities Files\rdp_connections and edit the rdp file for the computer I am connecting to in notepad, edit the resolution, save it and then double click on it.

It looks like that every time you make and RDP connection fr om Remote Utilities it creates the rdp file and it is hard coded to use the 1024x768 resolution.
Edited:Geoff Patton - Mar 21, 2014 2:43:42 pm EDT

Anton Kalugin, User (Posts: 210)

Mar 21, 2014 3:37:13 pm EDT

Hello, Geoff.

Thank you for your message.

You can set default settings for every computer by following these steps:
1. Open connection properties
2. Go to the RDP tab
3. Press Configure
4. Change resolution on the Screen tab
5. Get back to the General tab and press Save
6. Close the RDP settings and press OK in the connection properties window

Now the resolution is default.

Geoff Patton, User (Posts: 3)

Mar 21, 2014 3:46:05 pm EDT

As I originally said pressing the Save button in RDP does not work.

EDIT: I just tried it again and it worked. I don't know if it was because I closed Viewer and then started it back up or if maybe I was not pressing the OK button on the properties and was pressing the red X close box.

Now If I could just specify a a non standard resolution...
Edited:Geoff Patton - Mar 21, 2014 4:09:10 pm EDT

Anton Kalugin, User (Posts: 210)

Mar 22, 2014 1:18:06 pm EDT

Hello again, Geoff.

Unfortunately, you can only use a resolution that is supported by standart RDP settings.

Geoff Patton, User (Posts: 3)

Mar 25, 2014 10:11:54 am EDT

Actually I just figured out how to :) .
1. Open connection properties
2. Go to the RDP tab
3. Press Configure
4. Change resolution on the Screen tab
5. Get back to the General tab and press Save
6. Close the RDP configuration window but leave the Remote Utilities properties window open.
7. go to C:\Users\<User>\AppData\Roaming\Remote Utilities Files\rdp_connections (where <User> is the current user logged in to windows) and edit the rdp file for the computer to be connected to in notepad, edit the resolution,
desktopwidth:i:1280
desktopheight:i:710
Save the file and close notepad.
8. Press OK on the Remote Utilities properties window.

When OK is press to on the Remote Utilities properties window It looks like Remote Utilities reads the rdp file and saves the configuration in itself somewhere because if you just go and edit the rdp file and then start an RDP session Remote Utilities overwrites the rdp file with whatever has been last saved into it for that computer connection.

Anton Kalugin, User (Posts: 210)

Mar 25, 2014 5:38:50 pm EDT

Hello, Geoff.

Glad to hear you have found a workaround :)

* Website time zone: America/New_York (UTC -4)