Can't See Pointer on Host Computer

Links used in this discussion

RUSerious, User (Posts: 5)

Aug 19, 2020 3:38:09 pm EDT

Support level: Free or trial
NOTE: I am going to use the term "Pointer" to indicate the little graphic that moves around when you move around the mouse. RU settings seem to use both "Pointer" and "Cursor" to sometimes mean the same thing.

I am testing out RU to hopefully use for remote training. For testing purposes, I am connecting to the host machine remotely using a remote desktop connection (specifically Cisco AnyConnect). The host machine at work (W10 Pro) is running v6.10.10.0 Run-only Agent. The remote machine at home (W10 Pro) is running v6.10.10.0 Portable Viewer. Both machines have working mice and keyboards.

The connection works fine, both host and remote screens are the same resolution, so all is behaving properly, except the pointer is not visible on the host machine. Highlights and tooltips show up when the pointer hovers over a location, but you can't see the pointer itself from the host machine. The reason this is important is that I want to be able to move the pointer around something on the screen (for example, circling the pointer around a specific area to draw attention to it).

Now maybe this issue is simply because I am connecting to the host computer remotely, and if someone were actually physically in front of the host computer, they would see the pointer, but I haven't been able to get another person to sit there to test it that way just yet.

I also tried running the viewer from another office machine (W10 Pro) and connected to that computer using AnyConnect as well, and then used RU to connect between the viewer and the host (so I was remotely connected to both computers), and I still experienced the same issue with the pointer.

I can see the pointer on the Viewer computer regardless of which side is controlling it.

I played around with some various settings ("Local Mouse Pointer" & "Rendering of hosts cursor") on the viewer, but this had no effect. I didn't see anything similar on the Agent application, so I wasn't able to test out anything on that end.

Without RU running on the host machine, the pointer shows up just fine.

Any suggestions as to what else I can try?

Polina, Support (Posts: 1157)

Aug 19, 2020 5:17:54 pm EDT


Thank you for your message.

Am I right in assuming that you've already tried switching the "rendering of hosts cursor" to Always but it did not make any difference as well? If this is the case, then could you please try enabling the Use legacy capture mode feature in Settings for Host/Agent -> Other tab and see if this helps to resolve the issue?

In addition, I recommend that you update Remote Utilities to the latest 6.12 Beta 2 version as the issue might have already been resolved in the most recent update.
Version 6.12 Beta 2 is available for the download on this page. Please make sure to use Agent and Portable Viewer of the same versions as the version mismatch might also lead to performance issues or some features not working.

Finally, in case if the issue persists even when using the latest 6.12 Beta 2 version, then could you please provide us a screenshot (or, perhaps, even a short video, if possible) of the issue? You can upload it here or send it to

Hope that helps.

RU Serious, User (Posts: 5)

Aug 19, 2020 5:23:37 pm EDT

Support level: Free or trial
Yes, I did try the "Always" option (before I made my original post). I'll try the legacy mode, and if that doesn't work, I'll try the beta.

If those don't work I'd be happy to give you a screenshot (unfortunately, I can't do a video) - but how do I show you a screenshot of a pointer that isn't there?
Edited:RU Serious - Aug 19, 2020 5:25:10 pm EDT

RU Serious, User (Posts: 5)

Aug 20, 2020 7:39:08 am EDT

Support level: Free or trial
Unfortunately, none of the suggested options resulted in a visible pointer.

I tried enabling legacy capture mode - still no pointer.

I then tried beta agent and beta portable viewer (and tried the various options I used with non-beta, including legacy capture) - still no pointer.

BTW, I tried connecting to the host machine using both the 'Internet-ID-connection' and the 'Direct connection' options - no difference in pointer visibility.

I uploaded a dual screen shot (viewer on left, host on right) showing the discrepancy between the two screens. You can see the pointer on the left, but it's missing on the right (though the drop-down menu selection is clearly shown).

Can't See Pointer on Host Computer - 20 Aug 2020 07:36:51

I also discovered (remembered) a temporary work-around: I enabled the option "Show location of pointer when I press the CTRL key" (under Windows 'Mouse Properties' -> 'Pointer Options' - see my other uploaded screenshot). This creates an animated series of diminishing concentric circles focused on the pointer location. While it's not as useful as my moving the pointer around a specific section of the screen, the moving circles should at least help to get the user's attention to where the pointer is. I just have to keep remembering to do this (since I will still be seeing a pointer on my side of the connection).

Can't See Pointer on Host Computer - 20 Aug 2020 07:36:56

Now all of this may be moot if the pointer is visible to a user who is actually sitting in front of the host monitor. Once I am able to get someone to do that (probably not until next week), I'll post here and let you know the results.  In the meantime, let me know if there's anything else I can try.

Polina, Support (Posts: 1157)

Aug 20, 2020 9:54:38 am EDT


Thank you for the clarification.

Could you please confirm if the second screenshot, i.e. the Host screen where the cursor is invisible, is what you see on the remote screen using the 3rd party software (during the active remote session) and not on the actual physical remote screen? If this is the case, then this might be caused by some specifications of the 3rd party software.

In addition, please note that the cursor is always visible on the physical screen of the remote machine and follows the movement of your local cursor on the Viewer's side.

Looking forward to your reply.

RU Serious, User (Posts: 5)

Aug 20, 2020 11:20:43 am EDT

Support level: Free or trial

Yes the screenshot is what I saw connecting to both machines remotely using [censored]. I experienced the same issue when the viewer was my local machine, but I was still looking at the host through [censored].

The computer in question controls laboratory equipment at our university, and I mainly need to train users on the software that controls this equipment. Because of social distancing guidelines, the room with both the computer and lab equipment is now too small to have more than one person at a time. Therefore, because of the pandemic, I am trying to figure out how to remotely do training sessions (which I used to do in person before the pandemic). Since I am currently doing all my work remotely, I've been testing out various screen sharing programs as much as I could by pretending to be both student and teacher (and performing both roles remotely).

As I said at the end of my previous message, I realize that this pointer 'problem' may not actually exist once I am able to have someone sit in front of the host monitor. I just have no way of knowing yet if that is true (other than taking your word). Once I can confirm that a user in the room with the host system can see the pointer when I move it around, I will let you know (and will obviously let you know if they can't see the cursor). I just started using RU this week, so I had no idea if this problem was a known issue, or simply a result of my viewing both machines remotely.

By the way, thank very much for your prompt replies. That means a lot more than you may realize!

Polina, Support (Posts: 1157)

Aug 20, 2020 5:36:19 pm EDT


Thank you for the clarification.

Of course, I understand the situation. However, I've checked on the issue with our developers - they confirmed that it's most likely that the cursor is not displayed this way on the 3rd party software's side. We recommend that you also refer to the corresponding software's support service as according to our Support Policy we cannot assist in resolving issues with third-party software.

In addition, please note that I modified the previous messages as mentioning competitor links and product names are not allowed on our forum. For more information please refer to our Community forum rules.

Please let us know if you have more questions.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.