Community

RU v6.10.10.0 with TEMP variables on RamDisk -> Error 2755

TheDutchJewel, User (Posts: 3)

Jul 27, 2019 2:36:59 am EDT

Thanks for your reaction, Pepa.

After some more testing, I found that the biggest problem is the execution of an MSI file from a ramdisk in Windows 10 v1809 or newer.

Probably - as you wrote - because the Installer service prevents access to the actual MSI file that was extracted from the original EXE.

That is why MSI saved-to-EXE files cannot be installed when TEMP folders are used on a ramdisk, but also why the MSI file can only be installed from a physical disk.

RU v6.10.10.0 with TEMP variables on RamDisk -> Error 2755

TheDutchJewel, User (Posts: 3)

Jul 25, 2019 12:53:58 pm EDT

The problem is not my understanding of the TEMP variables, but only that RU does only support TEMP paths on the C drive.

The question is if it's possible to implement/accept TEMP paths also on other drive letters, like R.

RU v6.10.10.0 with TEMP variables on RamDisk -> Error 2755

TheDutchJewel, User (Posts: 3)

Jul 24, 2019 6:53:46 am EDT

On my pc with Windows 10 x64 v1903 I use a RamDisk which is created by ImDisk Toolkit<br>.
With the RamDisk Configuration of ImDisk Toolkit I've set the User and System TEMP variables to R:\Temp, instead of %USERPROFILE%\AppData\Local\Temp and %SystemRoot%\TEMP.

But when I try to install the Host of Remote Utilities v6.10.10.0, I get this error:

Remote Utilities - Host Installer information
The system cannot open the device or file specified.

After [Cancel] I get this error:

Remote Utilities - Host Installer information
Error 2755: Server returned unexpected error 110 attempting to install package R:\Temp\RUT_{700E7500-CB11-46F6-AC49-012A3749BD3F}\installer.msi.

Btw, R:\Temp\RUT_{700E7500-CB11-46F6-AC49-012A3749BD3F}\installer.msi exist.

After [OK] I get this one:

The wizard was interrupted before Remote Utilites - Host could be completely installed.
Your system has not been modified. To complete installation at another time, please run setup again.
Click Finish to exit the wizard.

Only after resetting the TEMP variables I can install the Host.

Is it possible to fix this bug?
This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.