Recurring Intermittent Problem with Installed Version of RUTVIEW

Links used in this discussion

Davd Cichy, User (Posts: 4)

Jul 28, 2020 5:10:56 pm EDT

Support level: Free or trial
I have a paid starter license and have been using Remote Utilities for a couple of years now.  I run the installed version of Viewer (not portable) on both Windows 7 and Windows 10.

Fr om time to time, Viewer reports that every single host is offline when they are not.  I have tried everything when this happens to get Viewer to refresh and find the online hosts to no avail.

Everything includes suspending or stopping any/all running firewall and virus protections software, KILLING any/all instances of RUTVIEW.EXE, running the viewer portable version, adding a new connection to see if that will find a known running host, logging off the current windows user and back on .

NONE of these things work.  The ONLY way I can get RUTVIEW.EXE to start behaving correctly is to freaking reboot my PC which sucks when I am developing code and have a 100 browser windows open.

WHY does this keep happening?

Any suggestions on how to reset RUTVIEW and get thing working without rebooting my computer?  This has been consistently happening for two years.  I am on 6.10.

Also, I saw another post wh ere the moderator suggested trying to PING

. I tried that and it FAILED. I can ping no problem, but now with the id. prefix.
Attached Files

Polina Krasnoborceva, Support (Posts: 1011)

Jul 29, 2020 12:47:17 pm EDT

Hello Davd,

Thank you for your message.

The issue might be caused by some connectivity problems, especially since you've mentioned that pinging is unsuccessful, as this is our public ID servers' DNS name that is used for Internet-ID connections. This might be caused by various reasons - for example, some antivirus programs may block Remote Utilities, put it into a “restricted” group or even delete the program files they suspect to be malicious. The issue might also be occurring if there are issues with DNS resolution on any sides of the connection.

Please try the following solutions and see if any of them help to resolve the issue:
1. Try updating your Remote Utilities installations to the latest 6.12 Beta 2 version. We had a similar issue in version that sometimes caused connections in the address book to briefly go offline even on a stable Internet connection, but it was fixed in the subsequent release. In this case, the issue you're encountering might have also been fixed in the latest Beta version release. Here you can find a full list of bug fixes and improvements:
When updating Remote Utilities please make sure to update both Host/Agent and Viewer as the version mismatch might lead to performance issues and some features not working.
2. Try flushing the DNS cache by executing the following command in the command-line interface:
ipconfig /flushdns
3. Please try whitelisting the domain with a mask * This will whitelist our website and addresses of our Internet-ID servers (

In addition, here's a related KB troubleshooting guide that provides solutions for the most common issues when using Internet-ID connection:

Please let us know if the solutions above did not help and the issue persists.

Davd Cichy, User (Posts: 4)

Jul 29, 2020 1:51:08 pm EDT

Support level: Free or trial
If must be reachable, then this has to be the root cause of my issue.  I cannot ping this URL at all.  My network (at the moment) is blind to it completely.

As you can see from that attached image, I can ping REMOTEUTILITIES.COM all day long, but NOT

Turns out we are using CLOUDFLARE for DNS and while can resolve, they are 100% blocking
. So, I'm going to either have to get CloudFlare to add to their list or change my DNS provider
Attached Files

Davd Cichy, User (Posts: 4)

Jul 29, 2020 2:01:37 pm EDT

Support level: Free or trial
Just to verify and close out this issue, it WAS CloudFlare's DNS servers that were COLD blocking your address.

I reverted our DNS to Google's and and all of my remote hosts started showing up again.

Polina Krasnoborceva, Support (Posts: 1011)

Jul 29, 2020 3:55:10 pm EDT

Hello Davd,

I'm glad to hear that you've figured out the issue!

Please feel free to post another message if you have more questions. We're happy to help!

Davd Cichy, User (Posts: 4)

Jul 29, 2020 4:11:21 pm EDT

Support level: Free or trial
Thanks for the follow up.  In my opinion, it would be worthwhile for your organization to inquire of CloudFlare as to WHY, they are blocking the IP address of your identity server.  I think it is by accident b/c your base domain name is NOT being blocked.

CloudFlare is becoming quite dominant as a DNS provider at and provides faster name resolution than even Google.  You don't want them accidentally crippling your service.

Also, I have now been forced to STOP using their DNS service and the protective benefits it afforst just so I can continue to run Remote Utilities.

Polina Krasnoborceva, Support (Posts: 1011)

Jul 29, 2020 5:58:52 pm EDT

Hello Davd,

Thank you for the suggestion.

Of course, we will definitely contact them and request to whitelist It would be very helpful if you could contact them as well, as their customer, and report on the issue. We believe they would take reports from their customers into consideration much faster.

Please let us know if you have more questions.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.