Remote Utilities Viewer for Mac andLinux has been released. Send us your feedback and report bugs in this discussion thread.

Server Address Book missing

Links used in this discussion

Cristian Braun, User (Posts: 32)

Jul 20, 2018 4:24:39 pm EDT

I was trying out the server roles, address book sync to be more specific.
Im having this problem: The address book just desappears.
Sometimes (just sometimes) if i manually stop and start the mini internet ID service, the address book reappears. But most of the times, it doesnt.
I show you an image:

I cant create a new one, i cant right click, if i press "Edit" nothing happens.

This is happening both in and the new beta

Conrad, Support (Posts: 2450)

Jul 22, 2018 2:51:15 am EDT

Hello Cristian,

Thank you for your post.

It looks like your admin console has difficulty accessing the data folder. The address book is located here  C:\Program Files (x86)\Remote Utilities - Server\data .

Did you try restarting the computer since you installed the server?

Cristian Braun, User (Posts: 32)

Jul 23, 2018 2:41:07 pm EDT

Yes i did! Several times.
Sometimes, i can see it at first, but when i access for the second time, its already gone.
I algo tried to delete all files on C:\Program Files (x86)\Remote Utilities - Server\data, but it keeps happening :(

Cristian Braun, User (Posts: 32)

Jul 24, 2018 1:54:08 pm EDT

I see that im not the only one with this problem (

For now, i deleted all data on "data" folder, restarted the machine, and reconfigure the address book again.

Its working, at least for now

Conrad, Support (Posts: 2450)

Jul 25, 2018 4:39:34 am EDT

Hello Cristian,

Thank you for the update. Please, let us know if the problem persists in the future.

Steven Coleman, User (Posts: 21)

Dec 10, 2018 9:20:58 am EST

Support level: Starter
I am having the same issue with RUS I am running Windows 7 64 with all the latest patches.  I uninstalled all anti-virus programs. The RUS server_log does not show any issues. It just shows the server starting and listening. I can get it to work sometimes by restarting the service but it keep happening.

I also noticed the the address book appears to work again initially after rebooting the computer. However once the remote connections start reporting as idle the address book goes blank again. I really want to purchase this product but I can't without a working address book sync feature.

I used process monitor to confirm the data.xml and address books are being read by the Internetldservice on start up with no access issues. See image below. The file is on the E: drive because I also tried changing the default install location to see if there was a drive access issue.

Edited:Steven Coleman - Dec 10, 2018 12:26:11 pm EST

Conrad Sallian, Support (Posts: 2450)

Dec 10, 2018 3:16:53 pm EST

Hello Steven,

Approximately how many connections do you have in your address book (books)? I mean the books synced through the server.

Steven Coleman, User (Posts: 21)

Dec 10, 2018 3:24:46 pm EST

Support level: Starter
I created three address books on the server. Two books have 4 connections each and one book has no connections configured.

Conrad Sallian, Support (Posts: 2450)

Dec 10, 2018 3:46:31 pm EST

Thank you. Further questions:

1. Will connectivity restore if you restart the admin panel (InternetIdAdmin.exe) without restarting the service (InternetIdService.exe)?

2. At the moment when this issue occurs do the Viewers keep syncing the address book normally, or does the sync break as well? You can tell if the address book sync works normally in the Viewer by the address book icon - a regular cloud says it's ok, whereas a cloud with an exclamation sign says that there's no connectivity with the sync server or sync isn't possible.

Looking forward to your reply.

Steven Coleman, User (Posts: 21)

Dec 10, 2018 4:03:20 pm EST

Support level: Starter
Restarting the Admin panel (InternetIdAdmin.exe) never resolves the Address Book issue. Restarting the service (InternetIdService.exe) gives you access to the address books for about about 30 seconds - 1 minute. After that time you can't edit it anymore and it goes blank again if you exit and go back into the address book manager.

The sync breaks as well from the viewer. You can't sign in to the server anymore when the address books show up blank on the server.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.