Access violation when ending session

John Geraghty, User (Posts: 3)

Jun 04, 2016 1:39:29 pm EDT

I can connect from my guest machine (Windows 7) to different hosts (Windows 7, Windows Server 2012 R2) with no problems. I am using

However on closing any of the connections I get an error dialog:

Error (EAccessViolation): Access violation at address 0093D190 in module 'rutview.exe'. Read of address 00000058.

Class: EAccessViolation
Text: Access violation at address 0093D190 in module 'rutview.exe'. Read of address 00000058
Version: 63006 (0)
Id: {C30E2158-6EED-4D4B-8777-6D61ADDB699A}

This occurs repeatedly (though the addresses may vary) and I have to close rutview.exe from the Windows Task Manager.

I have added the Remote Viewer folder to the exceptions list for my anti-virus software (AVGFree) as described elsewhere (though that appears to relate to an error when starting sessions).

It is frustrating to have to close the program using the Task Manager every time I use it. Is this a known problem?

Edited:John Geraghty - Jun 04, 2016 1:45:08 pm EDT

Conrad, Administrator (Posts: 1118)

Jun 04, 2016 3:12:43 pm EDT

Hello John,

Thank you for your message.

Most likely your Viewer configuration files are corrupted somehow. They are stored in your user account folder rather than in the program installation folder.

Here is a related troubleshooting article:

Hope it will help.

John Geraghty, User (Posts: 3)

Jun 04, 2016 3:36:16 pm EDT

Conrad -

Thanks for the message. I have tried this and unfortunately the behaviour is still the same. Please note also that the problem occurs when closing a session, not starting one (which appears to be the circumstances described in the article).


Conrad, Administrator (Posts: 1118)

Jun 04, 2016 4:24:13 pm EDT

Hi John,

The trick is that you should completely uninstall the Viewer. Alternatively, you can just navigate to C:\Users\YOUR_USERNAME\AppData\Roaming\Remote Utilities Files\ (exit the Viewer first) and delete the file config_4.xml. This file contains Viewer options - in most cases the error appears because of the corrupted file.

Then start the Viewer again and see if the error persists.

John Geraghty, User (Posts: 3)

Jun 05, 2016 11:21:34 am EDT

Conrad -

Unfortunately that still hasn't fixed the problem. The latest message in the dialog box is the same as previously (incidentally, I note that as I close each dialog box and a new one pops up, the 'Id' value changes).

Conrad, Administrator (Posts: 1118)

Jun 06, 2016 9:31:47 am EDT

Hello John,

I moved this discussion to support tickets so that we could forward it to our 2nd tier support. You should have received an email by now about creating a new ticket.

Your tickets are available here (log in required).

* Website time zone: America/New_York (UTC -4)