Remote Utilities Viewer for Mac andLinux has been released. Send us your feedback and report bugs in this discussion thread.

Anybody else having trouble getting direct connection to work


Ron Brennan, User (Posts: 40)

May 07, 2017 8:11:06 pm EDT

Up-to-date Windows 10 Pro; Remote Utilities

I have Private Internet Access installed on the host but not connected.

In summary, I've disabled my anti-malware and firewall (both Bitdefender 2017), and bypassed my router with a direct connection to my computer.

The following Powerscript cndlet successfully pings the socket but fails the TCP connection test:

Test-NetConnection <domain-name> -port 5650 -InformationLevel Detailed

I've had Remote Utilities version 6.5 (maybe earlier) running on earlier versions of this platform (router firmware, OS, security software) with a direct connection.

Everything works fine with an Internet-ID connection with 6.6; however, I need Wake-on-LAN which is available only with a direct connection.

Is anybody else having a problem connecting with a direct connection?

Does anybody have any suggestions?

Benny Tucker, User (Posts: 27)

May 07, 2017 8:56:30 pm EDT

If you are connecting over VPN, try using the IP address instead of domain name. That has worked for me in the past.

Ron Brennan, User (Posts: 40)

May 07, 2017 9:00:32 pm EDT

No, I'm not trying to connect over a VPN. I mentioned that it is installed, but it's not connected when I'm trying to get a direct connection with Remote Utilities.

I did try using an IP address instead of a domain name, but that didn't help.

Thanks for the suggestion though.

Benny Tucker, User (Posts: 27)

May 07, 2017 9:15:30 pm EDT

A couple of questions:
1. When you say that you bypassed your router, do you mean that you opened a port for RU ?
2. Are both computers on the same network ? RU version WOL only works on the same network.

Conrad, Support (Posts: 2457)

May 08, 2017 6:59:19 am EDT

Hi Ron,

Could you check if your Windows firewall is on?

Ron Brennan, User (Posts: 40)

May 08, 2017 9:01:57 am EDT

1. By bypassing my router, I meant that I connected the cable from my modem directly to my computer (disconnecting the cables between my ISP and my router, and my router and computer).

2. Yes, in my original test, both the Host and the Viewer were on the same subnet. However, I cannot even log on with a direct connection; it isn't just WOL I can't get to work.

3. WOL does work over the Internet I believe.

4. After I went to bed I remembered that I forgot to mention above that Windows firewall was turned off too, as was Windows Defender. (I realize that Windows firewall is automatically turned on when one turns off Bitdefender.)

5. Summary of Test-NetConnection test run on Host machine:

The Host was running correctly as confirmed by a previous successful Internet-ID connection
The Router was physically disconnected from host
All Bitdefender firewall and all Bitdefender anti-malware settings turned off
All Windows Firewall settings turned off
Windows Defender settings turned off
No other defensive software nor VPN software running
Powershell Test-NetConnection test on Host returns success for ping and failure on TCP

This morning I think I try to find a copy of the RU version I had running a few months ago and try that. I think I've narrowed the possible explanations down to my having repeated the same error over and over again or a version 6.6 bug.

Conrad, Support (Posts: 2457)

May 08, 2017 9:04:33 am EDT

Hi Ron,

I sent you an older version via the tickets. Feel free to install it and check if it works for you. For proper experimentation, please keep other factors unchanged.

Ron Brennan, User (Posts: 40)

May 08, 2017 1:02:08 pm EDT

Benny Tucker wrote:

try using the IP address instead of domain name

Benny, you were correct and I was wrong. I tried the PowerShell Test-NetConnection cmdlet again with the domain name and it came back TcpTestSucceeded: false; with the IP address it came back with TcpTestSucceeded: true. I was obviously wrong when I said that I had already tried it.

I'm still working on my direct connection problem.

Would someone please verify that they have been successful in using a direct connection with RU version

Conrad, Support (Posts: 2457)

May 08, 2017 1:14:25 pm EDT

Hi Ron,

Would someone please verify that they have been successful in using a direct connection with RU version

As a support person, I can only confirm that there was not a single complaint that direct connection in RU wasn't working. We have plenty of customers/users who use direct connection in RU, both on a LAN and WAN,  and they would immediately let us know about the issue. Version has been around for a week already.

Did you try to set up Host on another computer in the same network. Preferably a computer without BitDefender installed. Antivirus software nowadays is extremely intrusive and always tries to decide for the user what they can and cannot run, even if they explicitly allow something or turn off the a/v application.

Ron Brennan, User (Posts: 40)

May 08, 2017 1:23:57 pm EDT

Many people using direct connection and my being the only one having a problem is definitive and reassuring. The fix should be easy when I find it.

All my machines have Bitdefender Total Security 2017 installed.

I'll try reducing my environment to a minimum (no router, Bitdefender uninstalled, Windows Firewall and Defender disabled) again, on another machine, and keep looking for the problem with installed.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.