Where is the Linux viewer?

Jonathan Brickman, User (Posts: 1)

Jun 21, 2012 11:13:10 pm EDT

I didn't see a place from which to download the Linux viewer; can you direct me?

Conrad Sallian, Administrator (Posts: 1115)

Jun 22, 2012 2:10:04 am EDT


Viewer works on Linux under 'Wine'. Use the regular Viewer download link.

nikkil, User (Posts: 50)

Jan 27, 2013 8:43:45 am EST

Thanks. Wine looks like open source and might be a tough one to set up. Has anyone tried to set this up yet?

You're never a loser until you quit trying.

Conrad Sallian, Administrator (Posts: 1115)

Jan 28, 2013 6:33:22 am EST

nikkil wrote:
Thanks. Wine looks like open source and might be a tough one to set up. Has anyone tried to set this up yet?
Wine is no more touch to set up than Linux. It's the matter of choice though - if one uses a Linux they should be ready to do some manual labor. :)

levent özgür kaplan, User (Posts: 17)

Mar 04, 2013 5:25:32 pm EST

with wine not work!

Conrad Sallian, Administrator (Posts: 1115)

Mar 05, 2013 1:42:11 am EST

levent özgür kaplan wrote:
with wine not work!
How do I install the Viewer for Linux using Wine

Nate Bergeron, User (Posts: 4)

Feb 06, 2015 1:41:11 pm EST

I know that this isn't "officially" supported, but here's where I am with this:

My setup - Fedora 21 on Lenovo Thinkpad Yoga
What I've done:
- Install latest Wine
- Install Viewer.msi (works fine!)
- Connect to Remote computer, using IP address (works fine!)
- Everything works, but the toolbar at the top is hidden and remains hidden, can't send CTRL-ALT-DEL to unlock computer

- After that I searched and found the knowledgebase article above. I tried to follow the steps, but I couldn't install msxml in winetricks because I have a 64 bit wine system (default these days)
- Wiped my wine setup and restarted with a 32 bit wine prefix (see accepted answer here)
- Installed Viewer.msi on the 32 bit prefix after following the KB article
- Everything installs, but now there is issues connecting. I can log on to the remote computer, but when I try to enter full control, it just sticks a black screen saying "Connecting" (or something similar, can't remember). Also, I tried to change "Remote Settings" but it gave an error that our versions didn't match.
- Reverted to 64 bit install, still having issues. Everything works, except the toolbar

Conrad Sallian, Administrator (Posts: 1115)

Feb 06, 2015 8:01:14 pm EST

Hello Nate,

Thank you for the detailed report! We will put it in our testing queue and see what's happening.

* Website time zone: America/New_York (UTC -4)