Community

can't connect to host with viewer from the command line

Links used in this discussion

Brandon M, User (Posts: 2)

Jun 11, 2020 2:39:36 pm EDT

Support level: Free or trial
I'm currently evaluating this software for a project, where one of our computers needs to duplicate the screen of  a terminal on a robot arm system. Everything is running windows 10.

I can manually connect the two systems, running the Viewer UI and double clicking on the connection. That works just fine. However running the command:

rutview /navsystem /fullcontrol
brings up the the Viewer UI, but does not connect to the other system. The remote system is shown as offline until I manually connect by double clicking on the saved connection in the UI.

Is there a way to get the commandline interface to do this automatically? I didn't see any "logon" command for the CLI like there is in UI.

I'm also kinda confused, what's the point of having the CLI options to connect to a system, if it won't do that until after you've manually run the UI and selected "Logon"?

Conrad Sallian, Support (Posts: 2560)

Jun 12, 2020 3:45:11 am EDT

Hello Brandon,

Thank you for your message.

You should provide the name of the remote connection and access password. Please, see example 1 on this page https://www.remoteutilities.com/support/docs/viewer-parameters/ .

Hope that helps.

Brandon M, User (Posts: 2)

Jun 12, 2020 9:21:43 am EDT

Support level: Free or trial
I posted the code above, that's exactly what I did. The password is saved in the connection. It doesn't work, it just opens up the UI, because the connection isn't "logged in" and there is no CLI command that I could find to get the connection to logon before trying to use it. But for some reason, double clicking on the connection in the UI takes care of this automatically, but the CLI does not.

Polina Krasnoborceva, Support (Posts: 1011)

Jun 15, 2020 10:34:13 am EDT

Hello Brandon,

Thank you for the clarification.

Unfortunately, we couldn't reproduce the issue - it's possible to connect to a remote Host machine in the Full Control mode using command line parameters. Could you please clarify if you're running the following command, i.e. without the "name" parameter, but just its value?
rutview /navsystem /fullcontrol
If this is the case, then, indeed, the Full Control mode is not initiated, it just opens the Viewer main window even if the password is saved for the remote connection entry. Could you please try running the following command instead and see if it works this way?
rutview /name:navsystem /fullcontrol
Please let me know if the issue persists.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.