Does copy and paste work?

Links used in this discussion

cosmos, User (Posts: 37)

Apr 27, 2020 4:13:20 am EDT


any idea why copy and paste does not work? I'm the latest stable host everywhere and I'm unable to drag and drop from local to remote desktop. Windows 10 as both host and viewer environment, but I've also tried with the viewer on XP or the host on XP.

Polina, Support (Posts: 1172)

Apr 27, 2020 11:55:27 am EDT


Thank you for your message.

Could you please clarify if you mean copying/pasting using the clipboard (i.e. via ctrl+c/ctrl+v key combination) or the Drag and Drop feature?
Please note, that right now the clipboard only allows you to transfer plain text, as the rich content (files, images, etc.) of the clipboard is not synchronized between Viewer and Host yet. However, we already have this in our roadmap and perhaps it will be implemented in the next major version of Remote Utilities, which we hope to release by the end of the year. I'm sorry if this makes the program less useful for you.

In case if you mean the Drag and Drop feature, then please note that depending on the used connection type (Direct or Internet-ID connection), a slight delay might be needed for the Drag and Drop to work properly. Please try waiting for a couple more seconds (about 3 to 4 seconds depending on the connection type) before dropping the file and see if this helps to resolve the issue.

In addition, please consider using the File Transfer mode, which can also work via drag and drop.

Hope that helps.

cosmos, User (Posts: 37)

Apr 27, 2020 1:08:41 pm EDT

Hello Polina,

I'm referring to drag and drop here. I'm mainly using an Internet-ID connection over a custom relay setup. Unfortunately, no matter how much time I'm waiting I can't make this happen. I've also checked the viewer settings and in it the checkbox to disable drag and drop is deselected. So everything seems fine, but drag and drop does not work, either way I've tried.

Polina, Support (Posts: 1172)

Apr 27, 2020 5:50:15 pm EDT


Thank you for the clarification.

Unfortunately, we couldn't reproduce the issue - the Drag and Drop feature works well both ways: from a local Viewer machine to a remote Host, and vise versa.

Could you please try updating Remote Utilities to the most recent 6.12 Beta 1 version and see if it helps to resolve the issue? The 6.12 Beta 1 version is available for the download on this page.
When updating, please make sure to update both Viewer and Host as well as the RU Server, as the version mismatch might lead to performance issues or some features not working.

Please let me know if updating Remote Utilities did not help and the issue persists.

cosmos, User (Posts: 37)

Apr 28, 2020 4:23:45 am EDT

That is very strange. I've been using RU for some time now both at home and at work. I've never managed to get drag and drop to work!

Perhaps I'll find the time to test the beta.

Polina, Support (Posts: 1172)

Apr 28, 2020 3:43:30 pm EDT


I have also checked if we have previously had any reports on this and found out that there was actually some certain issues with the Drag and Drop feature when using it with Internet-ID connection in the current version.

Although the Drag and Drop feature might work better when using the 6.12 Beta 1 version, the feature will be significantly improved in our future updates, so it would be also possible to use the feature via Internet-ID connection.
Some of the improvements will be implemented in the nearest beta version update. However, unfortunately, we cannot provide a specific ETA on the update yet. Sorry for the inconvenience.

Please let us know if you have more questions.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.