Forums

Installation via RDP problems

Mike G, User (Posts: 21)

Apr 03, 2014 4:30:28 pm EDT

Hi,
We have been experiencing some issues installing RUT hosts within a RDP session. It seems the install never completes an no message box and email are sent while connected via RDP. The service is installed but no internet ID is created. No change after host reboot. We can manually create an internet ID in settings, log out via RDP, use the manually created internet ID to connect via RUT but the first connect shows the message box and email are then sent. The internet ID sent via email is different than the one manually created and is no longer valid.

Is this expected? Any way to change this behavior?

Thanks,

Anton Kalugin, User (Posts: 210)

Apr 04, 2014 9:15:01 am EDT

Hello, Mike.

Thank you for your message.

This is a known issue and we will try to fix it. But let me ask, why do you want to use Internet-ID if you have the opportunity to use direct connection? And why do you need to automatically generate ID if you can do it manually?

Mike G, User (Posts: 21)

Apr 05, 2014 5:00:55 am EDT

Anton Kalugin wrote:
This is a known issue and we will try to fix it. But let me ask, why do you want to use Internet-ID if you have the opportunity to use direct connection?
Main reason: Security.

We find servers having port 3389 exposed through a router get hammered frequently. Customer sees the logs (and failed login attempts) and freaks out/gets worried. While your default port is not a common attack vector like RDP, it is safer to have just 25/443 open.

And why do you need to automatically generate ID if you can do it manually?
We use the custom MSI feature to email the Intenet ID back to our server as your product does not currently have any means to use a common address book. So to allow our support techs to get a copy to add to their address books. We use this same MSI that has our own pre-configured password and settings.

Anton Kalugin, User (Posts: 210)

Apr 08, 2014 3:35:21 pm EDT

Hello, Mike.

Thank you for your feedback.

This issue is complicated. It will be resolved when we implement address book sync.

Don’t hesitate to ask me, if you have any questions.

* Website time zone: America/New_York (UTC -5)