Ctrl, shift, enter keys not working

Links used in this discussion

Richard Moser, User (Posts: 6)

Mar 31, 2020 2:56:01 am EDT

Support level: Free or trial
Overnight, my shift and control keys have stopped working when I connect to a remote PC. I see that this is a common problem. I have tried changing to unicode keyboard - this allows me to use the shift key, but not ctrl or enter. No changes have been made to the remote PC (at least, not manually instigated). This makes the software unusable for me which, in the current working from home situation, is a major issue. Since so many people are suffering from this, please make finding a solution a priority.

Polina, Support (Posts: 1175)

Mar 31, 2020 1:07:38 pm EDT

Hello Richard,

Thank you for your message.

Could you please clarify what version of Remote Utilities do you use? If you use version, please try updating Remote Utilities to the latest 6.12 Beta 1 version as we have already implemented a fix for this behavior in the beta version. The 6.12 Beta 1 version of Remote Utilities is available for the download here.
When updating Remote Utilities please also make sure to update both Viewer and Host/Agent as the version mismatch might lead to performance issues and some features not working.

Please let us know if the issue persists.

Richard Moser, User (Posts: 6)

Apr 08, 2020 2:14:44 pm EDT

Support level: Free or trial
Updating to 6.12 Beta has solved the problem with the shift, ctrl an enter keys. However, I now get a lot of connection problems, where the connection screen is blank. The only way I can get a connection again is to connect via a terminal screen, restart the remote computer and then do a new connection. I need to do this multiple times a day and it's very annoying. I have updated the host machine so that both viewer and host are using the same version.

Polina, Support (Posts: 1175)

Apr 08, 2020 3:32:20 pm EDT

Hello Richard,

I'm glad to hear we were able to help!

As for the blank screen issue - could you please try enabling the Use legacy capture mode feature? In order to do so, please do the following:
1. Right-click on the Host icon in the system tray and select Settings for Host and navigate to the Other tab.
2. Enable the Use legacy capture mode checkbox and click OK.
After enabling the feature please make sure to restart the Host.

In addition, please try referring to this troubleshooting guide and see if any of the solutions listed there help to resolve the issue.

Please let us know if the solutions above did not help and the issue persists.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.