Community

Cannot properly upgrade from 6.3.0.6 to 6.9.4.0

jackk, User (Posts: 23)

Dec 22, 2018 4:53:46 pm EST

This happens on every computer that I upgrade the Remote Utilities to the newest version.  I create a new MSI, with only a new single password.  Then, I use Remote Install within the 6.9.4.0 viewer to update the host using Windows Authentication.  Then after it updates, Remote Utilities host will not accept the new password.  I have to manually delete (in the registry) HKEY_LOCAL_MACHINE\SOFTWARE\Usoris on the host and then I do the remote update again and it works.  It's like the old settings inside the registry are conflicting with the new version.  Again, this happens on every computer that I update.

Conrad Sallian, Support (Posts: 2371)

Dec 22, 2018 5:47:05 pm EST

Hello Jack,

Thank you for your post. Could you please update another Host and then look into the Host settings to see if the single password checkbox is selected at all and password is set. Here is a screenshot:



Also, please double check that your configured installer has "Single password" enabled and configured.

jackk, User (Posts: 23)

Dec 25, 2018 3:35:00 pm EST

Yes, Single Password is checked, just like your screenshot.  Also, the OLD password works.  When it tells me the password is wrong, I can put in the OLD password and login.

It seems like the password from the new install does not overwrite the old password.  If I put the MSI on a new computer, everything works fine, and if I erase the reg settings on the existing computer and do the upgrade, everything works fine.

If I simply do an upgrade without erasing the registry settings, it keeps the OLD password and does not use the NEW password from the new MSI.
Edited:jackk - Dec 25, 2018 3:35:42 pm EST

Conrad Sallian, Support (Posts: 2371)

Dec 26, 2018 5:29:07 am EST

Hello Jack,

It seems like the password from the new install does not overwrite the old password. If I put the MSI on a new computer, everything works fine, and if I erase the reg settings on the existing computer and do the upgrade, everything works fine.

Yes, it seems to be the case. We need more information:

1. In step 4 of the configuration process you should have selected Pre-configure -> Security settings checkbox:



2. In the Host configuration window that appeared thereafter you should have enabled single password and actually set the new password, then click OK and finish the configuration process.

Was that the case?

Conrad Sallian, Support (Posts: 2371)

Dec 26, 2018 6:23:06 am EST

Hello Jack,

Update on this issue. Your setup was most likely correct, it's only that when updating old versions - and 6.3.0.6 is a very old version given how many changes we have made ever since it was released - the new password won't apply due to changes to authorization mechanism.

So if you want to change the password with your update you are advised to do that beforehand in the Host settings, and then update.

Hope that helps.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.