Remote Utilities 7.0 has been released! Learn what's new and upgrade your license key. (X) Dismiss


Users cannot connect

River Oaks Chiropractic, User (Posts: 1)

Nov 21, 2014 4:08:18 pm EST

Support level: Free or trial

I do apologize if this issue was covered elsewhere, but I could not see any posts that were related.

We have the free version of Remote Utilities (we have only 8 people that use it) on our Windows 8 office computer. All of the users have the Remote app on their phones to connect into it. For the last few months it has worked flawlessly, and with us needing to get a new ID maybe twice when we had computer issues (Host end).

For whatever reason it has stopped working this week. I obtained a new ID, but still no one would connect and we would get an error saying the host was not available. After a few attempts of this, I re-downloaded the program and started it over (checking off the setting for the firewall).
While I am now able to connect without an error, the screen is just black.

Do you have any suggestions?
Edited:River Oaks Chiropractic - Nov 21, 2014 4:25:47 pm EST

Anton Kalugin, User (Posts: 209)

Nov 21, 2014 4:36:42 pm EST

Support level: Free or trial
Hello River,

Thank you for your message.

Could you please send me your Host log files?

You can find them in C:\Program Files\Remote Utilities - Host\Logs folder.

Looking forward to your reply.

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.