Looking for a solution for remote work? See how Remote Utilities can help! (X) Dismiss

Community

Remote Utilities Viewer for Mac andLinux has been released. Send us your feedback and report bugs in this discussion thread.

Cannot see mouse cursor on the remote computer

Ryan Kenna, User (Posts: 3)

Jun 16, 2018 3:29:52 pm EDT

The iOS version and host version are the newest available at this point. I’m connecting fr om an iPhone 8 Plus iOS remote utilities app to Windows 10 Professional host. Whenever I’m connected I can’t see the mouse at all. I can only kind of judge wh ere it is from moving my finger around and highlighting icons. I tried connecting to my Windows 7 Professional laptop and strangely enough I could see the mouse (Using portable host on that machine not the service install). I’ve tried changing my mouse type on my Windows 10 machine but I still can’t see it. Any suggestions? Is this a known bug?

Conrad, Support (Posts: 2487)

Jun 18, 2018 3:39:58 am EDT

Hello Ryan,

Thank you for your post.

Is a physical mouse connected to the remote Host PC?

Ryan Kenna, User (Posts: 3)

Jun 18, 2018 6:37:00 am EDT

Hi,

No, no mouse or keyboard. It’s a media server I run on my network. Like I say, “a” mouse is present. I just can’t physically see it. Very frustrating!

Conrad, Support (Posts: 2487)

Jun 19, 2018 10:29:01 am EDT

Hello Ryan,

When there is no physical mouse the cursor might not be visible. The iOS version has nothing to do with it - the same is true about the desktop Viewer, only in desktop Viewer you see the local cursor by default so that behavior is not immediately evident.

But this is a bug and we have already added it to our bugfix queue. We will fix it in one of the upcoming updates.

Conrad, Support (Posts: 2487)

Jun 19, 2018 10:35:25 am EDT

Meanwhile, here is a workaround that can help temporarily fix the problem. On the remote computer, go to windows settings -> Ease of access -> Mouse and enable "Turn on mouse keys...":



Let us know if it worked. Thanks.

Ryan Kenna, User (Posts: 3)

Jun 20, 2018 6:09:34 am EDT

Hi Conrad,

Thanks for the reply. I understand what you mean. Likewise I can see a cursor when viewing the host from a desktop or laptop, but as you mention it'll be locally, not the remote mouse - Explaining why it isn't visible on iOS.

I enabled mouse keys and it has indeed solved the problem for now. I can now see a remote mouse on the iOS viewer application which is extremely helpful. I'm glad it's been acknowledged as a bug as I use this computer with no peripherals and rely on remote desktop software to access it. I've migrated from a 'different' remote desktop software (which did show the remote mouse). But I acknowledged this is a bug and overall I'm really pleased with this software, I look forward to future updates it has a lot of potential - Thanks again.
Edited:Ryan Kenna - Jun 20, 2018 6:10:56 am EDT

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.