Community

Viewer Can't login to Self Hosted Server

Prime Computers, User (Posts: 4)

Nov 07, 2017 1:08:21 pm EST

Hello everyone, last week i started to use RU in our premesis, so far this is what I been able to do.

1- Installed RU Server for relay ID server
2- Created MSI package and deploy to our computers, configured with self hosted server
3- Auto register to address book the computers in the Self hosted RU server.
4- Created user and address book and assign security for the Self Hosted server address book.

Im able to access the computers inside the network and outside the network.

what I can't do is to connect the viewer to self hosted server. I just cant login. even with a viewer inside the same network using the local ip address of the server, it just dont connect. I enter the user name and password created in the Self Hosted and the viewer just says signing on to "192.168.3.99" and then goes away and nothing, thats all i get.

I want to be able to login so i can use Sync Address Books.
Attached Files

Conrad, Administrator (Posts: 1738)

Nov 07, 2017 1:17:05 pm EST

Hello,

Thank you for your post.

what I can't do is to connect the viewer to self hosted server. I just cant login. even with a viewer inside the same network using the local ip address of the server, it just dont connect. I enter the user name and password created in the Self Hosted and the viewer just says signing on to "192.168.3.99" and then goes away and nothing, thats all i get.

Make sure that the port specified in Viewer's server manage (Manage tab -> Server manager -> your server's properties) is the same as the communication port specified in the configuration dialog on the server side. See the attached screenshots.

Also, make sure that this port is allowed on the server machine in the firewall settings (inbound TCP port).

Hope that helps.
Attached Files

Like Remote Utilities? Write a review

Prime Computers, User (Posts: 4)

Nov 07, 2017 1:21:10 pm EST

Thanks for your fast response.

Im sorry to inform that i have triple check the ports and they do match , im using the default ports 5655. Windows Firewall is turn OFF for all profiles, and theres no other firewall running in the machine.

any other advice?

Benny Tucker, User (Posts: 27)

Nov 07, 2017 2:53:46 pm EST

Also be sure to check under Server Configuration-Access and administration-Allow named pipes connection (local connection). Make sure it's checked...
Hope that helps !!
Benny
Edited:Benny Tucker - Nov 07, 2017 2:54:47 pm EST

Conrad, Administrator (Posts: 1738)

Nov 07, 2017 3:55:31 pm EST

Hello,

Im sorry to inform that i have triple check the ports and they do match , im using the default ports 5655. Windows Firewall is turn OFF for all profiles, and theres no other firewall running in the machine.

Do you also have both Remote Utilities and RU Server updated to the most recent version? It's 6.8.0.1 and 2.6.0.6 respectively. You can download the latest versions from here.

If you do and if nothing else helps please let me know and I'll create a ticket from this thread. We may have a remote session because I cannot come up with any other reasons why the Viewer may not be connecting.

Also be sure to check under Server Configuration-Access and administration-Allow named pipes connection (local connection). Make sure it's checked...

Hi Benny,

Thanks for contributing. However, this is not about "administration connection" but rather about a regular Viewer signing in on the server.

Like Remote Utilities? Write a review

Prime Computers, User (Posts: 4)

Nov 07, 2017 4:26:11 pm EST

Hello, yes im running the lastest version of viewer and self hosted
viewer 6.8.01
and server  2.6 [2603]

And I think i know whats the problem. in the Server configuration in the tab Authentications. it only has the MD5 but does not have any key.

gonna try to reinstall and see if that help , hopefully i don't loose my current computers that are register in to this self hosted.

btw the self RU is installed in the windows Server 2008 r2 I assume it's compatible?

Prime Computers, User (Posts: 4)

Nov 07, 2017 4:30:31 pm EST

OK yes its fixed now.

I just hit "Generate New Key" and now im able to login with viewer and sync the address books.

Thanks for the help !

no idea why when i installed for the first time it didn't generate the key. I found about the key by installing the Self Hosted into another computer, that's when i saw there was a key there and not in my other installation.

Thanks.!

Conrad, Administrator (Posts: 1738)

Nov 07, 2017 4:40:33 pm EST

Hello,

I just hit "Generate New Key" and now im able to login with viewer and sync the address books.

Shame on me I didn't think of a missing key as a possible reason.  But I'm glad you figured it out on your own.

btw the self RU is installed in the windows Server 2008 r2 I assume it's compatible?

Yes.

no idea why when i installed for the first time it didn't generate the key. I found about the key by installing the Self Hosted into another computer, that's when i saw there was a key there and not in my other installation.

We will check that just in case. Thank you for letting us know!

Like Remote Utilities? Write a review

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.