Forums

[resolved] RDP

john brown, User (Posts: 2)

Sep 06, 2012 10:31:02 pm EDT

Hi, whenever I try to connect via RDP a window pops up saying connecting then it disappears a couple seconds later and nothing happens. I don't know if it's just me or there is a bug in the software. All the other types of connections work ok.

Conrad Sallian, Administrator (Posts: 1082)

Sep 07, 2012 3:57:37 am EDT

Hi John,

Have you enabled incoming Remote Desktop connections on the remote computer first? By default RDP access is disabled in Windows.

john brown, User (Posts: 2)

Sep 07, 2012 9:37:54 am EDT

Hi Conrad,

Remote Desktop is setup and working just fine. I should mention though that I use the callback feature to establish a connection to the host. The reason I have to use the callback connection is, the host is behind a firewall that only allow outgoing connections on port 80 & 443; hence no connection can be made with your server which is listening on port 5655. What I have observed with other remote software is they normally setup there server to listen on port 80 & 443 as they know that most firewall administrators will at least allow these 2 ports for outgoing connections.

Conrad Sallian, Administrator (Posts: 1082)

Sep 07, 2012 10:02:53 am EDT

John,

RDP connection mode doesn't work via callback connection or Internet ID. We are planning to make RDP working via those some time in the future.

What I have observed with other remote software is they normally setup there server to listen on port 80 & 443 as they know that most firewall administrators will at least allow these 2 ports for outgoing connections.
We didn't use ports 80 and 443 by default for a reason - Remote Utilities is often used not only for administering workstations but servers as well. To avoid port conflicts with server software that might listen to those ports, Remote Utilities uses port 5650.

BTW, you can change that port manually in the Host settings, if necessary.

nikkil, User (Posts: 50)

Dec 22, 2012 5:05:45 pm EST

"RDP connection mode doesn't work via callback connection or Internet ID."

Makes sense. I really haven't tried calling the traditional way. Any notes on when the changes will be made?

You're never a loser until you quit trying.

Conrad Sallian, Administrator (Posts: 1082)

Dec 23, 2012 5:53:49 am EST

nikkil wrote:
"RDP connection mode doesn't work via callback connection or Internet ID."

Makes sense. I really haven't tried calling the traditional way. Any notes on when the changes will be made?
Starting version 5.4 RDP works via Interent ID. Here's the related blog post.

http://www.remoteutilities.com/about/blog/Remote_Utilities/rdp-over-id-is-coming-with-version-54/

* Website time zone: America/New_York (UTC -4)