Forums

Duplicated ID

Sakari Suominen, User (Posts: 2)

Sep 15, 2014 9:43:17 pm EDT

I have a host which is connected to internet via rather unreliable mobile hotspot. Connection is lost frequently for a few seconds or minutes and then recovered automatically. However, sometimes host becomes unreachable after connection issues. When I checked the log file I noticed that there is an error message "Internet-ID stopped - Stop command. Reason: Duplicated ID".



I have tried to generate a new Internet-ID but the problem still persist. I suspect that connection is lost for so brief moment that host loses connection but Internet-ID server doesn't notice that. When host connects to server to register itself a conflict occurs. Host recovers from this situation only be restarting the service.

How do I resolve this problem?

Anton Kalugin, User (Posts: 210)

Sep 16, 2014 9:18:21 am EDT

Hello Sakari,

Thank you for your message.

I asked our developers about this issue. I will answer you as soon as I get a reply from them.

Anton Kalugin, User (Posts: 210)

Sep 22, 2014 1:46:59 pm EDT

Hello Sakari,

We are not able to reproduce this issue in our environment. Could you please clarify, is there any antivirus software or firewalls installed on your Host machine? And how often do you get this "Duplicated ID" issue?

Looking forward to your reply.

Sakari Suominen, User (Posts: 2)

Sep 23, 2014 1:53:31 pm EDT

I have tested without antivirus and firewall. This usually occurs when host software has been running for a few hours but it depends on internet connection quality and it varies a lot.

Conrad Sallian, Administrator (Posts: 1083)

Nov 03, 2014 9:46:52 am EST

Hello Sakari,

Does the issue still persist?

Grzegorz Suchy, User (Posts: 3)

Oct 26, 2015 5:23:12 pm EDT

Hi
The issue still persist, I also have a "strange" internet connection, the host disconnets few times a day...

What does the DUPLICATE ID error means? I mean from developer perspective? maybe there is some error in server implementation... :)

Conrad Sallian, Administrator (Posts: 1083)

Oct 26, 2015 6:01:36 pm EDT

Hello Grzegorz,

Did you re-issue the ID using the "Get new ID" command?

Grzegorz Suchy, User (Posts: 3)

Oct 28, 2015 5:40:25 pm EDT

It didnt repeated, but, I have lost cnnection to 3 hosts. I had old TeamViewer installation there, so it saved me, but I didn't wanted to use TV any more.

Now I wonder... :-/

Conrad Sallian, Administrator (Posts: 1083)

Oct 28, 2015 6:28:48 pm EDT

Grzegorz Suchy wrote:
It didnt repeated, but, I have lost cnnection to 3 hosts. I had old TeamViewer installation there, so it saved me, but I didn't wanted to use TV any more.



Now I wonder... :-/
Grzegorz,

Re-issuing the ID means generating a new ID, which will not repeat the previous ID. This is done to "reset" the connection of the Host with the intermediary server and start it anew.

but, I have lost cnnection to 3 hosts.


How is this issue related to the first one? You said that you were having issues with one Host.

* Website time zone: America/New_York (UTC -4)