Community

Delay on dragging files and clipboard

Cristian Braun, User (Posts: 32)

Dec 06, 2018 9:40:33 am EST

Hi!
This is not a issue, just a question.
When i drag a file directly to the remote connection, y first get the "fobidden" cursor for about 2 seconds, and then it changes and i can release my file.
The same happens when copying to clipboard: if i just paste inmediatly, it doesnt work. If i wait about 2 seconds, it paste what i've copied.
I just want to know: Is this a normal behavior, can i modify this "timer", or its a bug?

Thanks!

Conrad Sallian, Support (Posts: 2406)

Dec 06, 2018 5:06:28 pm EST

Hello Cristian,

Thank you for your post.

This is normal behavior. Remember that in this case you are not merely dragging between destinations on the same computer. Rather, your dragging operation triggers a remote transfer and that requires some time to "get registered" by the program.

Trent, User (Posts: 15)

Dec 10, 2018 8:26:48 am EST

Cristian Braun wrote:

The same happens when copying to clipboard: if i just paste inmediatly, it doesnt work. If i wait about 2 seconds, it paste what i've copied.

I've noticed the same with the clipboard.  It tends to take a fairly significant amount of time for the clipboard contents to transfer even if the amount of data is very small (a website address for example).  I have seen it take as long as 10 seconds to transfer those contents.

As Cristian said, not a major issue, but perhaps something to add to the list of possible improvements in a future version.

Thanks for making a great product!

Conrad Sallian, Support (Posts: 2406)

Dec 10, 2018 2:39:45 pm EST

Hello Trent,

Thank you for the kind words.

I've noticed the same with the clipboard. It tends to take a fairly significant amount of time for the clipboard contents to transfer even if the amount of data is very small (a website address for example). I have seen it take as long as 10 seconds to transfer those contents.

This is still too much time even for slower connections, especially if small amount of data is being copied. Do you have the same version of Viewer and Host on both ends?

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.