Remote Utilities 6.9 Beta is available for download. (X) Dismiss

Knowledge Base

Does the program require ActiveX or Java Runtime Environment?

No, Remote Utilities does not require JRE, ActiveX or other frameworks for operation.

Tags: Features

Was this article helpful?

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.