Forums

Firewall ports and unable to restart host

Ronnie Morgan, User (Posts: 3)

Jul 24, 2014 4:26:23 pm EDT

I really want to like this software, but before I can implement it, it has to use port 80 and 443. The IT department, in all their wisdom, is blocking the default ports for remote utilities. The GMS won't work either because we have PC's outside of our network.

I've also tried changing the port number in the host software, and it tells me that I need to restart it for the change to take place. Fine. But where do I restart it? When I install the program, it doesn't put anything in the start menu. And when I go to the directory where it is installed, the host program doesn't do anything when I try to run it. (Advanced options to set the port during installation would be nice)

I have read reviews regarding Remote Utilities needing some polish. And I agree. It needs some refining. I would continue to play with it and offer suggestions on needed changes, but this brick wall I've hit now is going to have to be dealt with before I can proceed.

Anton Kalugin, User (Posts: 210)

Jul 24, 2014 5:00:13 pm EDT

Hello Ronnie,

Thank you for your message.

Ronnie Morgan wrote:
I really want to like this software, but before I can implement it, it has to use port 80 and 443.
Could you please specify, what are you trying to use for the connection? Internet-ID or IP adress?
These are the port pairs for the Internet-ID:
5655, 5656;
5655, 563;
5656, 443;
443, 5656;
443, 563.
At least one of these pairs should be open.

Ronnie Morgan wrote:
The IT department, in all their wisdom, is blocking the default ports for remote utilities.
What program exactly do you have behind this firewall? Host or Viewer? I mean, are you trying to connect fr om outside your corporate network to the internal Host or from inside the corporate network to the external Host?

Ronnie Morgan wrote:
The GMS won't work either because we have PC's outside of our network.
The GMS was designed exactly for the purpose of using it for easy connecting over the Internet (with firewall bypass). It is used together with the Internet ID feature. When using the GMS instead of our hosted service you can manually specify a single port (not the Host's port, but the GMS' "tunnel" port) , such as 443, instead of having to open the ports I listed above.

Ronnie Morgan wrote:
I've also tried changing the port number in the host software
Changing Host's port number only makes sense when connection by an IP address is used. Do you have an external IP adress, which is visible from the Internet on your Host computer?

Ronnie Morgan wrote:
But wh ere do I restart it?
After installing you should have 3 shortcuts in Start->All programs->Remote Utilities - Host. If for some reason you don't have them now, you can create them manually. They should looks like:

%Your_installation_folder%\rutserv.exe /config
for Host's settings

%Your_installation_folder%\rutserv.exe /start
for starting Host

%Your_installation_folder%\rutserv.exe /start
for stoping Host

Ronnie Morgan, User (Posts: 3)

Jul 25, 2014 8:06:01 am EDT

Could you please specify, what are you trying to use for the connection? Internet-ID or IP adress?
These are the port pairs for the Internet-ID:
5655, 5656;
5655, 563;
5656, 443;
443, 5656;
443, 563.
At least one of these pairs should be open
Would not be possible to do IP Address, so I'm attempting to use Internet-ID. And, that's my point. 443 and 80 are available for use, but the IT department has all of the other port possibilities closed.

What program exactly do you have behind this firewall? Host or Viewer? I mean, are you trying to connect fr om outside your corporate network to the internal Host or from inside the corporate network to the external Host?
Host. At the moment. But eventually it would be viewer and host. I tried using the viewer from outside the network. I can try reversing that, but I don't think it will make a difference either way.

The GMS was designed exactly for the purpose of using it for easy connecting over the Internet (with firewall bypass). It is used together with the Internet ID feature. When using the GMS instead of our hosted service you can manually specify a single port (not the Host's port, but the GMS' "tunnel" port) , such as 443, instead of having to open the ports I listed above.
I understand. But in order for it to work in our application, I would need to run GMS on a server outside of our network. I don't have the resources (unless I wanted to run it on a home PC) to do that. I could probably request a server (for a charge) through the IT department that has an outside IP address. But I'm trying to avoid that.

Changing Host's port number only makes sense when connection by an IP address is used. Do you have an external IP adress, which is visible from the Internet on your Host computer?
No. All machines are NATed.

After installing you should have 3 shortcuts in Start->All programs->Remote Utilities - Host. If for some reason you don't have them now, you can create them manually. They should looks like:

%Your_installation_folder%\rutserv.exe /config
for Host's settings

%Your_installation_folder%\rutserv.exe /start
for starting Host

%Your_installation_folder%\rutserv.exe /start
for stoping Host
I looked for that, but it's not in the start menu anywhere. I even found the command lines that you list there, and attempted to run it from a CMD prompt, still nothing. I don't even see the process attempt to start in the process list. But if changing the port doesn't matter anyway, then this probably doesn't matter. Although I don't know why it's not putting the shortcuts in the start menu...

Thanks for the response. Hopefully the port pairs can have 80/443 added. And then that solves my problem (besides the missing shortcuts).

Ronnie

Anton Kalugin, User (Posts: 210)

Jul 25, 2014 10:05:36 am EDT

Hello Ronnie,

Unfortunately, the ports listed above should be open if you want to use our default server. But we will think about adding 40 and 443 ports in the future.

Ronnie Morgan wrote:
besides the missing shortcuts
You could try to reinstall Host, it will create these shortcuts again. All settings will be unaffected.

Let me know, if you need further assistance.

Ronnie Morgan, User (Posts: 3)

Jul 25, 2014 10:16:18 am EDT

Unfortunately, the ports listed above should be open if you want to use our default server. But we will think about adding 40 and 443 ports in the future.
I understand. I'm just letting someone know that as is, the product is unusable. Hopefully port 80 can be added at some point in the near future. Or, change it so that it only needs a single port (443).

You could try to reinstall Host, it will create these shortcuts again. All settings will be unaffected.
Tried that. I uninstalled it and reinstalled it 3 times. Can't figure out why it's not creating the shortcuts. But at this point, it doesn't matter (for me) until the port issue is resolved.

Ronnie

Conrad Sallian, Administrator (Posts: 1078)

Jul 25, 2014 11:18:59 am EDT

Hi Ronnie,

I understand. I'm just letting someone know that as is, the product is unusable.
I'm sorry, but this is somewhat a bold statement. Remote Utilities has been used in many different companies and environments, including very big ones (some with up to 50 000 remote PCs dotted around the globe). Although we do our best to make it as easy to configure and use as possible, there are still some networks/environments with extremely strict (if not paranoid) rules we can't do anything about.

In such cases it is recommended to solve the issue on the "administrative level" - that is to add an exception in the software in the antivirus software/firewall, create a new company-wide policy etc. by getting permission from company executives/IT department.

* Website time zone: America/New_York (UTC -4)