Forums

10-15 second lag in screen refresh

Micky Mirchandani, User (Posts: 2)

Jul 13, 2016 4:50:07 pm EDT

Hi

does anyone know why there is significant lag between getting the cursor to navigate fields in a form or for a field to gain focus or various other tasks where it just seems to freeze.

once it eventually timed out and i had to restablish session but in most cases it is just super slow.
comms and computers are all new on both ends.

A

Conrad, Administrator (Posts: 1079)

Jul 13, 2016 6:34:34 pm EDT

Hello Micky,

Thank you for your post.

If you are using "Internet-ID" connection it may be slow because this type of connection requires an intermediary server and not optimized for all geographical regions. For that reason we offer a free self-hosted relay server (called "RU Server") that you can install on your premises or on a Windows web hosting of your choice and route all traffic through that server.

Also, this documentation page has some advice on how to improve performance: https://www.remoteutilities.com/support/docs/slow-remote-connection-speed-performance./

Hope that helps.

Micky Mirchandani, User (Posts: 2)

Jul 26, 2016 4:34:00 pm EDT

Hello

thank you for pointing out the remote server option. I installed it and have tried using it.
It may only be 10% better than going through the default server option.

I continue to get timeouts, cursor disappears, characters get lost. etc etc.

All machines are up to date, lots of memory etc., and high bandwidth connections.

what could be the problem?

If this continues, then it's not useable - but maybe something is not configured correctly.

Micky

Conrad, Administrator (Posts: 1079)

Jul 27, 2016 5:22:32 am EDT

Hello Micky,

It may only be 10% better than going through the default server option.

I continue to get timeouts, cursor disappears, characters get lost. etc etc.
An improvement should be much better so it's unlikely to be the intermediary server issue. The type of issues you describe could arise on the Viewer side rather than on the Host or server side.

Could you please to try to completely re-install the Viewer. See our documentation on how to fully erase the program from your PC: https://www.remoteutilities.com/support/docs/installing-and-uninstalling/#uninstall-viewer . Then download and install the Viewer from scratch and add the program to your antivirus software exceptions list just in case.

* Website time zone: America/New_York (UTC -4)