剪贴板传输
在完全控制会话中,您的计算机的剪贴板与远程计算机的剪贴板保持同步。您在一侧复制的内容即可在另一侧粘贴,双向均可:文本、带格式的文本、图片,以及自 Windows 版 Remote Utilities 7.9 和 macOS 与 Linux 版 2.1.1 起的文件和文件夹。不会自动粘贴任何内容 —— 传输只会填充另一侧的剪贴板,由您在需要的位置粘贴。
剪贴板传输适用于两侧 Windows、macOS 和 Linux 的任意组合。它仅在完全控制模式下可用;在仅查看模式下不会自动传输任何内容。
纯文本
在一侧使用 Ctrl+C(Mac 上为 Cmd+C)或程序的 编辑 菜单复制文本。片刻之后文本就会出现在另一侧的剪贴板中;切换到需要它的程序,然后使用 Ctrl+V(Cmd+V)粘贴。
只有会话期间发生的更改才会传输。连接之前剪贴板中已有的文本不会发送;请重新复制,或使用 设置远程剪贴板(见下文)。
带格式的文本
带格式的文本会保留其格式。在 Word、LibreOffice Writer、TextEdit 或网页浏览器中复制的粗体文本、标题、列表和链接,粘贴到另一侧时会保留格式,只要接收程序支持。在 Linux 或 macOS 计算机上复制的 HTML 可以在 Windows 上正确粘贴,反之亦然。如果只需要纯文本,请使用接收程序的 粘贴为纯文本 命令(大多数程序中为 Ctrl+Shift+V)。
图片
在一个程序中复制的图片可以粘贴到另一侧的程序中:在图像编辑器或办公文档中复制一张图片,然后在另一台计算机上粘贴。图片传输已在 Paint、Photoshop 和 GIMP 之间的各个方向上测试过,也在 Mac 上的 Preview 中测试过(文件 → 从剪贴板新建)。图片与文本一样自动传输,无需手动命令。
文件和文件夹
您可以在一侧的文件管理器中复制文件和文件夹,然后在另一侧的文件管理器中粘贴,而无需打开文件传输模式:
- 在完全控制会话中,在一侧的文件资源管理器、访达或 Linux 文件管理器中选择文件或文件夹,然后按 Ctrl+C(Mac 上为 Cmd+C)。
- 切换到另一侧,打开目标文件夹,然后按 Ctrl+V(Cmd+V)。
文件夹会连同其内容一起复制。文件既可以从 Host 传到您的计算机,也可以从您的计算机传到 Host,并适用于 Windows、macOS 和 Linux 的任意组合。
要求
- 两侧都必须是新版本:Windows 上为 Remote Utilities 7.9 或更高版本,macOS 和 Linux 上为 2.1.1 或更高版本。较旧的 Viewer 或 Host 根本看不到剪贴板中的文件;文本和图片照常工作。
- Host 上必须允许 文件传输 模式(Host 设置 → 模式),并且您连接所用的帐户必须有权使用该模式。通过剪贴板传输的文件遵循相同的权限,并以与文件传输会话相同的方式写入 Host 日志。如果不允许文件传输,文件不会提供给另一侧,或者粘贴会以错误结束。
- Linux 版 Viewer 需要
fuse3软件包才能从 Host 接收文件;安装程序会推荐安装它。
传输什么,何时传输
按 Ctrl+C 只会发送所复制项目的列表:名称、大小和日期。内容在您粘贴时才会传输,而且只传输您实际粘贴的文件。您可以在远程计算机上复制一个大文件夹,然后改变主意,而不会有任何数据经过网络。
- 粘贴到您计算机上的文件(Host 到 Viewer)通过文件传输模式所用的同一连接传输,具有相同的加密、权限和速度。
- 粘贴到 Host 上的文件(Viewer 到 Host)由 Host 通过会话连接逐块请求,块大小会根据链路调整,以使远程屏幕保持响应。macOS 或 Linux 版 Host 在接收文件期间会在屏幕角落显示一条小通知,让那台计算机前的人知道文件管理器为何忙碌。
可以粘贴到哪里
接收方在复制时得到的并不是文件本身,而是对文件的承诺,操作系统会在粘贴的那一刻将其变成真正的文件。每种操作系统的处理方式不同:
- Windows:在文件资源管理器中粘贴到文件夹或桌面上。资源管理器会显示其常规的进度窗口,带有 取消 按钮。只接受磁盘上已有文件的程序(例如 Telegram 或 WhatsApp)看不到来自另一侧的文件;请先将它们粘贴到文件夹中,再从那里附加。这与 Windows 远程桌面的行为相同。
- macOS:在访达中粘贴。在文件到达之前,访达会显示“正在准备拷贝”而没有进度条;这并不是卡住了。自行读取所粘贴文件的程序(例如 Mail 或聊天应用)会得到一个空文件,直到同样的文件在访达中粘贴过一次为止。
- Linux:可在任意文件管理器中粘贴;Nautilus 等会显示各自的进度。您也可以直接打开所粘贴集合中的文件。
规则和限制
- 只有在会话窗口处于活动状态时,您计算机上复制的文件才会提供给 Host。否则,您计算机上的每一次 Ctrl+C 都会把文件暴露给每个已连接的 Host。在其他窗口获得焦点时复制也没有问题:当您返回会话窗口时,文件就会被提供。
- 第二次粘贴同一剪贴板内容时,会取源端文件的当前状态,包括复制之后所做的更改。复制过程中被修改的文件会产生读取错误,而不会生成损坏的副本。
- 剪切(Ctrl+X)的行为与复制相同:源端不会删除任何内容。
- 名称、大小和修改时间会被传输;权限、所有者和扩展属性则不会。所复制文件夹中的符号链接会被跳过。
- 连接中断后无法续传:请重新粘贴。
- 从一个 Host 接收的文件永远不会再传给另一个 Host。
手动获取和设置远程剪贴板
完全控制窗口菜单(
)中的两个命令可手动传送剪贴板内容:
- 获取远程剪贴板—将远程计算机剪贴板中此刻的内容放入您计算机的剪贴板。
- 设置远程剪贴板—将您计算机剪贴板中的内容放入远程计算机的剪贴板。
这两个命令同样适用于文本、图片和文件。在以下情况下使用它们:
- 内容是在会话开始之前复制的。 自动传输只发送会话期间发生的更改;连接时,或者启动 Host 或 Viewer 时剪贴板中已有的内容会留在原处。如果文本或文件仍在您的剪贴板中,请选择 设置远程剪贴板 发送它们;对于连接之前在 Host 上复制的内容,获取远程剪贴板 的作用相同。
- 自动同步已关闭(在 Viewer 选项中,见下文)。这时这两个命令是传输剪贴板的唯一方式,没有您的明确操作,任何内容都不会传送。
- 您想确认另一侧此刻的内容,例如从仅查看切换回完全控制之后。
一次复制,多个会话:如果您打开了多个完全控制窗口,您计算机上复制的内容会提供给每个已连接的 Host,因此您可以在各个会话中依次粘贴相同的文本或文件。(例外情况是在某个特定会话窗口处于活动状态时复制的文件;见上文的规则。)
关闭剪贴板传输
在 Viewer 中
自动同步意味着,当会话窗口处于活动状态时您复制的任何内容都会提供给该远程计算机。如果您更愿意逐次决定,请在 Viewer 中转到 工具 → 选项 → 远程屏幕,然后选择 禁止自动同步剪贴板(见 Viewer 选项)。这样任何内容都不会自行传送,两个方向均是如此,而 获取远程剪贴板 和 设置远程剪贴板 仍可按需使用。
在 Host 上
远程计算机的所有者拥有最终决定权。在 Host 设置 的 其他 页面上,选择 禁用剪贴板传输,然后选择 双向 或 仅 Host 到 Viewer。第二个选项允许 Viewer 用户在 Host 上粘贴,但不让 Host 上复制的任何内容离开它。在被阻止的方向上,自动传输和手动命令都不起作用。此外,文件还要求在 模式 页面上允许 文件传输 模式,如上文所述。
发送剪贴板作为击键
远程计算机上的某些位置根本不接受粘贴:Windows 登录屏幕、UAC 提示、以其他用户身份运行的程序、虚拟机控制台或类似 BIOS 的文本界面。对于这些情况,请在您的计算机上复制文本,然后在完全控制窗口菜单中选择 发送剪贴板作为击键。Viewer 会将文本逐字符输入到远程计算机中,就像您在键盘上输入一样。这是在远程 Windows 欢迎屏幕上输入长密码的常用方法。
这种方式只能发送纯文本。选择该命令之前,请确保远程计算机上正确的输入框已获得焦点。
移动应用
移动应用双向传输文本;如果接收程序支持,带格式的文本也会保留其格式。图片和文件不会传输 —— 通过剪贴板复制文件是桌面版 Viewer 和 Host 的功能。应用处于后台时在手机上复制的文本,会在您返回会话时发送到远程计算机。获取远程剪贴板 和 设置远程剪贴板 命令位于会话工具栏的闪电图标下。
提示
- 稍等片刻。 在快速链路上,剪贴板内容会在您复制后的不到一秒内到达另一侧,在慢速链路上则更晚。如果粘贴出来的是之前的内容,请稍等后重新粘贴。在 Mac 上,粘贴前请等待大约五秒。
- 大文件。 通过剪贴板粘贴大文件所需的时间与在文件传输模式中复制它一样长,在 macOS 版 Host 上则更长。对于数 GB 的数据,或者当您想查看进度并在连接中断后续传时,请使用文件传输模式。
- 您计算机上的内容没有传过去? 请检查复制时会话窗口是否处于活动状态、Viewer 选项中是否没有选择 禁止自动同步剪贴板,以及 Host 上是否没有禁用该方向的剪贴板传输。
