Free Licensing is giving Invalid License Key message

Coffmans, User (Posts: 10)

Sep 16, 2013 3:05:50 pm EDT

Support level: Free or trial
I am using Remote Utilities on a coupe of home machines (including my laptop). I did a bonehead move and I forgot to license the Host. I am trying to connect to the HOST and I am greeted with the "License" window.

I read the registering-free-edition.pdf document and followed the directions, step by step.
  • I opened the Viewer
  • I opened the selected the connection for the Host for home
  • I right click and select Register Remote Host
  • I select the entry in the License Key Storage
  • I click OK
  • I am greeted with the "Invalid License Key" message

I have disabled the firewall on the machine, as a precaution.

Any ideas on how I can get the register the Host for the free version?

Conrad Sallian, Support (Posts: 2591)

Sep 16, 2013 3:15:38 pm EDT

Hello Coffmans,

Is that happening with a newly registered free license key? I.e. you click the Get Free License button, the key is generated and successfully written to the Storage and then you get the "Invalid License key" error when trying to apply the key on the remote Host. Correct?

The key should have been sent to your email too (the one you specified when generating the key). Before going further and to exclude some temporary glitch I would recommend to do the following:

1. Generate a new key (you can generate as many as you wish) and specify a correct e-mail address.

2. When you receive an email with your key, and if the error still persists, try to copy the key from the email and paste it in the registration form.

Looking forward to your reply.

Coffmans, User (Posts: 10)

Sep 16, 2013 3:31:04 pm EDT

Support level: Free or trial
I am receiving the error message on both procedures. I generate a new license via the License Key Storage and attempt to license with no success. Upon the failure, I have been trying to copy the license from the email with the same error message.

Perhaps I am not copying the license information correctly. The email has two copies of the license. And I am only copying the actual key portion from the email (ex: RMS-F-1...P) . Is there a specific part of the key that needs to be copied?

Conrad Sallian, Support (Posts: 2591)

Sep 16, 2013 3:39:41 pm EDT

The key for Remote Utilities should start with RUT, not RMS. The RMS prefix is for the Russian version only.

Can you please forward the email message you received to for examination?


Coffmans, User (Posts: 10)

Sep 16, 2013 5:06:19 pm EDT

Support level: Free or trial
Sure thing, I will do it at the first opportunity.

I noticed the documentation showed "RUT..." for the license. I used the License Key Server to generate the key.

Coffmans, User (Posts: 10)

Sep 17, 2013 9:07:06 am EDT

Support level: Free or trial
Thanks for the help, the problem has been solved!

I am not sure how I would have installed the incorrect version but I uninstalled my existing Viewer, downloaded just the Viewer install, re-installed the Viewer, and I was able to license the remote host without any issues.   :)

Conrad Sallian, Support (Posts: 2591)

Sep 17, 2013 10:01:34 am EDT

Great. All well that ends well.  8)

* Website time zone: America/New_York (UTC -5)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.