Community

Black screen on Windows computer when external monitor used

Links used in this discussion

Andy Pilate, User (Posts: 2)

Mar 29, 2020 11:00:48 am EDT

Support level: Free or trial
Hi,

I am having a black screen issue on a Windows (18362) machine. Using Viewer 6.10.10.0 and  Host of the same version
This issue only happens when the computer is using an external monitor (DisplayPort) and has it's main screen off (lid closed). I have not tried with both screens on, since this is a laptop in use and I cannot bother the user much.
Everything worked "fine" before using the external monitor, and no particular change to the machine could be involved.

Installing the display driver (and rebooting) did not change anything. However, using legacy capture mode does bring the screen back. I'm assuming this is not a plan for the long term (being legacy), so I would be interested into having this issue fixed.

The weird thing is that I can still see the screenshots from the machine on the address book.

I am aware that being a free user does not entitle me to any help, and I am very grateful for any help you will provide. Your software really saved me from headaches.

Andy

Polina Krasnoborceva, Support (Posts: 827)

Mar 30, 2020 4:28:01 pm EDT

Hello Andy,

Thank you for your message.

Installing the display driver (and rebooting) did not change anything.

Please note that the Monitor driver is only used for the Blank remote screen feature. In case if you don't use this feature we advise that you uninstall the Monitor driver.

However, using legacy capture mode does bring the screen back. I'm assuming this is not a plan for the long term (being legacy), so I would be interested into having this issue fixed.

Could you please confirm that enabling the Legacy capture mode did resolve the issue?
As for the legacy mode - the difference between the default capture and legacy modes has to do with how the screen capture is processed deep inside the operating system. However, I'll forward your question to our development department and ask for their input on this.

In addition, here's a related troubleshooting KB article that might be useful as well.

Looking forward to your reply.

Andy Pilate, User (Posts: 2)

Mar 30, 2020 7:56:00 pm EDT

Support level: Free or trial

Please note that the Monitor driver  is only used for the  Blank remote screen  feature. In case if you don't use this feature we advise that you  uninstall the Monitor driver .

Oh. Well, I thought it was connected. My bad.

Could you please confirm that enabling the Legacy capture mode did resolve the issue?
As for the legacy mode - the difference between the default capture and legacy modes has to do with how the screen capture is processed deep inside the operating system. However, I'll forward your question to our development department and ask for their input on this.

Legacy mode does resolve the issue. The reason I made this post would be to help your development team fix the issue. I am willing to give you any debug info I can gather if needed.
Let me know if they need more information to reproduce this issue. Thanks

Polina Krasnoborceva, Support (Posts: 827)

Mar 31, 2020 11:08:22 am EDT

Hello Andy,

Thank you for the confirmation.

I'm glad to hear it works for you now!

The reason I made this post would be to help your development team fix the issue. I am willing to give you any debug info I can gather if needed.
Let me know if they need more information to reproduce this issue. Thanks

Thank you for the input! We'll get back to you in case if we need more information.

Please feel free to post another message if you have more questions.

* Website time zone: America/New_York (UTC -4)

This website uses cookies to improve user experience. By using this website you agree to our Terms of Service and Privacy Policy.